Create PSI Extension using Claims based authentication help RRS feed

All replies

  • I am still struggling with Claims based site. Could you please point me if there are any samples or documentation? Please let me know. I have to make my PSI extension to work for Claims based PWA site.

    Monday, March 21, 2011 2:56 PM
  • The blog article you mentioned is updated into several topics in the SDK. See Developing PSI Extensions.

    In Project Server 2010, all authentication is claims-based, including Windows and forms auth. For an example, see Using Forms Authentication and Impersonation in ProjTool. You can get the ProjTool source code in the SDK download. In particular, note:
    "For Forms authentication, ProjTool for Project Server 2010 uses the Authentication web service that is part of Microsoft SharePoint Foundation 2010."

    Although ProjTool doesn't use any PSI extensions, a web app that uses forms auth and accesses a PSI extension should follow the same procedure that ProjTool uses for forms auth, and that the SDK example uses for testing a PSI extension.

    Jim Corbin [MSFT]
    • Proposed as answer by Jim Corbin Tuesday, March 22, 2011 3:32 PM
    Tuesday, March 22, 2011 3:31 PM
  • Thank you Jim. I am testing the code from blog article against my PWA. I followed the document from the article and configured my service.  I also tested the code from ProjTool to use Impersonation. I am getting the following error.

    Protocol Exception "The content type text/html; charset=UTF-8 of the response message does not match the content type of the binding (text/xml; charset=utf-8)."

    Here is the line I am getting the above error message.


    TimesheetListDataSet timesheetList = timesheetExtClient.ReadTimesheetListForCurrentUser(pwaUrl);

    I don't see any errors in ULS logs. Also couldn't hit the breakpoint in WCF. When I change PWA site to use 'Classic Mode Authentication' then the above code works. Thank you for any advice. I am stuck with this error.

    Here is the user I added and provided FullControl to 'Permission for Project server Application'.


    I created a brand new web application in Sharepoint 2010, and specified "Claims-based ..." as the authentication method, with (just) NTLM Windows Authentication enabled and mapped PWA site to this application.

    Tuesday, March 22, 2011 7:47 PM
  • I was debugging the client application using Fiddler for HelloService(PSI extension) from Project SDK I received the following error message at this line.


    Request Headers:

    GET /_login/default.aspx?ReturnUrl=%2f_vti_bin%2fPSI%2fHelloService.svc HTTP/1.1


    No Proxy-Authenticate Header is present.

    No WWW-Authenticate Header is present.

    Wednesday, March 23, 2011 8:41 PM
  • I'm not sure what you mean about mapping PWA to a claims-based web app, or what effect that would have. PWA is already claims-based, and you don't have to do anything about that. Also, WCF and IIS are pretty persnickitty about valid endpoints and double-hops. Why don't you just extend the PSI in the original PWA, and use the extension from there?

    Also, you should be using the sample from the March 7 SDK download, not the sample in the earlier blog. If you have installed a private Project Server hot fix or a recent CU, it is possible that the Timesheet service proxy file (wcf.TimeSheet.cs) or the ProjectServerServices.dll proxy assembly that you compile from the proxy files needs updating. However, that is not likely; a recent check of a pre-release SP1 build shows no changes in the PSI.

    Jim Corbin [MSFT]
    Wednesday, March 23, 2011 10:16 PM
  • Thank you Jim. I downloded new SDK and ran against original PWA. It doesn't work. If I run PSI extension on PWA with Classic Authentication then everything works fine. I am running everthing on my local machine. I am not sure how to fix this problem. I appreciate any suggestions.

    Monday, March 28, 2011 6:18 PM
  • Hello,

    Did you finally find how to do this ?


    Monday, January 28, 2013 11:28 AM
  • Can you provide me the code, may be i can tell whats wrong.

    Thanks, Parth

    Tuesday, January 29, 2013 6:13 AM