Configuration Error - Could not load file or assembly 'Microsoft.ReportViewer.WebForms'


  • I just installed the 2.0 RC version of TeamPlain. When I go to the web access website it throws a configuration exception. It appears that it cannot find the ReportViewer assemblies. Server is Windows server 2003 R2 SP1.


    Server Error in '/' Application.

    Configuration Error

    Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately.

    Parser Error Message: Could not load file or assembly 'Microsoft.ReportViewer.WebForms, Version=, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a' or one of its dependencies. The system cannot find the file specified.

    Source Error:

    Line 73: 
    Line 74: <assemblies>
    Line 75: <add assembly="Microsoft.ReportViewer.WebForms, Version=, Culture=neutral, PublicKeyToken=B03F5F7F11D50A3A"/>
    Line 76: <add assembly="Microsoft.ReportViewer.Common, Version=, Culture=neutral, PublicKeyToken=B03F5F7F11D50A3A"/>
    Line 77: <add assembly="Microsoft.ReportViewer.ProcessingObjectModel, Version=, Culture=neutral, PublicKeyToken=B03F5F7F11D50A3A"/>

    Source File: C:\Program Files\devBiz\TeamPlain Web Access\Web\web.config    Line: 75

    Assembly Load Trace: The following information can be helpful to determine why the assembly 'Microsoft.ReportViewer.WebForms, Version=, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a' could not be loaded.

    WRN: Assembly binding logging is turned OFF.
    To enable assembly bind failure logging, set the registry value [HKLM\Software\Microsoft\Fusion!EnableLog] (DWORD) to 1.
    Note: There is some performance penalty associated with assembly bind failure logging.
    To turn this feature off, remove the registry value [HKLM\Software\Microsoft\Fusion!EnableLog].

    Version Information: Microsoft .NET Framework Version:2.0.50727.42; ASP.NET Version:2.0.50727.210

    Thanks for any help!
    Monday, April 16, 2007 8:26 PM


All replies

  • Hello,


    In my case, our TFS is a dual-server install, and these assemblies do not exist on the Web tier.


    I was able to fix this by copying the assemblies from the Database tier into the GAC of the Web tier.


    After I did that, I noticed that these same reporting assemblies are also located in the \bin folder of the devBiz install folder... not sure why it isn't finding them in that case. You might be able to just register the DLLs by dragging and dropping the relevant .dll files from the \bin folder into c:\windows\assembly folder.


    Anyway, it's working now for me after I did that.


    Good luck!





    Monday, April 16, 2007 9:55 PM
  • Well, I copied the three files into the assembly folder and I still got the same error message. I am now going to try a repair/reinstall.

    Thanks for the idea anyway.
    Tuesday, April 17, 2007 12:10 PM
  • So I commented those three lines out in the web.config file and everything works....except viewing reports. The files are in the GAC, but it still gives me problems when it tries to load them.

    I guess I'm not sure if there were some pre reqs that I missed or something before installing.

    --Any help with this is greatly appreciated.
    Tuesday, April 17, 2007 12:44 PM
  • I'm experiencing the same problem - running without reports for now.
    Wednesday, April 18, 2007 5:55 PM
  • I was able to fix this problem.


    I copied the assemblies from the GAC of the data tier into the GAC of the web tier. The copied assemblies are as follows;

    • Microsoft.ReportViewer.Common
    • Microsoft.ReportViewer.Common.resources
    • Microsoft.ReportViewer.ProcessingObjectModel
    • Microsoft.ReportViewer.WebForms
    • Microsoft.ReportViewer.WebForms.resources
    • Microsoft.ReportViewer.WinForms
    • Microsoft.ReportViewer.WinForms.resources
    Thursday, April 19, 2007 1:16 AM
  • You can download the ReportViewer installer from here:




    Once I installed the library on the server the report pages started to work.



    Thursday, April 19, 2007 3:17 AM
  • I just installed the ReportViewer and now it works!

    Thanks for the solution.
    Thursday, April 19, 2007 12:14 PM
  • Hi,

    Do we need to have a License for using ReportViewer installer. Can someone clear my doubt because I need to install this in Server.


    Monday, April 06, 2009 10:39 AM
  • Thanks. This worked a treat.
    Wednesday, August 05, 2009 5:04 AM
  • We're experiencing the same issue here.  I've downloaded the ReportViewer.exe, and run it on the server.  Initially it wanted me to either repair or uninstall.  I tried repairing, but that didn't work.  Then I uninstalled and reinstalled it, and that still didn't work.  We're still getting the same error as listed at the start of this thread.  This is running on a 64-bit Windows 2003 Server.  Could that make a difference?

    Wednesday, August 26, 2009 4:58 PM
  • I found that I had downloaded and installed the wrong ReportViewer.exe.  What I installed was for VS 2005.  I needed the ReportViewer.exe for VS 2008.  Here's a link with better information.

    Thursday, August 27, 2009 7:23 PM
  • I have a shared server so not able to upload the installer

    Can anyone help me otherwise

    Saturday, January 23, 2010 5:28 PM
  • It worked for me :) thanks
    Monday, November 08, 2010 10:19 PM
  • Another solution if you want to avoid installing s/w on the server or modifying the GAC is to set "CopyLocal" on the referenced Miscroft ReportViewer DLL's in your project.

    For me, I had to also add a direct reference to Microsoft.ReportViewer.Common to the project and also specify "CopyLocal" on it too. (In the project, under references, right-click, select Properties to configure CopyLocal property)

    Then, once the project is redeployed to the server, the reporting DLLs will be included in the bin folder.

    This has the added advantage of working for other developers on other servers without them having to copy the DLL's themselves or install the ReportViewer s/w on the server.




    Thursday, January 27, 2011 3:37 PM
  • For  .NET Framework  4.0  install Microsoft Report Viewer 2010 Redistributable Pacckage


    After installing Report Viewer 2010 report pages started to work.

    Wednesday, March 30, 2011 7:13 AM
  • hi everybody,

    i have iis6.1 and i want to host my program in iis 5.1 .i have got the same error as

    "<add assembly="Microsoft.ReportViewer.WebForms, Version=, Culture=neutral, PublicKeyToken=B03F5F7F11D50A3A" />

    Friday, April 29, 2011 7:07 AM
  • This worked perfect for me.  I had to find the one for 2010 though and install it on Win 2008r2 server. 


    Tuesday, September 20, 2011 5:11 PM
  • In my case I had the same error message.
    The problem was in the version of the assembly:
    "Microsoft.ReportViewer.ProcessingObjectModel, Version ="

    I published the site on a Windows Server 2003 R2 with IIS 6.0
    and migrated the application to a Windows 2008R2 server with IIS 7.0
    and the version of this assembly had changed.

    Check on your server in the folder C: \ Windows \ assembly
    and see which version your Microsoft.ReportViewer.ProcessingObjectModel
    Tuesday, November 27, 2012 1:23 PM
  • I checked the assembly folder and found 8.0 and 10.0 version but not 9.0 version which my application requires.

    I am using VS2010 on Win server 2003 R2 development machine. Could you please help me locate the exact ReportViewer.exe?


    Tuesday, November 27, 2012 8:59 PM
  • I found the correct ReportViewer.exe for me. The issue for me was for MS Dynamics CRM Report Viewer.


    when I install the above link's ReportViewer then I could see the correct version (9.0.0) at c:\windows\assembly. It works fine now.


    Tuesday, November 27, 2012 9:18 PM