locked
How can I fix V-Studio wont run my unit test RRS feed

  • Question

  • Good Day,

    AS I remember I can run and see results of my unit test in my V-Studio, but lately it will not continue to run my unit test, Iam not sure if I did some changes on my VS Studio, but it just keeps on loading.

    please see image attached:


    Does anyone have a solution on what I can do to fix this?

    Note: Iam using MSTest, It occurs on both my V-Studio 2015 & 2017, Enterprise Edition
    And even I run my test on Resharper it is just Pending

    Here is the error:
    Error DEP3000 : Attempts to stop the application failed. This may cause the deployment to fail. 
    Exception from HRESULT: 0x92330047

    Thanks

    Thursday, January 18, 2018 1:21 AM

Answers

  • Found a solution, just run this on command prompt:
    CheckNetIsolation.exe LoopbackExempt -c
    For more info , check this article: https://developercommunity.visualstudio.com/content/problem/153784/unit-tests-to-not-execute-for-uwp-application.html
    • Marked as answer by NicoTing Wednesday, February 7, 2018 2:40 AM
    Wednesday, February 7, 2018 2:40 AM

All replies

  • I'm afraid it's caused by Resharper. You may try to update Resharper to it's newest version.

     To confirm this, you could create a fresh new unit test in Visual Studio and see. Or disable Resharper extension.

    If the issue still persists(not caused by Resharper), please share us a sample of your test script and let us know the specific Version of your Visual Studio(The latest VS2015 is with update3, and VS2017 is 15.5.4.), then we will try to reproduce it in our side and help you out.

     

    Regards,

    Fletcher


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.


    • Edited by Fletch Zhou Friday, January 19, 2018 2:15 AM
    • Proposed as answer by Fletch Zhou Tuesday, January 23, 2018 9:19 AM
    Friday, January 19, 2018 2:15 AM
  • Found a solution, just run this on command prompt:
    CheckNetIsolation.exe LoopbackExempt -c
    For more info , check this article: https://developercommunity.visualstudio.com/content/problem/153784/unit-tests-to-not-execute-for-uwp-application.html
    • Marked as answer by NicoTing Wednesday, February 7, 2018 2:40 AM
    Wednesday, February 7, 2018 2:40 AM