none
IMFActivate::ActivateObjet return e_accessdenied if the avstream driver is not installed as legacy hardware RRS feed

  • Question

  • I'm developing avstream driver for windows 8 and 8.1

    If the driver is installed as acpi driver, the camera application will fail when calling IMFActivate::ActivateObjet(IMFMediaSource) which returns e_accessdenied, while it succeeds and works properly if the driver is installed as legacy hardware.

    May you please help solving this issue?

    Thanks

    Nael

    Wednesday, October 29, 2014 5:52 PM

All replies

  • the ACPI PDO could have a default security descriptor that is different than the root bus (which doesn't have one at all). try setting the device security in your INF

    d -- This posting is provided "AS IS" with no warranties, and confers no rights.

    Wednesday, October 29, 2014 6:36 PM
  • I tried using Microsoft Camera metro application, there was no e_accessdenied error and the application worked fine.

    My question is, can I set security issue in the application and not change the driver security settings?

    Thanks

    Nael

    Wednesday, October 29, 2014 9:40 PM