locked
msbuild /p:platform:x64 finishes with error VCBLD0004: Project does not contain a configuration called 'Release|x64' RRS feed

  • Question

  • Hi,

    I've searched forum for answer, but all that I found, didn't work in my case.  I try to build my project on 64-bit Windows 2003 machine with VS 2008 installed.

    I'm calling command :

    msbuild myProject.sln /t:rebuild /p:Configuration=Release,Platform=x64

    when I do this I got error:

    vcbuild.exe : error VCBLD0004: Project '<some_location>\myProject.vcproj' does not contain a configuration called 'Release|x64'.

    the same command processed on other machines works ok. I'm bit confused.

    Tuesday, February 16, 2010 5:09 PM

Answers

  • Hi Tommi.best,

    I think this issue is caused by not installed x64 compiler and tools in your machine.

    Have you installed x64 compiler and tools in your machine when you install Visual Studio 2008? If not, This feature is available in the Visual Studio 2008 setup UI under the Visual C++ language tools node, but it is unchecked by default.  If you performed a default install of Visual Studio 2008, you will need to go to Add/Remove Programs, enter Visual Studio 2008 setup maintenance mode and add the x64 compilers and tools feature.

    If you have installed x64, make sure you intalled correctly.VS (and with it the x64 compilers and tools) was installed after the SDK. Had to uninstall and reinstall the SDK, then run a repair on it, then everything works fine.

    Best Regards,
    Nancy
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Welcome to the All-In-One Code Framework! If you have any feedback, please tell us.
    • Marked as answer by Nancy Shao Monday, March 1, 2010 6:24 AM
    Tuesday, February 23, 2010 8:22 AM

All replies

  • Hi tommi.best,

    Before you can build an x64 platform application, you must add the build configuration targeting x64 platform to your solution. you can do this from the Build->Configuration Manager:

         open the Configuration Manager;
         drop down and select <New> in the "Active solution platform"
         in the "New Solution Platform" dialog, select x64 from the dropdown list for the new platform, and make sure you select Copy settings from Win32

    Once the x64 platform configuration is added for release (debug), you can build you solution against release|x64 or debug|x64

    Hope this help
    Daofa Li, MSFT
    Tuesday, February 16, 2010 10:18 PM
  • Hi Daofa LI,

    Unfortunately, that was the first thing that I've checked, and all platforms are on their place (I build this solution against release|Win32 as well, and it works ok). When I build the same solution on Windows XP 32-Bit everything works fine (against both Win32 and x64).


    Wednesday, February 17, 2010 6:16 AM
  • Hi Tommi.best,

    I think this issue is caused by not installed x64 compiler and tools in your machine.

    Have you installed x64 compiler and tools in your machine when you install Visual Studio 2008? If not, This feature is available in the Visual Studio 2008 setup UI under the Visual C++ language tools node, but it is unchecked by default.  If you performed a default install of Visual Studio 2008, you will need to go to Add/Remove Programs, enter Visual Studio 2008 setup maintenance mode and add the x64 compilers and tools feature.

    If you have installed x64, make sure you intalled correctly.VS (and with it the x64 compilers and tools) was installed after the SDK. Had to uninstall and reinstall the SDK, then run a repair on it, then everything works fine.

    Best Regards,
    Nancy
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Welcome to the All-In-One Code Framework! If you have any feedback, please tell us.
    • Marked as answer by Nancy Shao Monday, March 1, 2010 6:24 AM
    Tuesday, February 23, 2010 8:22 AM