locked
Problem Loading Designer in Metro UI

    Question

  • Hi ,

    This starts to become very annoying . I have installed in Virtual Box VS2012 (windows 8 RC). I started to build a Metro UI APP using C# but I got stuck in a huge problem.

    I remember I faced that problem using Silverlight but after building the solution it was fixed.

    My problem here is that I CANNOT in ANYWAY load the Designer.  Even If I try to add a blank page with nothing in it I get the same exact error ,

    System.Runtime.Remoting.RemotingException
    [856] Designer process terminated unexpectedly!(The error code between the brackets differs from time to time.)

    or I get the XAML Designer is not working , do you want me to send the bug to Microsoft etc..?

    Also I don't know if it is much of a help the Main Page is at the root of my APP and the rest were added in a directory.

    Any help would be mostly appreciated.

    thank you

    Thursday, August 2, 2012 5:44 AM

Answers

  • Hi  and thank you for your answer,

    Not outside. Everything is installed inside. But I found a solution . If I create a directory in my solution let's say a folder named  VIEWS and add the page there , the designer is not loading. Whatever I do. Build,rebuild ,run ,deploy...

    If I add the page in the root(where the MainPage.xaml lies) of My solution then I'm OK. 

    So , I don't think that it has to do with the Virtual Box. Something's running behind the scenes , references or something ... and causes the problem.

    Perhaps Microsoft must take a look at it because when they release the final product on October , I don't think that the developers would like this situation. 

    Of course this is not the best solution because I want my pages to be organized in folders but I can live  with that for NOW. Not forever. Just now. 

    thank you

    • Marked as answer by zakkar Friday, August 3, 2012 4:37 AM
    Friday, August 3, 2012 4:37 AM

All replies

  • Hi,

    Does it happen outside on Virtual Box? Seems like someone reported the issue at http://connectppe.microsoft.com/VisualStudio/feedback/details/738734/system-runtime-remoting-remotingexception

    -Sagar

    Thursday, August 2, 2012 7:22 AM
    Moderator
  • Hi  and thank you for your answer,

    Not outside. Everything is installed inside. But I found a solution . If I create a directory in my solution let's say a folder named  VIEWS and add the page there , the designer is not loading. Whatever I do. Build,rebuild ,run ,deploy...

    If I add the page in the root(where the MainPage.xaml lies) of My solution then I'm OK. 

    So , I don't think that it has to do with the Virtual Box. Something's running behind the scenes , references or something ... and causes the problem.

    Perhaps Microsoft must take a look at it because when they release the final product on October , I don't think that the developers would like this situation. 

    Of course this is not the best solution because I want my pages to be organized in folders but I can live  with that for NOW. Not forever. Just now. 

    thank you

    • Marked as answer by zakkar Friday, August 3, 2012 4:37 AM
    Friday, August 3, 2012 4:37 AM
  • Uninstalling VirtualBox Guest Additions fixed the problem for me!

    Friday, August 3, 2012 11:16 AM