none
How to specify Affiliate application to SAP receive location? RRS feed

  • Question

  • How to specify Affiliate application to SAP receive location?

    There is no field "Affiliate application"...

     

    BR,

    Vaidotas

     

     

    Tuesday, November 4, 2008 11:59 AM

Answers

  • I think there is some confusion here. If you are using the new WCF based SAP Adapter which is a part of the BizTalk Adapter Pack, you don't need to create a port before generating schemas. For working with the new Adapter you need to choose Add Generated Items > Consume Adapter Service from the VS and not Add Generated Items > Add Adapter Metadata.

     

    SSO is not Supported at Design Time for the Adapters in BizTalk Adapter Pack (That is, while generating schemas for your project).

     

    SSO is supported at runtime though. Here's where you'll find it:

    1) On the Send Port Properties dialog choose WCF Custom Adapter

    2) Click on Properties (this will open WCF-Custom Transport Properties dialog)

    3) Go to Credentials tab. Here you'll find the option to use SSO as well as for selecting Affiliate Application

     

    Let me know if this doesn't help.

     

     

    Friday, November 7, 2008 12:41 PM

All replies

  • Are you refering to the SAP adapter in the BizTalk Adapter Pack?

     

    Wednesday, November 5, 2008 12:21 PM
  •  

    Yes, I do. I also have problems using SSO and Send-Receive SAP port. I sellect my created affiliate application in port and leave username and password blank. then I try to Generate XML schema using Visual Studio and this port I get error message "Incomplete logon data.". I configure sso affiliate application with default application fields "User ID" and "Password". In general is it posible to use SSO with SAP adapter???

     

    BR,

    Vaidotas

    Wednesday, November 5, 2008 12:28 PM
  • I think there is some confusion here. If you are using the new WCF based SAP Adapter which is a part of the BizTalk Adapter Pack, you don't need to create a port before generating schemas. For working with the new Adapter you need to choose Add Generated Items > Consume Adapter Service from the VS and not Add Generated Items > Add Adapter Metadata.

     

    SSO is not Supported at Design Time for the Adapters in BizTalk Adapter Pack (That is, while generating schemas for your project).

     

    SSO is supported at runtime though. Here's where you'll find it:

    1) On the Send Port Properties dialog choose WCF Custom Adapter

    2) Click on Properties (this will open WCF-Custom Transport Properties dialog)

    3) Go to Credentials tab. Here you'll find the option to use SSO as well as for selecting Affiliate Application

     

    Let me know if this doesn't help.

     

     

    Friday, November 7, 2008 12:41 PM