locked
Enable and disable websync.log RRS feed

  • Question

  • Hi, is there a way how to enable / disable logging on web merge synchronization into the file websync.log? The file exists in the ISAPI folder, on some machines there are some messages, on others there is nothing. There are Timeout messages on the client during synchronization and we need to find where is the problem, if it is on the server side or if it is a network error or something else.
    Thanks, Pavel
    Tuesday, January 9, 2007 10:41 AM

Answers

  • I dont know how you got into this situation, but here is what you can try:

    Check if you have this key in your registry:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Microsoft SQL Server\90\Replication\WebSyncLoggingOff

    Is this value 1?

    If it is, reset it to 0. Then do iisreset.

    That should solve your problem

    Tuesday, January 16, 2007 10:51 PM

All replies

  • The web sync log should be enabled by default.

    On the IE replisapi.dll?diag page, what do you see the status as?

    ReplIsapi Settings:

    Property Value
    SNAC version (sqlncli.dll) 2005.90.1399.0
    Logging Enabled TRUE
    Log Severity 2
    Current Log Size 673542
    Maximum Log Size 10485760
    Log FileName websync.log
    Log Dir D:\myVirtualDirectory

    Wednesday, January 10, 2007 6:57 PM
  • ReplIsapi Settings:

    Property Value
    SNAC version (sqlncli.dll) 2005.90.1399.0
    Logging Enabled FALSE
    Wednesday, January 10, 2007 8:08 PM
  • Can you create a new virtual directory and try with that?

    Also how did you come into this situation. Did anything change after you created the virtual directory.

    Friday, January 12, 2007 6:59 AM
  • Yes, I have tried to create virtual directory few times and nothing has changed. I can't realize any change on the server, which could switch off logging.

    Another thing is, that we need to monitor production system in which we cannot change virtual directory. In the test enviroment we have not any problems.

    Friday, January 12, 2007 7:13 AM
  • What about uninstalling and reinstalling the IIS side repl components?  Could you try that?
    Friday, January 12, 2007 7:19 AM
  • That's problem, It's production in which a thousands of subscribers are synchronizing and we cannot stop the system. All is working fine, but sometimes, say 1 day in months, there is problem with timeouts on some subscribers and the problem can be repeated on the client side in that moment. So we would like to enable logging in that moment to say, that the timeout is or is not on the server.
    Friday, January 12, 2007 7:30 AM
  • I dont know how you got into this situation, but here is what you can try:

    Check if you have this key in your registry:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Microsoft SQL Server\90\Replication\WebSyncLoggingOff

    Is this value 1?

    If it is, reset it to 0. Then do iisreset.

    That should solve your problem

    Tuesday, January 16, 2007 10:51 PM