locked
Refresh on Tabular Cube RRS feed

  • Question

  • Could someone help with this update issue, please?  For some reason, my Tabular Cube "connected via Excel" just won't have the latest data after myTabuCube is processed.

    I have deployed myTabuCube from BIDS to my tabular model.

    myTabuCube is based on data from one select statement from one table1 in SQL Server.  After the table1 is update, I successfully full process my myTabuCube using SSIS.  The Last Schema Update reflect the latest processing date/time.  But...  :)

    When I launch excel and connect to myTabuCube, it doesn't have the correct number of rows.  Opening BIDS doing Model|Process|Process All gets the latest data in myTabuCube.  But, this latest data doesn't get to the myTabuCube.  I've tried Deploying it, the Deploy was a success with the latest number of rows. Still, myTabuCube doesn't have the latest.

    Right click the myTabuCube and process full in SSMS doesn't update on my excel connection to it either.

    Changed processing from default to FULL in BIDS or SSMS doesn't correct it.

    script out the existing myTabuCube via SSMS, del the old myTabuCube, rename the myTabuCube name in script, confirm the sql select statement, in <QueryDefinition>, is correct and latest, create a  myNewTabuCube based on that.  process myNewTabuCube in full.  still doesn't update myNewTabuCube with correct records.

    I've checkout Cathy doc; but no resolutions. inhttp://connect.microsoft.com/SQLServer/feedback/details/685325/processing-ssas-in-tabular-mode-not-refreshing-data

    What am I missing?

    Thanks.
    • Edited by light_wt Wednesday, October 9, 2013 3:28 PM
    Tuesday, October 8, 2013 10:13 PM

Answers

All replies

  • The only solution I have which isn't practical... rebuild a new Tabu Solution and deploy it as a new Cube.

    I hope someone could point out what I am missing to get automatic refresh via BIDS and SSIS work.


    -- IBM has jobs for USA employee to work oversea (India) and get their wages.


    • Edited by light_wt Wednesday, October 9, 2013 5:46 PM
    Wednesday, October 9, 2013 4:36 PM
  • Hi light_wt,

    We can use the Table Properties to determine when the data was last refreshed. Please refer to the steps below:

    1. In the model designer, select the table that contains the data for which you want to know the refresh date.
    2. Click on the Table menu, and then click Table Properties.
    3. In the Edit Table Properties dialog box, Last Refreshed shows the last date that the table was refreshed.
      Note: We can also check the process status of partitions.

    Please refer to the following article to manually process data:
    http://technet.microsoft.com/en-us/library/gg492128.aspx

    If the "Last processed" property show the latest date time but the data not updated, please install the latest Service Pack and CU for SQL Server 2012 to see if this help.

    Regards,


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time.
    Thanks for helping make community forums a great place.

    • Marked as answer by Elvis Long Monday, November 4, 2013 2:53 AM
    Tuesday, October 15, 2013 5:43 AM
  • Hi

    i have Tabular cube refresh problem ,please help me

    problem Description : Tabular cube is refreshing the data when i chosse FullRefresh not refreshing through option "Process Default"

    but i would like to achive dynamica refresh\Delta load .

    if i have used the "Process Default" ,updated data i data source is not refreshing ,

    please suggest what could be the reason and solution

    note :in tabular  model cube i had all views  to build the cube

    Thanks

    Ram

    Friday, October 18, 2013 9:34 AM