none
localhost can't be reached RRS feed

  • Question

  • Hi All.

    In my Windows 10 Enterprise PC I setup IIS and create first web application project. When VS 2017 created solution I clicked IIS Express button to open localhost site. But unfortunately got such message in the Chrome browser:

    In Chrome in flag:
    chrome://flags/#allow-insecure-localhost I set up Allow invalid certificates for resources loaded from localhost. like Enabled.

    I don't have problem to open localhost when I selected IE or Edge. How to fix the problem?

    Thanks.



    • Edited by zleug Saturday, August 10, 2019 4:46 PM
    Friday, August 9, 2019 4:18 PM

All replies

  • Hi zleug,

    Sorry for delay in reply.

    From your description, the localhost site seems to be wrong, it should be like "https://localhost:44340/xx.aspx".

    Please try to set "IIS express(Google Chrome)", then rebuild this project, and try to debug it again.

    If it persists, please try to press "Start without debugging" under Debug menu.

    BTW, if you have other issue about IIS, we recommend you could redirect to IIS forum for dedicate support.

    Any feedback will be expected.

    Best Regards,

    Dylan


    MSDN Community Support Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com


    Monday, August 12, 2019 7:02 AM
  • Hi Dylan. Thanks for reply.

    Can you detail explain how to set "IIS express (Google Chrome)"?

    Thakns.

    Monday, August 12, 2019 1:17 PM
  • Hi zleug,

    Thank you for reply.

    Please refer the below image to set "IIS express(Google Chrome)" :

    Best Regards,

    Dylan


    MSDN Community Support Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com

    Tuesday, August 13, 2019 1:53 AM
  • That is exactly like when I set on the my computer Google Chrome and click on IIS Express button I got the message that I first time posted. When set Internet Explorer or Microsoft Edge I don't have the problem to open localhost site.
    Tuesday, August 13, 2019 2:01 PM
  • Hi zleug,

    Thank you for reply.

    Please have a try to below steps:

    -open "chrome://net-internals/#dns", clear the dns cache

    -open "chrome://net-internals/#hsts", under "Delete domain security policies", type "localhost", then click delete

    If it persists, we recommend you could redirect to stack overflow with google-chrome tag, since our forum is discussing about usage tool for VS IDE, and it seems to be beyond our support, you could get better support there.

    Thank you for understanding.

    Best Regards,

    Dylan


    MSDN Community Support Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com

    Wednesday, August 14, 2019 4:01 AM
  • Hi zleug,

    It seems that there is a problem in your Google Chrome since IE and Edge does work. Did you install some other google extensions? 

    >>In addition to Dylan's suggestions, we recommend that you delete the cache and cookies of the web browser or check with a different one.

    Or if you are using any antivirus, please disable it for a while for testing purpose.


    BTW, l have found more information for you:

    https://windowsreport.com/the-webpage-might-be-temporarily-down-or-it-may-have-moved-permanently/

    Note: This response contains a reference to a third-party World Wide Web site. Microsoft is providing this information as a convenience to you. 

    Microsoft does not control these sites and has not tested any software or information found on these sites; Therefore, Microsoft cannot make any representations regarding the quality, safety, or suitability of any software or information found there.

    There are inherent dangers in the use of any software found on the Internet, and Microsoft cautions you to make sure that you completely understand the risk before retrieving any software from the Internet

    Best Regards,

    Perry


    MSDN Community Support Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com


    Wednesday, August 14, 2019 10:12 AM