locked
Poll_List and Poll_View RRS feed

  • Question

  • User2068891794 posted

    Hi all,

    I have installed the poll on my site but I have got two problems. I am using VB.Net and SQL Server 2005.

    Poll works fine apart from the Poll_view doesnt show the reactions and Poll_View doesnt show the list of polls?

    i know there is no data sorce on these pages? I think I may have to add these but tried that and think my SQL statements are incorrect. 

    Any ideas? is it because Im using VB.NET. I can manage polls as administrator okay and vote in polls etc?
    Thursday, October 12, 2006 4:50 AM

All replies

  • User706866991 posted
    I am experiencing the same issue.  What version are you running?
    Friday, October 13, 2006 5:04 PM
  • User2068891794 posted

    I think its VERSION 1.0.4.. I set up my own datasource and SQl querires but if you look in the aspx files, they look for a created by field and the SQL tables dont have a createdBy field. This is taken from poll_list.aspx

     

    <asp:LinkButton ID="PollLink" runat="server" OnClick="PollLink_Click" CommandArgument='<%# Eval("PollId") %>' Text='<%# Eval("Question") %>'></asp:LinkButton>
                        (by <%# Eval("CreatedBy") %>, on <%#  Eval("CreationDate") %>)
      

    I think if you get the correct SQL Query syntax you'll work it fine. Am still working on it.

     

    Could anyone help us out here? 

    Monday, October 16, 2006 4:30 AM
  • User-813531518 posted

    Hi - I have the same problem. I found out that the query have a problem to match the member id's. So I changed the following statement in PollData.xsd from inner join to left outer join. Now the query find all Questions, but the CREATEDBY column only find the value NULL.

    <CommandText>SELECT p.PollId, p.Question, p.CreationDate, m.firstname + ' ' + m.lastname AS CREATEDBY
    FROM PollQuestions AS p LEFT OUTER JOIN
    MemberInfo AS m ON m.memberid = p.memberid
    </CommandText>

    I also removed the "CreatedBy" statement in the poll_list.aspx

    <asp:LinkButton ID="PollLink" runat="server" OnClick="PollLink_Click" CommandArgument='<%# Eval("PollId") %>' Text='<%# Eval("Question") %>'></asp:LinkButton>
                        (on <%#  Eval("CreationDate") %>)

    Now the List display only the Questions and the Creation date. Hope you can use this info.

    Greetings from Austria
    Christian 

     
     
    Wednesday, December 27, 2006 9:40 AM
  • User1275632693 posted

    Is this a new feature on one of the extended Kit versions?

     Don't remember seeing anything about polls in the current version.

     

    Thursday, December 28, 2006 7:49 AM
  • User-813531518 posted

    Is this a new feature on one of the extended Kit versions?

    No it is not a new feature! I think there is a problem with the club.mdf if a copy is used (the member id do not match with the user id in the poll tables). It is not the best solution, but it works.

    There is also a problem with reactions: If a administrator make a reaction post, it will not be displayed (but it will be counted). I think it is also a problem with the member id.

    I am going to try a new club.mdf, if then the problems disappear I will report it here.

    I also tried the Poll with an extended Kit, but it does not work good. It works on the Homepage (Startpage), but the Poll_View (if you click on reaction or all polls) dont use the right css file. The formating is not ok.

    Don't remember seeing anything about polls in the current version.

    What do you mean, I found no solution for this problems in the forum.

    Grettings CA

    Thursday, December 28, 2006 8:20 AM
  • User1275632693 posted

     Ok ,

     I must be missing something here, where is the poll functionality in the Club Site Starter kit.

    Can you list a url showing the csk with that functionality in place?

     

    Thursday, December 28, 2006 11:01 AM
  • User-813531518 posted

    You can can try my side here (is only a testaccount - do you know a good provider?) http://isee-5.at.vwdhosting.net/ 

    Btw: I changed the values of the column memberid in the table dbo.MemberInfo to the same values as stored in the column UserId  in the table dbo.aspnet_Users - and the problem has gone away [:D]

    Friday, December 29, 2006 6:21 AM
  • User523970105 posted

    Is this a new feature on one of the extended Kit versions?

     Don't remember seeing anything about polls in the current version.

     

    It is an add-on to the original club site.  I think that the original thread about it is this one: http://forums.asp.net/thread/1380176.aspx.

     

    Friday, December 29, 2006 9:42 AM