locked
The 'User Identity' property name is not formatted correctly. RRS feed

  • Question

  • I am trying to create a BI synmantic model for powerview connection but I am getting this error

    I didn't find anything meaningfull on searching the web. Has anyone faced this before?


    val it: unit=()

    Sunday, September 29, 2013 2:21 AM

All replies

  • Hi MSDN Student,

    The "User Name" must use slash instead of back-slash to separate the domain and user name. It is domain/username.

    Thanks,
    Jinchun Chen


    Jinchun Chen(JC)
    TechNet Community Support

    Tuesday, October 1, 2013 6:24 AM
    Moderator
  • Uh... really? I have been using "domain\user" since forever and it has always worked for me.

    infact the domain/user will never work and will always say that credentials are incorrect when as-a-matter-of-fact they are indeed the correct credentials.


    val it: unit=()

    Tuesday, October 1, 2013 2:52 PM
  • Hi MSDN Student,

    I apologize.You are right, it must be "\".

    Is the SQL Server 2012 Reporting Services (SSRS) add-in for SharePoint installed? It is required in this case.
    Also, could you please share me the detailed steps you are using to create the data source?

    For detailed on how to create a connection to a data model for Power View, please see:
    http://office.microsoft.com/en-in/excel-help/create-a-connection-to-a-data-model-for-power-view-HA102835737.aspx#_Create_a_shared

    Thanks,
    Jinchun Chen


    Jinchun Chen(JC)
    TechNet Community Support

    Wednesday, October 2, 2013 8:09 AM
    Moderator
  • yes. ssrs addin is installed and I can run powerview and ssrs reports without any problem.

    But when I follow the instructions in the tutorial and point the BISM data source to Excel (as specified in the tutorial), I get the error I have shown above.


    val it: unit=()

    Wednesday, October 2, 2013 2:33 PM
  • This error is related to the format of the connection string. For example the name property

    Therefore you have to write the "Data Source=" before your document link. 

    => Data Source="Insert Web link"

    The BISM connection string is quite particular. Hope that helps. 

    Cheers, 

    Kesh

    • Proposed as answer by Dan English Wednesday, February 26, 2014 12:32 PM
    Wednesday, February 26, 2014 10:09 AM