none
.Net 3.5 SP1 Setup Error in Win XP SP3? RRS feed

  • Question

  • I have tried to install the .Net frame work 3.5 sp1 (full package) in my laptop and I got the set up error. (Os Windows XP SP3)

    There is no error message, the setup screen just goes blank, and at the very top it says "setup error" , with no further options besides to close the window.

    See the below screen shots.

    Allready I have installed  the same setup with succesful. Last week I have uninstalled the .net 3.5 sp1 for some case.

    Now I need to install .Net 3.5 SP1, but I got the above error.

    what can I do?


    If a post answers your question, please click "Mark As Answer" on that post and "Mark as Helpful"

    Monday, June 4, 2012 7:41 AM

Answers

  • The issue is that you have .NET Framework 3.5 SP1 installed, but it is corrupt.

    From the tool output:

    "****ERROR**** Verification failed for product .NET Framework 3.5 SP1"

    I suggest you uninstall .NET Frameworks 3.5, 3.0 and 2.0 in that order, then reinstall using the same download:

     .NET Framework 3.5 Service Pack 1 (Full Package

    • Marked as answer by P Elayaraja Monday, June 11, 2012 12:32 PM
    Saturday, June 9, 2012 8:01 PM
  • Thnks for your information..
    I didnot found the .NEt 3.5 SP1 installation in COntrol panel Add or Remove programs.

    So I take some risk aow and I have delete the .Net Framework registry files from HKLM, HKCR and HKCU. Finally I have restart my lap and Again I have installed the .net 3.5 SP1 and I got the success now..


    If a post answers your question, please click "Mark As Answer" on that post and "Mark as Helpful"

    • Marked as answer by P Elayaraja Monday, June 11, 2012 12:32 PM
    Monday, June 11, 2012 12:32 PM

All replies

  • Supply complete install logs as follows:

    Please collect your install logs with this:

    http://www.microsoft.com/downloads/details.aspx?FamilyID=E0DA314F-6216-4A18-BC6B-7D29CF83AF20&displaylang=e&displaylang=en

    After you run Collect.exe, you'll find vslogs.cab in your %temp% directory. Please upload vslogs.cab to a public site, like SkyDrive, and post the link here.

    Monday, June 4, 2012 3:27 PM
  • Hi, Sorry for the late..

    download my vslog here

    Pls help me, 

    I am waited here for your reply..


    If a post answers your question, please click "Mark As Answer" on that post and "Mark as Helpful"

    Friday, June 8, 2012 4:38 PM
  • Please put your vslogs.cab on a site that does not insist I download "download managers" or other unwanted software to get your file.

    Friday, June 8, 2012 8:04 PM
  • I have used now SKYdrive..

    Click here


    If a post answers your question, please click "Mark As Answer" on that post and "Mark as Helpful"

    Saturday, June 9, 2012 1:47 AM
  • Examining your vslogs, it appears the .NET Framework 3.5 installation never started.

    Please show the link to the 3.5 you downloaded and tried to install.

    Also, please run this verification tool:

    http://blogs.msdn.com/b/astebner/archive/2008/10/13/8999004.aspx

    Post the first 15 lines and last 15 lines of tool output here.

    With that information, I hope to be able to suggest steps to solve your problem.

    Saturday, June 9, 2012 1:22 PM
  • I have downloaded from this link  .NET Framework 3.5 Service Pack 1 (Full Package).

    I have added my verification tools error logs here..

    setupverifier_errors_06-10-12_21.57.27

    setupverifier_main_06-10-12_21.57.27

    Pls help me.. I m waited here for your reply..


    If a post answers your question, please click "Mark As Answer" on that post and "Mark as Helpful"

    Saturday, June 9, 2012 4:40 PM
  • The issue is that you have .NET Framework 3.5 SP1 installed, but it is corrupt.

    From the tool output:

    "****ERROR**** Verification failed for product .NET Framework 3.5 SP1"

    I suggest you uninstall .NET Frameworks 3.5, 3.0 and 2.0 in that order, then reinstall using the same download:

     .NET Framework 3.5 Service Pack 1 (Full Package

    • Marked as answer by P Elayaraja Monday, June 11, 2012 12:32 PM
    Saturday, June 9, 2012 8:01 PM
  • Thnks for your information..
    I didnot found the .NEt 3.5 SP1 installation in COntrol panel Add or Remove programs.

    So I take some risk aow and I have delete the .Net Framework registry files from HKLM, HKCR and HKCU. Finally I have restart my lap and Again I have installed the .net 3.5 SP1 and I got the success now..


    If a post answers your question, please click "Mark As Answer" on that post and "Mark as Helpful"

    • Marked as answer by P Elayaraja Monday, June 11, 2012 12:32 PM
    Monday, June 11, 2012 12:32 PM
  • I solutioned this with this information:

    https://blogs.msdn.microsoft.com/astebner/2008/03/07/updated-what-to-do-if-other-net-framework-setup-troubleshooting-steps-do-not-help/

    https://blogs.msdn.microsoft.com/astebner/2008/08/28/net-framework-cleanup-tool-users-guide/

    =======================================

    If this pages dissapear, I make a copy here:

    http://www.astrodreams.com/NET_FrameWork_Problems/Updated _what_to_do_if_other_NET_Framework_setup_troubleshooting_steps_do_not_help_–_Aaron_Stebners_WebLog.mht

    http://www.astrodreams.com/NET_FrameWork_Problems/NET_Framework_Cleanup_Tool_Users_Guide_–_Aaron_Stebners_WebLog.mht

    If the Link to dotnetfx_cleanup_tool fail, I make also a Copy:
    http://www.astrodreams.com/NET_FrameWork_Problems/dotnetfx_cleanup_tool.zip

    =======================================

    ////////////////
    I SOLUTIONED DOING THIS IN MY WINDOWS XP - I HAVE VARIOUS WINDOWS IN MY PC AND XP FOR MY WORK VERY GOOD AND HAVE MANY PROGRAMAS INSTALLED -:

    I run the [url=http://www.astrodreams.com/NET_FrameWork_Problems/dotnetfx_cleanup_tool.zip]dotnetfx_cleanup_tool[/url], and reinit windows, and install NET framework 3.5 and 4.0, and all OK!!!

    NET Framework 3.5 Install the 2 Version of NET Framework

    Here a copy of Net Frame Works 3.5 and 4, full:
    http://www.astrodreams.com/NET_FrameWork_Problems/dotnetfx35.exe
    http://www.astrodreams.com/NET_FrameWork_Problems/dotNetFx40_Full_x86_x64.exe
    ////////////////

    Good day...
    Monday, August 27, 2018 8:58 AM