none
[PHP][Web Apps] Trouble installing demo Wordpress Theme RRS feed

Answers

  • By default on Azure, the upload_max_filesize is set to 8M, we can change the built-in PHP configurations to enlarge it.

    Here are the steps:

    1, Add a .user.ini file to your root directory.

    2, Add configuration settings to the .user.ini file using the same syntax you would use in a php.ini file. With your demand, your .user.ini file would contain this text:

    upload_max_filesize = 20M
    ; Maximum size of POST data that PHP will accept.
    post_max_size = 20M
    max_execution_time = 300

    3, Deploy your web app.

    4, Restart the web app.

    You can read official guide for more information.

    By the way, we can use FTP tool to connect your Azure Web sites server to create and modify the custom configuration file instead of redeploying the project.

    The default root directory is D:\home\site\wwwroot.

    Tuesday, February 9, 2016 1:50 AM
    Moderator

All replies

  • Hi,

    I went through https://wordpress.org/support/topic/increasing-memory-allocated-to-php-1 and it suggests three. 

    1. If you have access to your PHP.ini file, change the line in PHP.ini
    If your line shows 32M try 64M:
    memory_limit = 64M ; Maximum amount of memory a script may consume (64MB)

    2. If you don't have access to PHP.ini try adding this to an .htaccess file:
    php_value memory_limit 64M

    3. Try adding this line to your wp-config.php file:
    Increasing memory allocated to PHP
    define('WP_MEMORY_LIMIT', '64M');

    4. Talk to your host.

    Try out option three by opening your files through ftp client. Let's check on other options if it fails. 


    http://jsuhail.blogspot.com
    http://twitter.com/jsuhail
    http://www.linkedin.com/in/jsuhail

    Friday, February 5, 2016 5:27 AM
  • By default on Azure, the upload_max_filesize is set to 8M, we can change the built-in PHP configurations to enlarge it.

    Here are the steps:

    1, Add a .user.ini file to your root directory.

    2, Add configuration settings to the .user.ini file using the same syntax you would use in a php.ini file. With your demand, your .user.ini file would contain this text:

    upload_max_filesize = 20M
    ; Maximum size of POST data that PHP will accept.
    post_max_size = 20M
    max_execution_time = 300

    3, Deploy your web app.

    4, Restart the web app.

    You can read official guide for more information.

    By the way, we can use FTP tool to connect your Azure Web sites server to create and modify the custom configuration file instead of redeploying the project.

    The default root directory is D:\home\site\wwwroot.

    Tuesday, February 9, 2016 1:50 AM
    Moderator