locked
web.config RRS feed

  • General discussion

  • Hello, I have read all the solutions to the Run time errors in the web.config files an none have worked for me..:(

    Here is my error:

    <!-- Web.Config Configuration File --> <configuration> <system.web> <customErrors mode="Off"/> </system.web> </configuration>
    Notes: The current error page you are seeing can be replaced by a custom error page by modifying the "defaultRedirect" attribute of the application's <customErrors> configuration tag to point to a custom error page URL.

    <!-- Web.Config Configuration File -->
    
    <configuration>
        <system.web>
            <customErrors mode="RemoteOnly" defaultRedirect="mycustompage.htm"/>
        </system.web>
    </configuration>

    Here is my code using Visiual developer express

    <?xml version="1.0" encoding="utf-8"?>
    <configuration>
        <system.web>
            <authorization>
                <deny users="?" />
            </authorization>
                </system.web>         
    </configuration>

     

    I have added the "off" and the other lines but nothing has helped or worked!

    Please help!

    Thank you!

    Saturday, February 4, 2012 4:42 PM

All replies

  • What is your question?  You haven't told us what you are trying to achieve, or what the result was.  The "Notes" you quoted is not the error message, but just a way to go to a custom error page, which I doubt is what you really want to do and which is not necessary.  You need to see the actual error to do anything about it.

    If the page is published, post a link so we can see the full page, not just what you quoted.

    • Edited by KathyW2 Saturday, February 4, 2012 7:33 PM
    Saturday, February 4, 2012 5:17 PM
  • This isn't an EW question. It's an ASP.NET Forum question (if there is a question). Or a Visual Web Developer Forum.

    That's not to say people here might not know the answer, but the real place to ask (since it's about an ASP.NET file and not an Expression Web issue) is the asp.net forum.


    Comic Sans walks into a bar. The bartender says, "Get out! We don't serve your type."
    Saturday, February 4, 2012 6:45 PM
  • Here's a possible answer. The setting for 'customeErrors' is case sensitive, so it should read 'Off' not 'off'.
    Ian Haynes

    EW - V4 Add-Ins
    EW - Resources, hints and tips
    EW - Design for the Mobile Web
    Saturday, February 4, 2012 7:13 PM
  • Im sorry. This is for Expressions Web. I am trying to create a login page: http://createdstyle.com/login.aspx?ReturnUrl=%2fmembership%2flogin.aspx

     

    I followed a tutorial I found on this forum, it worked on the local host but not on the web.

    Sunday, February 5, 2012 12:12 AM
  • You haven't given us any information to help you.  The link to your login page doesn't tell us what is wrong.  What tutorial?  Implemented the login, how?  Standard asp.net membership provider?  That requires a database - have you put the database on your site and changed the appropriate connection string in the web.config to point to it? 

    And have you published the web.config to the root of your site that lets you see the error messages (do not put a custom error page in - that is not what you want).  Do you know where to put the changes in the web.config?  And so on. You'll need to provide more information to get help, and for asp.net , it's best done on the asp.net forum (http://forums.asp.net/) .  (It doesn't matter that you are using EW to create the pages, you are using asp.net.)


    • Edited by KathyW2 Sunday, February 5, 2012 8:02 AM
    Sunday, February 5, 2012 3:33 AM
  • I followed a tutorial I found on this forum, it worked on the local host but not on the web.

    Do you know how many tutorials have been referenced in this forum? And if you're talking about the "Learn" link above, those are not even exclusively EW. We have absolutely no way to know what tutorial you're talking about, or what procedures you have followed. And, as Kathy has noted, you haven't actually asked a question.

    cheers,
    scott


    Please remember to "Mark as Answer" the responses that resolved your issue. It is common courtesy to recognize those who have helped you, and it also makes it easier for visitors to find the resolution later.
    Monday, February 6, 2012 2:36 AM