locked
Visual Studio 2015 Crashes on Opening or Creating Project after installation RRS feed

  • Question

  • I've been trying to solve this problem since last week.  I installed VS 2015 Enterprise last week side by side with VS 2015 Premium.  I tried to open the solution I'd been working on.  In the output it said that is was opening repositories then VS 2015 just shuts down.  I tried searching for an answer and couldn't really find anything that was exactly like my question.  VS 2013 was still working.  During installation it said the TypeScript was not installed.  

    I first tried installation from the Web installer.  So I uninstalled that and then downloaded the .iso file and tried it from there.  Same thing, stops on trying to open the solution.  I thought there might be something wrong with the git repository so I tried to create an new project with a git repository and it crashed as well.  Then I tried creating a project without a repository and it crashed as well.

    After some more searching some more for a solution I found some answers that said there might be problems with side by side installations.  So I uninstalled VS2015 the VS 2013 the reinstalled VS 2105 but with the same result.

    I've now gone back and installed VS 2013 Ultimate Update 5 and it's working fine.  (When we renewed our license we were told there was going to be no premium version of VS 2015 so we went with the Enterprise license which included the Ultimate version of VS 2013.  I'd just never saw a reason to upgrade from the premium to ultimate, but I did so today.)

    Any help about what is causing this would be helpful.

    Thanks


    Jack of all trades master of none.

    Wednesday, August 5, 2015 3:33 PM

Answers

  • Thanks Jiaya.  Everything loaded and it's working fine.

    Jack of all trades master of none.

    • Marked as answer by Jiayi Li Monday, August 17, 2015 9:37 AM
    Tuesday, August 11, 2015 1:04 PM

All replies

  • After posting this I noticed a thread that I hadn't found before it here

    https://social.msdn.microsoft.com/Forums/en-US/ddcaf5dc-9b20-459f-9dd8-c7f5bde3ccca/visual-studio-2015-installs-but-crashes-as-it-starts-to-execute?forum=vssetup

    Also I'm running Windows 7 64 bit SP1, Dell Precision Tower 7810, 64 GB memory


    Jack of all trades master of none.

    Wednesday, August 5, 2015 3:39 PM
  • I tried down loading the SHA-1 checker and I can't I'm taken to a page that says that the page has a redirect.  The problem on the thread isn't exact either.  When I launch VS 2015 Enterprise and try to do anything with a project or solution I get no message it just stops and closes.

    Jack of all trades master of none.

    Wednesday, August 5, 2015 3:49 PM
  • Hi marvmax,

    You can download the FCIV.exe from here: http://support.microsoft.com/kb/841290  to verify hash of the ISO. Any discrepancy would indicate that the file was corrupted. Here is a blog for how to use it, you can refer to it.

     

    The sha1 value of ISO is “07C949078F895CE0D9C03A1B8D55571A8C90AC94". Refer to: https://www.visualstudio.com/en-us/downloads/visual-studio-2015-iso-sha1-vs.aspx

    If your package is well, please try the following commands:

    Please open Windows Explorer, and navigate to  <Visual Studio Installation Path>\Common7\IDE (by default is C:\Program Files \Microsoft Visual Studio 14.0\Common7\IDE)

    1. Devenv.exe /SafeMode, This can eliminate the possibility that third party Add-ins or packages are causing problems. Thus ensuring stable execution.
    2. Devenv.exe /ResetSkipPkgs, it will clear all SkipLoading tags that have been added to VSPackages by users who want to avoid loading problem VSPackages.

    If the above doesn’t help, I need more detail information to troubleshoot this issue, please take the following steps to collect the log files to us:

    1. Devenv.exe /log, to start Visual Studio and log all activity to the log file. By default, the log file is: %APPDATA%\Microsoft\VisualStudio\Version\ActivityLog.xml
    2. You could use  http://aka.ms/vscollect to gather the installation logs. After using it, you will find vslogs.cab from %temp% folder.
    3. Please upload the vslogs.cab and ActivityLog.xml to https://skydrive.live.com/ and share the link here.

    Best Regards,

    Jiayi Li


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.

    Click HERE to participate the survey.

    Thursday, August 6, 2015 5:55 AM
  • Thanks Jiayi Li.  I use Chrome as my primary programming browser and it could not open the FCIV.EXE link.  Then I tried to use IE11 and the drop down menus to get to the forums didn't work.  I was going to tell you what a failure I was when I decided to try my service browser.  Yes I program and cover a service desk if no one else is available.  Anyway my service desk browser is Opera and it was able to open the link and download it.  Yay.

    Bad news for me though.  Just to make sure I did this command

    FCIV.EXE path-to-the-iso-file >> hash.tst

    If that's the right command then there is something wrong with the ISO I have.  Here's the results I got back.

    d883686251f3b7de2255980b6000ef34218da6ea c:\users\115653\downloads\en_visual_studio_enterprise_2015_x86_x64_dvd_6850497\autorun.inf
    59fad2be03ee491222db1794c0da5bbf95805b3b c:\users\115653\downloads\en_visual_studio_enterprise_2015_x86_x64_dvd_6850497\vs_enterprise.exe

    Neither of those match the above hash.  I downloaded my ISO from my msdn subscriptions page.  I guess I'll try somewhere else.


    Jack of all trades master of none.

    Thursday, August 6, 2015 7:02 PM
  • Hi Marvmax,

    >>FCIV.EXE path-to-the-iso-file >> hash.tst

    We should run the following command: FCIV.exe -sha1 path-to-the-iso-file, please refer to this blog

    After running it, if your SHA-1 value is still incorrect, please try download it from this link: http://download.microsoft.com/download/6/4/7/647EC5B1-68BE-445E-B137-916A0AE51304/vs2015.ent_enu.iso

    Best Regards,

    Jiayi Li


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.

    Click HERE to participate the survey.

    Friday, August 7, 2015 7:21 AM
  • Thanks.  When I ran it the right way both of the ISOs I've downloaded came back with the right hash.  I'll try uninstalling my 2013 version and install 2015 and follow the steps you gave earlier.

    Thanks again.


    Jack of all trades master of none.

    Friday, August 7, 2015 2:45 PM
  • Allright Jiayi,

    I tried installing it again it still didn't work.  When I run it from devenv.exe /SafeMode I do get a new error when trying to open a new project "No such interface supported" but then it just shuts down with no error message or anything like that.

    I did load the vslogs.com onto skydrive like you requested.  Here is the web page where it is stored.

    https://onedrive.live.com/?id=A5C68875AF14401A%21141&cid=A5C68875AF14401A&group=0

    VS 2013 Ultimate Update 5 runs fine after I install it.


    Jack of all trades master of none.

    Friday, August 7, 2015 7:14 PM
  • Hi marvmax,

    I found the following error from your log file:

    implementation is not part of the Windows Platform FIPS validated cryptographic algorithms.

    Please go to registry editor to check the value. Please go to: HKLM\System\CurrentControlSet\Control\Lsa\FIPSAlgorithmPolicy    

    This registry value reflects the current FIPS setting. If this setting is enabled, the value is 1. If this setting is disabled, the value is 0. If your value is 1, please set it to 0, and then restart your machine to reinstall visual studio.

    Best Regards,

    Jiayi Li


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.

    Click HERE to participate the survey.

    • Proposed as answer by Jiayi Li Wednesday, August 12, 2015 8:02 AM
    Monday, August 10, 2015 7:06 AM
  • Thanks Jiaya.  Everything loaded and it's working fine.

    Jack of all trades master of none.

    • Marked as answer by Jiayi Li Monday, August 17, 2015 9:37 AM
    Tuesday, August 11, 2015 1:04 PM
  • Hi marvmax,

    I'm very glad to hear that you issue has been solved.

    Best Regards,

    Jiayi Li


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.

    Click HERE to participate the survey.

    Wednesday, August 12, 2015 8:03 AM
  • Jiayi:

    Can you explain the issue further?

    Does Visual Studio (2015) require installation with FIPS Compliance disabled?

    Then does it require FIPS Compliance for operation if it was installed with FIPS disabled, or can FIPS Compliance be reenabled post-installation?

    Thanks in advance!

    Wednesday, December 2, 2015 10:01 PM
  • Is there any further information about this issue?

    At most federal government installations, FIPS is REQUIRED to be enabled.  We don't have the option to disable FIPS.  Is there a workaround for installing VS2015 with FIPS enabled?

    Jiayi - can you answer the previous question from J. Yeski?  (can FIPS compliance be reenabled post-installation)

    At this point, every attempt to install VS2015 with FIPS enabled has failed (for me).

    Tuesday, February 16, 2016 2:04 PM
  • Jiayi,

    I have installed VS2015 Professional with Update 1.  When I try to create a C# project I get a The 'RoslynPackage' package did not load correctly.  The VS2015 performs a restart.  It did this when I was on Windows 8.1 and now when I updated to Windows 10.

    I can create C++ projects, but no C# projects.    

    I tried starting VS2015 with your suggestions:

    Devenv.exe /SafeMode, and Devenv.exe /ResetSkipPkgs

    Neither worked.

    I would appreciate any help, this IDE just doesn't seem to want to work for me...

    Sunday, March 6, 2016 2:48 PM
  • Hello Jiayi,

    I have followed all of the steps here including looking at the registry key, but still cannot get Visual Studio 2015 Pro to run.  I have installed and uninstalled the program and all the associated programs and I have tried the enterprise edition, I also upgraded windows 10 home to windows 10 pro and still have had no luck.  When loading a solution it crashes as discussed above.  If I try to open the same solution in Blend for Visual Studio, it opens with no problems.  Everything worked well until about October 2015, so I am not sure if it was an update pushed out, but would really like to get this fixed any help would be greatly appreciated.

    Thanks,

    Eric

    Friday, June 10, 2016 1:31 AM
  • You are correct.  With FIPS enabled VS2015 crashes every time when attempting to open a solution.  My computer was recently upgraded to Windows 10 Enterprise and I experienced it myself before I remembered the fix.  My workaround involves a simple one line addition to the Visual Studio configuration file.  Close Visual Studio 2015 and remember to backup the original configuration file as a basic precaution.

    The configuration file can be found at: "C:\Program Files (x86)\Microsoft Visual Studio 14.0\Common7\IDE\devenv.exe.config" and is in a common XML format.  I use an XML editor but a simple text editor like Notepad will work equally well.

    Search for the runtime closing tag which looks like this: </runtime> and insert the following on a line above the closing tag exactly as shown:

    <enforceFIPSPolicy enabled="false"/>

    Save the file and run VS2015 again.  This should solve your problem.  Hope it helps.

    I want to apologize to the original poster who came up with this idea. I cannot find your post to give you the credit you deserve.

    

    Wednesday, October 12, 2016 8:06 PM