locked
Web Activity Error RRS feed

  • Question

  • Hi Team,

    While implementing web activity in pipeline getting error "Error Calling the endpoint". Please find the code below which i am using.

    {
    "name": "PushDirectExpenseToCostPoint",
    "properties": {
    "activities": [
    {
    "name": "Web1",
    "type": "WebActivity",
    "policy": {
    "timeout": "7.00:00:00",
    "retry": 0,
    "retryIntervalInSeconds": 30,
    "secureOutput": false,
    "secureInput": false
    },
    "typeProperties": {
    "url": "http://10.26.130.2/GPS/Service/VendorApi",
    "method": "GET",
    "linkedServices": [
    {
    "referenceName": "HttpLinkedService",
    "type": "LinkedServiceReference"
    }
    ],
    "datasets": [
    {
    "referenceName": "HttpWebApi",
    "type": "DatasetReference"
    }
    ]
    }
    }
    ],
    "folder": {
    "name": "DIRECT EXPENSE"
    }
    }

    }

    If i check with Linkedservice and Dataset then it is working fine only with webactivity it is not working.

    Dataset Code:

    {
    "name": "HttpWebApi",
    "properties": {
    "linkedServiceName": {
    "referenceName": "HttpLinkedService",
    "type": "LinkedServiceReference"
    },
    "folder": {
    "name": "DIRECT EXPENSE"
    },
    "type": "HttpFile",
    "typeProperties": {
    "format": {
    "type": "TextFormat",
    "columnDelimiter": ",",
    "rowDelimiter": "",
    "nullValue": "\\N",
    "treatEmptyAsNull": true,
    "skipLineCount": 0,
    "firstRowAsHeader": false
    },
    "relativeUrl": "GPS/Service/VendorApi",
    "requestMethod": "Get"
    }
    }

    }

    Linked Service Code:

    {
    "name": "HttpLinkedService",
    "type": "Microsoft.DataFactory/factories/linkedservices",
    "properties": {
    "type": "HttpServer",
    "typeProperties": {
    "url": "http://10.26.130.2/",
    "enableServerCertificateValidation": false,
    "authenticationType": "Anonymous"
    },
    "connectVia": {
    "referenceName": "integrationRuntime2",
    "type": "IntegrationRuntimeReference"
    }
    }
    }

    Wednesday, September 12, 2018 5:49 AM

All replies

  • Can any one please help on the above issue?
    Wednesday, September 12, 2018 1:14 PM
  • Hello,

    Since your Web activity is calling a private IP, are utilizing a self hosted IR?

    Could you test connectivity from your IR to your API endpoint?  If there are any issues there, that might be the answer.

    Friday, September 21, 2018 7:20 PM