locked
Azure Virtual Machine - How to change DNS name RRS feed

  • Question

  • I created a new Virtual Machine in Azure but typo'ed the DNS name for the machine.  Can this be changed or do I have to delete and recreate the machine.

    Thanks,
    Rob

    Saturday, August 4, 2012 6:51 PM

Answers

  • There is not support to change the DNS name at present. You need to delete the VM and recreate it.

    When you delete the VM, the VHD still exists in your storage account. Just create your VM by associated from it, it would be faster and you wont lose anything even if you delete your VM. Also make sure that you attache your VHDs back after creating VM.

    Hope it helps



    Please mark the replies as Answered if they help and Vote if you found them helpful.

    Saturday, August 4, 2012 7:35 PM

All replies

  • There is not support to change the DNS name at present. You need to delete the VM and recreate it.

    When you delete the VM, the VHD still exists in your storage account. Just create your VM by associated from it, it would be faster and you wont lose anything even if you delete your VM. Also make sure that you attache your VHDs back after creating VM.

    Hope it helps



    Please mark the replies as Answered if they help and Vote if you found them helpful.

    Saturday, August 4, 2012 7:35 PM
  • I have two virtual machines running on the same cloud service. The two machines have the same DNS name as the cloud service. One machine is am SQL Server, another Windows Server 2012. We have a portal deployed on the machines. The portal works fine locally but we cannot access it using the URL. We have created an endpoint to open port 80 on the Windows Server virtual machine, we still cannot connect. We have come to believe that the reason might be because the two machines have the same DNS name. My question is how can we resolve this. The image below shows thr


    Monday, February 24, 2014 9:14 AM
  • I'm not so sure about that diagnostic...

    I have currently the same setup, 2 VMs in one DNS name, only one of them is publishing AD FS through the  Remote Access/WAP feature, and it's working fine. Are you sure the protocol your portal is accessed through is HTTP on port 80? try opening HTTPS on port 443, or confirming what port is used.

    I'm trying to change a DNS name, but apparently it can't be done... :/

    Wednesday, June 4, 2014 2:20 AM
  • Actually this url (DNS Name) is not allowing due to firewall setting. You need to enable that port on virtual machine.

    You need to follow below steps to enable port on VM.

    This is windows based setting :

    open VM -> Start -> administrative tool ->windows firewall with advanced security -> Inbound Rules -> click on new rule -> select port radio button -> next -> enter specific port (defined in endpoint for http) -> allow the connection -> next ->next ->finish

    Now after enabling this port, you can access using DNS name also.

    Check in your machine's browser now.

    Thursday, June 11, 2015 6:32 AM