locked
Analysis Services AdventureWorks Deploy Error - Target Mail Cube Doesn't found RRS feed

  • Question

  • Hello everyone,

    I have been working on adventureworks for a while. I closed my computer and when I opened it, It gave me the following error and I could't understand what is the problem

     

    Error    1    Errors in the metadata manager. The dimension with ID of 'Targeted Mailing ~MC-Customer Key', Name of 'Targeted Mailing ~MC-Customer Key' referenced by the 'Targeted Mailing ~MC' cube, does not exist. Errors in the metadata manager. An error occurred when loading the Targeted Mailing ~MC cube, from the file, '\\?\C:\Program Files\Microsoft SQL Server\MSAS10_50.MSSQLSERVER\OLAP\Data\Adventure Works DW 2008R2.0.db\Targeted Mailing ~MC.1.cub.xml'.         0    0

     

    and there are lots of messages in the error pane about engine schema

    Message    4    Could not find schema information for the element 'http://schemas.microsoft.com/analysisservices/2003/engine:DatabaseID'.    C:\Program Files\Microsoft SQL Server\MSAS10_50.MSSQLSERVER\OLAP\Data\Adventure Works DW 2008R2.0.db\Targeted Mailing ~MC.1.cub.xml    3    4    Miscellaneous Files

    Thank you in advance

    Best regards,

    Erdem Zengin

    Wednesday, January 26, 2011 10:55 PM

Answers

  • I have changed the database name deployed and got success but If It was a prod system it couldn't be the solution.


    It seems the SSAS server still preserve the information of the original database. So, you cannot deploy the database with name “Adventure Works DW 2008”? What if you create a simply database with the that name?

     

    You can also try to change the name back, and then stop SSAS server, delete everything from the “data” folder (please ensure the folder is the correct one, after deleting you should be able to see nothing in SSMS), and then delete everything from the folder C:\Program Files\Microsoft SQL Server\MSAS10_50.MSSQLSERVER\OLAP\Temp. If it still doesn’t work, please contact Support engineer, they can provide more effective way to resolve the issue:

     http://support.microsoft.com/contactus

     

    Thanks,

    Raymond


    Raymond Li - MSFT
    • Marked as answer by Jerry Nee Wednesday, February 9, 2011 2:51 AM
    Wednesday, February 2, 2011 5:28 AM

All replies

  • Hi Erdem.

    Try deleting and re-creating your dimension, and then process your cube. Let me know if you get any error then.


    http://thebipalace.wordpress.com/
    Thursday, January 27, 2011 12:14 AM
  • Hi Erdem,

    Please right click the solution, click Rebuild. Check if there is any error. If no error, please right click the solution, click properties, switch to Deployment pane, select ‘Deploy All’ as the Deployment Mode, Full as Processing option, and then try to deploy it again.

     

    Hope this helps,

    Raymond


    Raymond Li - MSFT
    Friday, January 28, 2011 11:32 AM
  • Hi Raymond,

    Thanks for your interest. I have rebuild the solution and It didn't give any error. After that I changed the properties like you said. Finally when I was deploying It gave the same error. It's an interesting thing that I didn't even changed or opened the project. I was just trying some MDX queries with AdventureWorks and it was fine. At some time I opened the SSMS for trying a new query there was only the database witout any dimension or cube. I can't understand the problem. As you can see from the error message There is a statement like ' 'Targeted Mailing ~MC' cube, does not exist.' but there is no cube called Targetted Mailing. Isn't it a mining model related dimension.

    Regards,

    Erdem

    Friday, January 28, 2011 11:49 AM
  • In AdventureWorks, only ‘Customer Mining’ mining structure created from cube, but I don’t think it is the root cause (you can try to delete it and then test it again). I still want to narrow down the issue, how did you process the cube? Right click the project and then click Deploy? If so, I’m not sure the error comes from Deploying or Processing. Could you select ‘Do Not Process’ as the Processing Option, deploy it first and then right click the solution click process. Then we can know whether this is a processing error.

     

    Thanks,

    Raymond


    Raymond Li - MSFT
    Friday, January 28, 2011 12:19 PM
  • I set the properties to full process and deploy all. Then right clicked the project to deploy.

    I set the processing option to 'Do not Process' then right clicked the project to deploy but got the same error. Here is a copy of xml file which is being mentioned in the error message.

    <Load xmlns="http://schemas.microsoft.com/analysisservices/2003/engine" xmlns:ddl2="http://schemas.microsoft.com/analysisservices/2003/engine/2" xmlns:ddl2_2="http://schemas.microsoft.com/analysisservices/2003/engine/2/2" xmlns:ddl100="http://schemas.microsoft.com/analysisservices/2008/engine/100" xmlns:ddl100_100="http://schemas.microsoft.com/analysisservices/2008/engine/100/100" xmlns:ddl200="http://schemas.microsoft.com/analysisservices/2010/engine/200" xmlns:ddl200_200="http://schemas.microsoft.com/analysisservices/2010/engine/200/200" xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
    	<ParentObject>
    		<DatabaseID>Adventure Works DW 2008R2</DatabaseID>
    	</ParentObject>
    	<ObjectDefinition>
    		<Cube>
    			<Name>Targeted Mailing ~MC</Name>
    			<ID>Targeted Mailing ~MC</ID>
    			<CreatedTimestamp>2010-12-24T20:19:00.663333</CreatedTimestamp>
    			<LastSchemaUpdate>2010-12-24T20:19:00.663333</LastSchemaUpdate>
    			<ObjectVersion>1</ObjectVersion>
    			<ObjectID>89065642-056D-40C9-A60B-03F116C05E6B</ObjectID>
    			<Ordinal>2</Ordinal>
    			<PersistLocation>0</PersistLocation>
    			<System>true</System>
    			<DataFileList/>
    			<Description/>
    			<LastProcessed>2010-12-24T20:31:11.583333</LastProcessed>
    			<Language>1033</Language>
    			<Collation>Latin1_General_CI_AS</Collation>
    			<DefaultMeasure/>
    			<Visible>false</Visible>
    			<AggregationPrefix>dbo_vTargetMail</AggregationPrefix>
    			<StorageMode>Molap</StorageMode>
    			<ProcessingMode>Regular</ProcessingMode>
    			<ProcessingPriority>0</ProcessingPriority>
    			<ScriptCacheProcessingMode>Regular</ScriptCacheProcessingMode>
    			<ScriptErrorHandlingMode>IgnoreNone</ScriptErrorHandlingMode>
    			<ErrorConfiguration>
    				<KeyErrorLimit>-1</KeyErrorLimit>
    				<KeyErrorLogFile/>
    				<KeyErrorAction>DiscardRecord</KeyErrorAction>
    				<KeyErrorLimitAction>StopProcessing</KeyErrorLimitAction>
    				<KeyDuplicate>IgnoreError</KeyDuplicate>
    				<KeyNotFound>IgnoreError</KeyNotFound>
    				<NullKeyConvertedToUnknown>IgnoreError</NullKeyConvertedToUnknown>
    				<NullKeyNotAllowed>ReportAndContinue</NullKeyNotAllowed>
    			</ErrorConfiguration>
    			<StorageLocation/>
    			<EstimatedRows>0</EstimatedRows>
    			<Source xsi:type="DataSourceViewBinding">
    				<DataSourceViewID>Adventure Works DW</DataSourceViewID>
    			</Source>
    			<ProactiveCaching>
    				<SilenceInterval>-PT1S</SilenceInterval>
    				<Latency>-PT1S</Latency>
    				<SilenceOverrideInterval>-PT1S</SilenceOverrideInterval>
    				<ForceRebuildInterval>-PT1S</ForceRebuildInterval>
    				<Enabled>false</Enabled>
    				<AggregationStorage>Regular</AggregationStorage>
    				<OnlineMode>Immediate</OnlineMode>
    				<Source xsi:type="ProactiveCachingInheritedBinding">
    					<NotificationTechnique>Client</NotificationTechnique>
    				</Source>
    			</ProactiveCaching>
    			<Translations/>
    			<Dimensions>
    				<Dimension>
    					<ID>Targeted Mailing ~MC-Customer Key</ID>
    					<Name>Targeted Mailing ~MC-Customer Key</Name>
    					<DimensionID>Targeted Mailing ~MC-Customer Key</DimensionID>
    					<Visible>true</Visible>
    					<HierarchyUniqueNameStyle>IncludeDimensionName</HierarchyUniqueNameStyle>
    					<MemberUniqueNameStyle>Native</MemberUniqueNameStyle>
    					<AllMemberAggregationUsage>Default</AllMemberAggregationUsage>
    					<Translations/>
    					<Attributes>
    						<Attribute>
    							<AttributeID>Customer Key</AttributeID>
    							<AggregationUsage>Default</AggregationUsage>
    							<AttributeHierarchyEnabled>true</AttributeHierarchyEnabled>
    							<AttributeHierarchyVisible>true</AttributeHierarchyVisible>
    							<AttributeHierarchyOptimizedState>FullyOptimized</AttributeHierarchyOptimizedState>
    						</Attribute>
    						<Attribute>
    							<AttributeID>Age</AttributeID>
    							<AggregationUsage>Default</AggregationUsage>
    							<AttributeHierarchyEnabled>true</AttributeHierarchyEnabled>
    							<AttributeHierarchyVisible>true</AttributeHierarchyVisible>
    							<AttributeHierarchyOptimizedState>FullyOptimized</AttributeHierarchyOptimizedState>
    						</Attribute>
    						<Attribute>
    							<AttributeID>Bike Buyer</AttributeID>
    							<AggregationUsage>Default</AggregationUsage>
    							<AttributeHierarchyEnabled>true</AttributeHierarchyEnabled>
    							<AttributeHierarchyVisible>true</AttributeHierarchyVisible>
    							<AttributeHierarchyOptimizedState>FullyOptimized</AttributeHierarchyOptimizedState>
    						</Attribute>
    						<Attribute>
    							<AttributeID>Commute Distance</AttributeID>
    							<AggregationUsage>Default</AggregationUsage>
    							<AttributeHierarchyEnabled>true</AttributeHierarchyEnabled>
    							<AttributeHierarchyVisible>true</AttributeHierarchyVisible>
    							<AttributeHierarchyOptimizedState>FullyOptimized</AttributeHierarchyOptimizedState>
    						</Attribute>
    						<Attribute>
    							<AttributeID>English Education</AttributeID>
    							<AggregationUsage>Default</AggregationUsage>
    							<AttributeHierarchyEnabled>true</AttributeHierarchyEnabled>
    							<AttributeHierarchyVisible>true</AttributeHierarchyVisible>
    							<AttributeHierarchyOptimizedState>FullyOptimized</AttributeHierarchyOptimizedState>
    						</Attribute>
    						<Attribute>
    							<AttributeID>English Occupation</AttributeID>
    							<AggregationUsage>Default</AggregationUsage>
    							<AttributeHierarchyEnabled>true</AttributeHierarchyEnabled>
    							<AttributeHierarchyVisible>true</AttributeHierarchyVisible>
    							<AttributeHierarchyOptimizedState>FullyOptimized</AttributeHierarchyOptimizedState>
    						</Attribute>
    						<Attribute>
    							<AttributeID>Gender</AttributeID>
    							<AggregationUsage>Default</AggregationUsage>
    							<AttributeHierarchyEnabled>true</AttributeHierarchyEnabled>
    							<AttributeHierarchyVisible>true</AttributeHierarchyVisible>
    							<AttributeHierarchyOptimizedState>FullyOptimized</AttributeHierarchyOptimizedState>
    						</Attribute>
    						<Attribute>
    							<AttributeID>House Owner Flag</AttributeID>
    							<AggregationUsage>Default</AggregationUsage>
    							<AttributeHierarchyEnabled>true</AttributeHierarchyEnabled>
    							<AttributeHierarchyVisible>true</AttributeHierarchyVisible>
    							<AttributeHierarchyOptimizedState>FullyOptimized</AttributeHierarchyOptimizedState>
    						</Attribute>
    						<Attribute>
    							<AttributeID>Marital Status</AttributeID>
    							<AggregationUsage>Default</AggregationUsage>
    							<AttributeHierarchyEnabled>true</AttributeHierarchyEnabled>
    							<AttributeHierarchyVisible>true</AttributeHierarchyVisible>
    							<AttributeHierarchyOptimizedState>FullyOptimized</AttributeHierarchyOptimizedState>
    						</Attribute>
    						<Attribute>
    							<AttributeID>Number Cars Owned</AttributeID>
    							<AggregationUsage>Default</AggregationUsage>
    							<AttributeHierarchyEnabled>true</AttributeHierarchyEnabled>
    							<AttributeHierarchyVisible>true</AttributeHierarchyVisible>
    							<AttributeHierarchyOptimizedState>FullyOptimized</AttributeHierarchyOptimizedState>
    						</Attribute>
    						<Attribute>
    							<AttributeID>Number Children At Home</AttributeID>
    							<AggregationUsage>Default</AggregationUsage>
    							<AttributeHierarchyEnabled>true</AttributeHierarchyEnabled>
    							<AttributeHierarchyVisible>true</AttributeHierarchyVisible>
    							<AttributeHierarchyOptimizedState>FullyOptimized</AttributeHierarchyOptimizedState>
    						</Attribute>
    						<Attribute>
    							<AttributeID>Region</AttributeID>
    							<AggregationUsage>Default</AggregationUsage>
    							<AttributeHierarchyEnabled>true</AttributeHierarchyEnabled>
    							<AttributeHierarchyVisible>true</AttributeHierarchyVisible>
    							<AttributeHierarchyOptimizedState>FullyOptimized</AttributeHierarchyOptimizedState>
    						</Attribute>
    						<Attribute>
    							<AttributeID>Total Children</AttributeID>
    							<AggregationUsage>Default</AggregationUsage>
    							<AttributeHierarchyEnabled>true</AttributeHierarchyEnabled>
    							<AttributeHierarchyVisible>true</AttributeHierarchyVisible>
    							<AttributeHierarchyOptimizedState>FullyOptimized</AttributeHierarchyOptimizedState>
    						</Attribute>
    					</Attributes>
    					<Hierarchies/>
    				</Dimension>
    			</Dimensions>
    			<Kpis/>
    			<Actions/>
    			<StructureVersion>0</StructureVersion>
    			<DataVersion>1</DataVersion>
    			<CalcVersion>0</CalcVersion>
    			<LastBindingChange>1601-01-01T00:00:00</LastBindingChange>
    			<LastUpdate>2010-12-24T20:33:07.303333</LastUpdate>
    			<MeasureGroupFileList>~CaseDetail ~MG.1.det.xml</MeasureGroupFileList>
    			<PerspectiveFileList/>
    			<AssemblyFileList/>
    			<PermissionFileList/>
    			<ParentMiningStructureID>Targeted Mailing</ParentMiningStructureID>
    		</Cube>
    	</ObjectDefinition>
    </Load>

    Regards,

    Erdem

    Friday, January 28, 2011 12:33 PM
  • It seems the metadata you deployed doesn’t match the current project.  Please stop Analysis Services, go to the folder:

    C:\Program Files\Microsoft SQL Server\MSAS10_50.MSSQLSERVER\OLAP\Data

    Delete the folder Adventure Works DW 2008R2.0.db and the related XML files in Data folder. After that, try to deploy it again.

     

    Hope this helps,

    Raymond

     

     


    Raymond Li - MSFT
    Monday, January 31, 2011 12:43 PM
  • I deleted everything from that folder. After that I downloaded adventureworks r2 sample databases again. After that I reinstalled samples. Deployed the project again. But it got a very similar error I don't understand the problem I deleted everything. I used Deploy All from the properties of the project. This time message was the same with first but "Customer Clusters xml".

    I have changed the database name deployed and got success but If It was a prod system it couldn't be the solution.

    Tuesday, February 1, 2011 11:57 AM
  • I have changed the database name deployed and got success but If It was a prod system it couldn't be the solution.


    It seems the SSAS server still preserve the information of the original database. So, you cannot deploy the database with name “Adventure Works DW 2008”? What if you create a simply database with the that name?

     

    You can also try to change the name back, and then stop SSAS server, delete everything from the “data” folder (please ensure the folder is the correct one, after deleting you should be able to see nothing in SSMS), and then delete everything from the folder C:\Program Files\Microsoft SQL Server\MSAS10_50.MSSQLSERVER\OLAP\Temp. If it still doesn’t work, please contact Support engineer, they can provide more effective way to resolve the issue:

     http://support.microsoft.com/contactus

     

    Thanks,

    Raymond


    Raymond Li - MSFT
    • Marked as answer by Jerry Nee Wednesday, February 9, 2011 2:51 AM
    Wednesday, February 2, 2011 5:28 AM