none
Wildcard * with File_Set_Path

    Question

  • I'm struggling to get the correct syntax for specifying a file set, i.e. a folder of identically formatted files. Specifically, these files are deposited to a Data Lake Store folder by an Azure Data Factory pipeline using the FlattenHierarchy copy behavior. Thus, they have random filenames with no extension. However, for test purposes, I've also tried to simply refer to a manually uploaded file with a .csv extension, using a wildcard, and that hasn't worked either.

    Is this a bug, or is there some problem with my paths, as shown here?

    FROM "adl://myacct.azuredatalakestore.net/avwOrders/*" FROM "/avwOrders/*" FROM "/avwOrders/*.csv"

    FROM "/avwOrders/"

    All of the above return file not foundI'm using this article for reference, and also this possibly related thread.

    Jason

    Friday, December 4, 2015 2:03 PM

Answers

All replies

  • Hi Jason

    The patterns have to be embedded in {} inside the string.

    So try for example FROM "/avwOrders/{*}.csv".


    Michael Rys

    Friday, December 4, 2015 5:55 PM
    Moderator
  • Thanks! I must have had something else wrong when I tried that before. Working perfectly now. Also "/avwOrders/{*}" without extension works, too.

    Jason

    Friday, December 4, 2015 6:52 PM