locked
Fastcgi crashes RRS feed

  • Question

  • User-924529333 posted

    I just know this will format badly.. :)  I believe i'm on the TP2 build of fastcgi - I tried to load ricks' 70412 build after hitting this issue, but no success on trying to install it - IIS worker process fails to start. Event log entry of "The Module name iisfcgi path C:\Windows\system32\inetsrv\iisfcgi.dll returned an error from registration. The data is the error.".

    Any thoughts or is this a new/known bug?

     Paul

    Report for w3wp__PID__2256__Date__07_18_2007__Time_08_05_48PM__302__First chance exception 0XC0000005.dmp

    Type of Analysis Performed   Crash Analysis
    Machine Name   
    Operating System   Windows Vista
    Number Of Processors   
    Process ID   2256
    Process Image   c:\Windows\System32\inetsrv\w3wp.exe
    System Up-Time   00:00:00
    Process Up-Time   00:00:09

    Thread 6 - System ID 4524

    Entry point   w3tp!THREAD_MANAGER::ThreadManagerThread
    Create time   18/07/2007 20:05:40
    Time spent in user mode   0 Days 0:0:0.15
    Time spent in kernel mode   0 Days 0:0:0.0


     

    Function     Arg 1     Arg 2     Arg 3   Source
    ntdll!RtlEnterCriticalSection+12     00000040     01560978     01560970   
    iisfcgi+6908     80070040     00000000     00dc3bb0   
    iisfcgi+9f7a     00000000     00000080     00000000   
    iiscore!NOTIFICATION_CONTEXT::RequestDoWork+25     01560970     00dc3aa0     015ffae8   
    iiscore!NOTIFICATION_CONTEXT::CallModules+271     00000001     00000000     80070040   
    iiscore!W3_CONTEXT::DoStateRequestExecuteHandler+39     00000001     00000000     80070040   
    iiscore!W3_CONTEXT::DoWork+d7     00000000     80070040     00000001   
    iiscore!W3_MAIN_CONTEXT::ContinueNotificationLoop+35     00000000     80070040     00000000   
    iiscore!W3_MAIN_CONTEXT::OnIoCompletion+59     00dc3aa0     00000000     00000040   
    w3dt!UL_NATIVE_REQUEST::DoStateProcess+21     0150b480     015ffe40     744c153b   
    w3dt!UL_NATIVE_REQUEST::DoWork+60     00000000     00000040     00dc3054   
    w3dt!OverlappedCompletionRoutine+1a     00000040     00000000     00dc3054   
    w3tp!THREAD_POOL_DATA::ThreadPoolThread+73     00000000     014aef90     72990000   
    w3tp!THREAD_POOL_DATA::ThreadPoolThread+24     0150b480     00000000     00000000   
    w3tp!THREAD_MANAGER::ThreadManagerThread+39     014aef90     015ffee8     776fa9bd   
    kernel32!BaseThreadInitThunk+e     014aef90     015f3670     00000000   
    ntdll!_RtlUserThreadStart+23     72991e3c     014aef90     00000000   


    NTDLL!RTLENTERCRITICALSECTION+12In w3wp__PID__2256__Date__07_18_2007__Time_08_05_48PM__302__First chance exception 0XC0000005.dmp the assembly instruction at ntdll!RtlEnterCriticalSection+12 in C:\Windows\System32\ntdll.dll from Microsoft Corporation has caused an access violation exception (0xC0000005) when trying to write to memory location 0x00000044 on thread 6

    Module Information

    Image Name: C:\Windows\System32\ntdll.dll   Symbol Type: PDB
    Base address: 0x776c0000   Time Stamp: Thu Nov 02 09:43:37 2006
    Checksum: 0x00128171   Comments:
    COM DLL: False   Company Name: Microsoft Corporation
    ISAPIExtension: False   File Description: NT Layer DLL
    ISAPIFilter: False   File Version: 6.0.6000.16386 (vista_rtm.061101-2205)
    Managed DLL: False   Internal Name: ntdll.dll
    VB DLL: False   Legal Copyright: © Microsoft Corporation. All rights reserved.
    Loaded Image Name: ntdll.dll   Legal Trademarks:
    Mapped Image Name: c:\symcache\ntdll.dll\4549BDC911e000\ntdll.dll   Original filename: ntdll.dll
    Module name: ntdll   Private Build:
    Single Threaded: False   Product Name: Microsoft® Windows® Operating System
    Module Size: 1.12 MBytes   Product Version: 6.0.6000.16386
    Symbol File Name: c:\symcache\ntdll.pdb\C0A498F0036E4D4FB5CBF69005B0F9242\ntdll.pdb   Special Build: &

    Friday, July 20, 2007 7:18 PM

All replies

  • User209782248 posted

    Paul,

    Thanks for letting us know about this.  I've asked Rick to take a look.

    Thanks,

    Mike Volodarsky

    Program Manager
    IIS Core Server
    Visit mvolo.com for more inside information on IIS7, IIS and ASP.NET

    Friday, July 20, 2007 10:27 PM
  • User-842020650 posted

    Hi,

     I am having the same problems getting FastCGI to install on the server using the following ways:

     
    1. Download the Technical Preview module from IIS.Net

    2. Downloaded the PHP 5.2.4 to C:\php5\

    3. Install the FastCGI as according to the readme.txt in the Technical Preview. Installation went without any problems.

    4. I tried to request for a simple html and php ( phpinfo.php ) and it throws the 503 Service Unavailable and the website application pool went stop. Here's the application log:

     

    Log Name:      Application
    Source:        Microsoft-Windows-IIS-W3SVC-WP
    Date:          9/24/2007 4:29:28 PM
    Event ID:      2293
    Task Category: None
    Level:         Error
    Keywords:      Classic
    User:          N/A
    Computer:      LONGHORN
    Description:
    The Module name iisfcgi path C:\Windows\system32\inetsrv\iisfcgi.dll returned an error from registration.  The data is the error.
    Event Xml:
    <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
      <System>
        <Provider Name="Microsoft-Windows-IIS-W3SVC-WP" Guid="{670080D9-742A-4187-8D16-41143D1290BD}" EventSourceName="W3SVC-WP" />
        <EventID Qualifiers="49152">2293</EventID>
        <Version>0</Version>
        <Level>2</Level>
        <Task>0</Task>
        <Opcode>0</Opcode>
        <Keywords>0x80000000000000</Keywords>
        <TimeCreated SystemTime="2007-09-24T08:29:28.000Z" />
        <EventRecordID>19291</EventRecordID>
        <Correlation />
        <Execution ProcessID="0" ThreadID="0" />
        <Channel>Application</Channel>
        <Computer>LONGHORN</Computer>
        <Security />
      </System>
      <EventData>
        <Data Name="ModuleDll">iisfcgi</Data>
        <Data Name="Path">C:\Windows\system32\inetsrv\iisfcgi.dll</Data>
        <Binary>05400080</Binary>
      </EventData>
    </Event>

    Here's the System log:

     Log Name:      System
    Source:        Microsoft-Windows-WAS
    Date:          9/24/2007 4:29:29 PM
    Event ID:      5139
    Task Category: None
    Level:         Warning
    Keywords:      Classic
    User:          N/A
    Computer:      LONGHORN
    Description:
    A listener channel for protocol 'http' in worker process '3928' serving application pool 'iis7.testdomain.com' reported a listener channel failure.  The data field contains the error number.
    Event Xml:
    <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
      <System>
        <Provider Name="Microsoft-Windows-WAS" Guid="{524B5D04-133C-4A62-8362-64E8EDB9CE40}" EventSourceName="WAS" />
        <EventID Qualifiers="32768">5139</EventID>
        <Version>0</Version>
        <Level>3</Level>
        <Task>0</Task>
        <Opcode>0</Opcode>
        <Keywords>0x80000000000000</Keywords>
        <TimeCreated SystemTime="2007-09-24T08:29:29.000Z" />
        <EventRecordID>12793</EventRecordID>
        <Correlation />
        <Execution ProcessID="0" ThreadID="0" />
        <Channel>System</Channel>
        <Computer>LONGHORN</Computer>
        <Security />
      </System>
      <EventData>
        <Data Name="AppPoolID">iis7.testdomain.com</Data>
        <Data Name="ProcessID">3928</Data>
        <Data Name="param3">0</Data>
        <Data Name="ProtocolID">http</Data>
        <Binary>05400080</Binary>
      </EventData>
    </Event>

    Monday, September 24, 2007 4:34 AM
  • User-842020650 posted

    Hmm.. I tried to install again and it throws this:

    C:\Users\Administrator\Desktop\IIS7-FastCGI-Technical-Preview>fcgisetup.exe /install /add C:\php5\php-cgi.exe PHP
    Stopping IIS services ...
    Copied files
    Error: (null) (HRESULT 8007000d)

     

    Monday, September 24, 2007 5:44 AM
  • User511787461 posted

    Please use the built-in fastcgi module for beta3 or later (install using the CGI checkbox in IIS) - the tech preview is only for older IIS7 builds.

    Monday, September 24, 2007 12:56 PM
  • User-842020650 posted

    Hi Anil,

     Thanks for the heads up. I was trying to uninstall and reinstall the CGI from the Add role services but getting the following error during the removal:

     Attempt to un-install CGI failed with error code -2147023293. Fatal error during installation.

    The following role services were not removed:

    Web Server

    Application Development

    CGI 


     

    Monday, September 24, 2007 9:38 PM
  • User-842020650 posted

     Hmm.. Heres something I believe you guys will be interested. When I open up the Handler mappings in the IIS, it prompts the following messages:

     
    There was an error while performing this operation.

    Details:

    Filename:\\?\C:\Windows\system32\inetsrv\config\applicationHost.config line Number:743

    Error: The configuratioin sections 'fastCGI' cannot be read because it is missing a section declaration

    I am going to check up the configuration right now and see if it is the one that is causing the issues for the installation.

     

    Monday, September 24, 2007 9:49 PM
  • User511787461 posted

    Looks like a leftover from installing the tech-preview on beta3 - the section name was changed from system.webServer/fastCGI to system.webServer/fastCgi in beta3 - you can remove the offending xml from applicationhost.config manually and should be good to go.

    Tuesday, September 25, 2007 1:19 PM