none
Installing an add-in for Outlook 2010 RRS feed

  • Question

  • We are attempting to install an add-in to Outlook 2010 32-bit on a 64-bit platform.

    The installation has been built in Installshield 2012 and on my own profile correctly installs the registry entries (into HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Office\Outlook\Addins) and the add-in.

    When I log in to the same computer as a user and open Outlook, the add-in does not appear and the registry entry appears in HKCU.

    I've followed the instructions in this article (http://blogs.msdn.com/b/vsto/archive/2010/03/08/deploying-your-vsto-add-ins-to-all-users-saurabh-bhatia.aspx) and am a little stuck now.

    Any help would be greatly appreciated.

    Kind Regards, Sumone

    Tuesday, March 31, 2015 2:18 PM

All replies

  • We are attempting to install an add-in to Outlook 2010 32-bit on a 64-bit platform.

    The installation has been built in Installshield 2012 and on my own profile correctly installs the registry entries (into HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Office\Outlook\Addins) and the add-in.

    When I log in to the same computer as a user and open Outlook, the add-in does not appear and the registry entry appears in HKCU.

    I've followed the instructions in this article (http://blogs.msdn.com/b/vsto/archive/2010/03/08/deploying-your-vsto-add-ins-to-all-users-saurabh-bhatia.aspx) and am a little stuck now.

    Any help would be greatly appreciated.

    Kind Regards, Sumone

    • Merged by L.HlModerator Wednesday, April 1, 2015 3:09 AM repeat thread
    Tuesday, March 31, 2015 1:51 PM
  • Hello Sumone,

    Make sure that you did all the steps described in the Deploying an Office Solution by Using Windows Installer article in MSDN. Be aware, you need to have admin privileges for installing add-ins for all users.

    Tuesday, March 31, 2015 3:07 PM
  • Eugene, we have followed all the steps, checked and double-checked but we haven't got any further.

    Do you have any further suggestions?

    Thursday, April 2, 2015 2:31 PM
  • Have you used to install an empty add-in without custom code , does it installs well in your outlook ?
    Wednesday, April 8, 2015 1:35 AM
  • The HKEY_LOCAL_MACHINE hive requires admin privileges for writing something. Do you run the installer with sufficient privileges?
    Wednesday, April 8, 2015 11:47 AM