none
Visual Studio 2013 C# Technical Problem RRS feed

  • Question

  • I am trying to create a web browser with Visual Studio 2013 C#, but I've encountered a problem. If I put any code within the set of curly brackets immediately after "public Form1()", then try to test out the web browser, it tries to test it, then goes into debugging mode, fails to fix anything, then gives me a stupid message (which I'll post if you need to see it) about how to troubleshoot. On the other hand, if I don't put any code in those curly brackets, when I try to test the browser it just pulls up a blank page that doesn't even have the icon I gave this browser. If I don't have those curly brackets after "public Form1()", I get an error message about needing to declare a body if I try to test the browser.

    I thank you in advance for your time and help.

    Here is the code I have so far (I didn't accomplish much before encountering this problem):

    namespace Epiillon_0._0._4_BETA
    {
        public partial class Form1 : Form
         
        {

            public Form1()
            {

            }
            
            
            private void textBox1_TextChanged(object sender, EventArgs e)
            {
                if (textBox1.Text.StartsWith("http://")) textBox1.Text.Contains(".com");
                {
                    webBrowser1.Navigate(new Uri(textBox1.Text));
                    
                    {
                        InitializeComponent();
                    }
                }
            }

            private void button1_Click(object sender, EventArgs e)
            {
                webBrowser1.GoBack();
            }
        }
       }


    Friday, May 22, 2015 3:20 AM

Answers

All replies