none
MS.net framework 2.0 RRS feed

  • Question

  • Help, PLEASE!!  I recently tried to upload pictures from my Canon digitlal camera to my computer. (Comp. is working fine in all respects) The last time I tried this, maybe a year ago,

    no problem. This time I repeatedly get from setup.exe ".NET framework 2.0 did not complete correctly." This is the message I get when trying to REINSTALL the "Canon Digital Camera Solution Disk, Ver. 41.0."  I removed the Canon camera 'utilities' 3 times attempting a fresh

    install, to no avail. I currently have....net framework 3.5, SP1, net framework 4 and 5

    security updates for net framework 4. A supplementary error message I got was 25007.

    Error occurred while initializing fusion. Setup could not load fusion with LoadLibraryShim ()

    Error 0x80131700. The disk is in good shape. I've tried every thing I can think of and

    would GREATLY appreciate a solution. (I'm up in years and this stuff is very difficult.

    Thanks, Don Hirth

    Tuesday, August 28, 2012 11:55 PM

Answers

  • Does the application come with <appexe_name>.config file?

    Add the following lines to the file and see if it can solve your problem.

      <startup useLegacyV2RuntimeActivationPolicy="true">
        <supportedRuntime version="v2.0"/>
        <requiredRuntime version="v2.0"/>
      </startup> 

    This will force the newer runtime select .NET framework v2.0 if it's already installed on the same machine.

    If none is found, create your own <appexe_name>.config with Notepad and paste the following:

    <?xml version="1.0" encoding="utf-8" ?>
    <configuration>
      <startup useLegacyV2RuntimeActivationPolicy="true">
        <supportedRuntime version="v2.0"/>
        <requiredRuntime version="v2.0"/>
      </startup>
    </configuration>
    Remember the file is XML so should be saved as utf-8 (althrough when the whole content is in English, this should not be a problem).
    Wednesday, August 29, 2012 3:18 AM
    Answerer