locked
SSMA For Oracle 5.2, how to connect to a remote SQL Server instance RRS feed

  • Question

  • Hi all,

    I try to migrate a Oracle DB to Sql Server 2005 DB ...

    It works (more/less) from a local Oracle DB to a local Sql Server expres DB  ...
    But I have to migrate to remote Sql Server 2005 .. and when I try to connect to SQL Server (via the assistant), I receive the following error :

    What I have to install in addition to have a working connection ?

    Regards,


    • Edited by Didier So Monday, August 13, 2012 10:18 AM
    Monday, August 13, 2012 10:16 AM

Answers

  • Did you install the SSMA for Oracle Extension Pack on the remote SQL Server?  You need to.  As per the requirements listed below you also need that server to have the Oracle client and connection to the Oracle server configured.

    Requirements for the SSMA for Oracle Extension Pack:
    •SQL Server 2005 or higher.
    •Microsoft Windows Installer 3.1 or a later version.
    •Oracle Client 8.1.7 or a later version, and connectivity to the Oracle databases that you want to migrate. The Oracle client version must be the same version as, or a later version than, the Oracle database version.

    • Marked as answer by Maggie Luo Tuesday, August 21, 2012 7:41 PM
    Monday, August 13, 2012 8:53 PM

All replies

  • Extension Pack has been installed correctly ...

    But only the local SQL Express instance is show in the Wizard ... No remote SQL Server is selectable ...

    Any Idea ?

    Additional info :

    SSMA For Oracle & Extension has been installed where Oracle DB is located ... not on the SQL Server 2005 side ...

    • Edited by Didier So Monday, August 13, 2012 10:26 AM
    Monday, August 13, 2012 10:20 AM
  • Did you install the SSMA for Oracle Extension Pack on the remote SQL Server?  You need to.  As per the requirements listed below you also need that server to have the Oracle client and connection to the Oracle server configured.

    Requirements for the SSMA for Oracle Extension Pack:
    •SQL Server 2005 or higher.
    •Microsoft Windows Installer 3.1 or a later version.
    •Oracle Client 8.1.7 or a later version, and connectivity to the Oracle databases that you want to migrate. The Oracle client version must be the same version as, or a later version than, the Oracle database version.

    • Marked as answer by Maggie Luo Tuesday, August 21, 2012 7:41 PM
    Monday, August 13, 2012 8:53 PM