none
Element 14 RPi3 with 14342 1 out of 3 has Wifi working RRS feed

  • Question

  • Hi,

    I am new to Windows 10 IoT and I bought three Raspberry PI 3 from same vendor.

    They are all from Element 14. No RS like people mentioned.

    I have installed Windows IoT 10.0.14328 on all of them, and only one board has WiFi working and none of them have Bluetooth working. I swapped the working micro SD card in the other two Raspberry PI 3,  I reinstalled the last three build of Windows IoT so many times in different way, in different SD cards, using the dashboard  tools and also by downloading directly from NOOBS. I even did install  the version 14342 that was released today and supposed to fix Wifi ( Windows10_InsiderPreview_IoTCore_RPi_ARM32_en-us_14342.iso) but still no luck on those two boards.

    Wifi and Bluetooth are working on all three boards using Debian for Raspberry PI 3 so I can assume the hardware is working.

    The driver is not working in Windows IoT on those two boards. From the device manager I have

    >Broadcom 802.11n Wireless SDIO Adapter

                    (ID:SD\VID_02D0&PID_A9A6&FN_1\3&2CE4C1BC&0&0, FriendlyName:Broadcom 802.11n Wireless SDIO Adapter, Class:Net, Manufacturer:Broadcom, StatusCode:25175040, ProblemCode:10)

    On the one that works I have:

    >Broadcom 802.11n Wireless SDIO Adapter

                    (ID:SD\VID_02D0&PID_A9A6&FN_1\3&2CE4C1BC&0&0, FriendlyName:Broadcom 802.11n Wireless SDIO Adapter, Class:Net, Manufacturer:Broadcom, StatusCode:25174026)

                        >Microsoft Wi-Fi Direct Virtual Adapter

                        (ID:{5D624F94-8850-40C3-A3FA-A4FD2080BAF3}\VWIFIMP_WFD\4&26C6B8D5&0&11, FriendlyName:Microsoft Wi-Fi Direct Virtual Adapter, Class:Net, Manufacturer:Microsoft, StatusCode:1098915850)

                        >Microsoft Wi-Fi Direct Virtual Adapter

                        (ID:{5D624F94-8850-40C3-A3FA-A4FD2080BAF3}\VWIFIMP_WFD\4&26C6B8D5&0&12, FriendlyName:Microsoft Wi-Fi Direct Virtual Adapter #2, Class:Net, Manufacturer:Microsoft, StatusCode:1098915850)

    Any suggestions?

    Thank you.

    Wednesday, May 18, 2016 10:18 PM

All replies

  • Hi WinWrestler,

    Unfortunately not all of the Wifi fixes we hoped made it into pre-release build#14342.  I am told the rest of the fixes will be available in 14348.  As these build numbers are loosely chronological by date, I would expect availability next week. 

    UPDATE: I asked the Developer to review your information and Code 10, is ‘device failed to start’. While he is not sure what we can do before the fixes reach the preview, he did ask if you could check if WiFi works on following system boots, that is does the Wifi start on devices on the second or later boots?

    Sincerely,

    IoTGirl


    Thursday, May 19, 2016 5:57 PM
    Moderator
  • Hi IoTGirl,

    No, I have never have WiFi working on those 2 boards after  so many reboot and SD card swapping or Win IoT version.
    I also booted without any Ethernet cable plugged in several times but I have no network connection once fully booted.
    WiFi is unavailable after boot.

    All three boards seem exactly the same, but only one have WiFi working with Windows IoT, but all three have WiFi working with Raspberry Debian which does indicate that hardware is working on all three boards.

    I also used the SD card with Windows IoT installed that works in one of the raspberry Pi 3 and inserted it in the other two raspberry PI 3 but they also show no WiFi after boot.

    Thank you, for looking into it.

    WinWrestler


    Saturday, May 21, 2016 10:29 PM
  • My board is behaving the same with an exception where Wifi adapter usually only works on first boot with a fresh SD card. I was getting Error Code 23 on "Broadcom 2836 Arasan SD Host ControllerGeneric SDIO Device" and Error Code 10 on "Broadcom 802.11n Wireless SDIO Adapter". Oddly enough, often the first boot on fresh SD card worked fine but subsequent boots after that would fail to start Wlan adapter.

    Couple restarts used to work on previouos build but now on 14342 it has tendency to get stuck during soft-reboot to where device shows up in LAN but not accessible. Currently using a tiny USB Wlan adapter, it was plug&play and appears to be more reliable.

    Edit: My board is also from Element 14.

    • Edited by samkumo Sunday, May 22, 2016 12:39 PM
    Sunday, May 22, 2016 12:29 PM
  • Having the same issue, also Element14, with 2 extra pieces of info:

    1. WiFi actually worked ONCE on my board (on the very first successful install of 14328) and never since (now tried 14342, to no avail)

    2. In Raspbian, WiFi works perfectly well, so doesn't SEEM to be a hardware issue.

    Daniel

    Monday, May 23, 2016 4:42 AM
  • Hi Folks,

    There seems to be an issue with the hardware response on some boards. The "10" indicates the driver tried to initialize the hardware but it did not get a response.  The developer working on this issue says all of his fixes did not get into 14342 so you may have to wait until 14348 is available to confirm the full fix.

    Sincerely,

    IoTGirl

    Tuesday, May 24, 2016 5:41 PM
    Moderator