locked
Define Sync Hub Database credentials not valid RRS feed

  • Question

  • Hi

    I am trying out SQL Azure and Sync to an on-premise SQL instance. I have successfully set up the agent on premise and SQL azure database but I am having difficulty with the Sync Group/Sync Hub.

    The issue is with the credentials in 'Define sync hub' in Azure. I have selected the SQL Azure instance but specifying the credentials as used for the SQL manager returns an error 'The Database credentials are not valid'. 

    Example:

    Server: xxxxxxxx.database.windows.net
    Old UserID: youruser@xxxxxxxx
    New UserID: youruser

    I have an at in my username so I have tried youruseryouruser@xxxxxxxx and youruser@yourdomain@xxxxxxxx

    The server username is in the format youruser@yourdomain

    Help! Thanks...

    Mark

    Wednesday, May 14, 2014 8:48 PM

Answers

  • OK, so I deleted the database and created a new one on a new virtual server. This let me provide a new username & password this time the username without my own@domain.com. Guess what, it worked....

    "Dear Microsoft, I think you have something going on with the Sync credentials and special characters in the username"

    regards

    Mark T



    Mark T

    • Marked as answer by Fanny Liu Monday, May 26, 2014 1:37 AM
    Friday, May 16, 2014 4:49 PM

All replies

  • Hello,

    When define a SQL database as hub database of sync group, you should provider a user name and password which has premission to connect to the SQL database.

    In your case, if the user name and password is vaild, please also check the SQL Database firewall allow Azure connections: open the Configure tab of the SQL database server on Windows Azure Management portal, select the "Yes" in Allowed Services section.

    Regards,
    Fanny Liu

    If you have any feedback on our support, please click here. 


    Fanny Liu
    TechNet Community Support

    • Proposed as answer by dell.ca Wednesday, August 26, 2015 5:00 PM
    Thursday, May 15, 2014 6:59 AM
  • Hi

    I have checked this setting on the server and it is allowed. The IP address of my network is also in the allowed list.

    Any other ideas?

    regards

    Mark



    Mark T

    Thursday, May 15, 2014 7:54 AM
  • OK, so I deleted the database and created a new one on a new virtual server. This let me provide a new username & password this time the username without my own@domain.com. Guess what, it worked....

    "Dear Microsoft, I think you have something going on with the Sync credentials and special characters in the username"

    regards

    Mark T



    Mark T

    • Marked as answer by Fanny Liu Monday, May 26, 2014 1:37 AM
    Friday, May 16, 2014 4:49 PM
  • the firewall rule for azure allowed services fixed my issue. thanks
    Wednesday, August 26, 2015 5:01 PM