none
Error opening URL 'local:////star5/schema//STARTransport2005.wsdl' on wcf call RRS feed

  • Question

  • I have created a wcf service consuming wsdl file. The wcf is secured with certificates which i have configured in web.config. The service have two methods one for pull and other to put. When I do a request using pull method it works but when i try to use put method i get the following error:

    Error opening URL 'local:////star5/schema//STARTransport2005.wsdl'

    Here is the configuration file(web.config)

      <endpointBehaviors>
        <!-- Ford LDS-->
        <behavior name="Ford_WSSecBehavior">
          <clientCredentials>
            <clientCertificate storeLocation="CurrentUser" storeName="My" x509FindType="FindBySubjectName" findValue="LD00BD.b2d.ford.com"/>
            <serviceCertificate>
              <defaultCertificate storeLocation="CurrentUser" storeName="Root" x509FindType="FindBySubjectName" findValue="b2dgwqa.ford.com"/>
              <authentication revocationMode="NoCheck"/>
            </serviceCertificate>
          </clientCredentials>
          <clientVia viaUri="https://b2dgwqa.ford.com/5027/StarTransport"/>
        </behavior>
      </endpointBehaviors> <binding name="Ford_starTransport" closeTimeout="00:01:00" openTimeout="00:01:00" receiveTimeout="00:10:00" sendTimeout="00:01:00" allowCookies="false" bypassProxyOnLocal="false" hostNameComparisonMode="StrongWildcard" maxBufferSize="65536" maxBufferPoolSize="524288" maxReceivedMessageSize="65536" messageEncoding="Text" textEncoding="utf-8" transferMode="Buffered" useDefaultWebProxy="true">
          <readerQuotas maxDepth="32" maxStringContentLength="8192" maxArrayLength="16384" maxBytesPerRead="4096" maxNameTableCharCount="16384"/>
          <security mode="None">
            <transport clientCredentialType="None" proxyCredentialType="None" realm=""/>
            <message clientCredentialType="UserName" algorithmSuite="Default"/>
          </security>
        </binding> <customBinding>
        <!-- Ford LDS-->
    
        <binding name="Ford_Secure_https" closeTimeout="00:05:00" openTimeout="00:05:00"
          receiveTimeout="00:05:00" sendTimeout="00:05:00">
          <textMessageEncoding  messageVersion="Soap11WSAddressing10">
            <readerQuotas maxDepth="2147483647" maxStringContentLength="2147483647" maxArrayLength="2147483647" maxBytesPerRead="2147483647" maxNameTableCharCount="2147483647" />
          </textMessageEncoding>
    
          <security defaultAlgorithmSuite="Basic128Rsa15" allowSerializedSigningTokenOnReply="true"
            authenticationMode="MutualCertificate" includeTimestamp="true" enableUnsecuredResponse="true"
            messageProtectionOrder="SignBeforeEncrypt" messageSecurityVersion="WSSecurity10WSTrustFebruary2005WSSecureConversationFebruary2005WSSecurityPolicy11BasicSecurityProfile10" />
          <httpsTransport maxReceivedMessageSize="5000000" maxBufferSize="5000000" />
        </binding>
      </customBinding> <endpoint  address="urn:ford/star/services/v1/GenericPull"
               behaviorConfiguration="Ford_WSSecBehavior"
               binding="customBinding"
               bindingConfiguration="Ford_Secure_https"
               contract="AutoIt.Backend.FordIntegration.Proxcies.Ford.RequestSalesLeadService.starTransportPortTypes"
               name="Ford_starTransport">
        <identity>
          <dns value="b2dgwqa.ford.com" />
        </identity>
      </endpoint>
    
      <endpoint  address="urn:ford/star/services/v1.0/SalesLead/EU"
             behaviorConfiguration="Ford_WSSecBehavior"
             binding="customBinding"
             bindingConfiguration="Ford_Secure_https"
             contract="Proxcies.Ford.ProcessSalesLeadService.starTransportPortTypes"
             name="Ford_starTransport">
        <identity>
          <dns value="b2dgwqa.ford.com" />
        </identity>
      </endpoint>
    
      <endpoint  address="urn:ford/star/services/v1.0/SalesLead/EU"
           behaviorConfiguration="Ford_WSSecBehavior"
           binding="customBinding"
           bindingConfiguration="Ford_Secure_https"
           contract="AutoIt.Backend.FordIntegration.Proxcies.Ford.UpdateSalesLeadService.starTransportPortTypes"
           name="Ford_starTransport">
        <identity>
          <dns value="b2dgwqa.ford.com" />
        </identity>
      </endpoint>
    Thursday, June 4, 2015 1:46 PM

All replies

  • Hi Raza_ahmed,
          According to this case, you can use the ListenUriMode property and set its value to ListenUriMode.Unique. When you do this, the channel infrastructure will either choose a unique port number (in the case of TCP, without port sharing enabled) or it will append a GUID to the end of the ListenUri address before using it.It’s worth noting that you can also use a relative address when specifying the ListenUri and WCF  will resolve it against the corresponding base address just like it does for the logical endpoint addresses.

    So You can do in config file like below sample:
    <configuration>
      <system.serviceModel>
        <services>
          <service name=”CalculatorService”>
            <endpoint address=”urn:calcservice:simplemath”
                      listenUri=”http://localhost:8080/calcservice” 
                      binding=”wsHttpBinding”
                      contract=”ISimpleMath”/>
            <endpoint address=”urn:calcservice:scientific”
                      listenUri=”http://localhost:8080/calcservice” 
                      binding=”wsHttpBinding”
                      contract=”IScientific”/>
          </service>
          ...
    for more information, Click here to know more about WCF addressing in depth.
    Monday, June 8, 2015 8:32 AM
  • Hi Edwin,

    Sorry for late reply as i was doing something else and left the issue as it is. And secondly thank you for taking interest in my issue.

    Can you please tell me why is this issue coming as i am dumbfounded by just looking into the exception message. Why is it trying to open a wsdl file where as i have generated a proxy classes from these wsdl files.

    I tried your solution but it did not work. probably i am doing something wrong. Please help


    Raza Ahmed

    Tuesday, June 16, 2015 2:49 PM
  • Can you please tell me why is this issue coming as i am dumbfounded by just looking into the exception message. Why is it trying to open a wsdl file where as i have generated a proxy classes from these wsdl files.

            I suspect that the issue might be in endpoint which are having same address urn in the following area of your code :
    <endpoint  address="urn:ford/star/services/v1.0/SalesLead/EU"
             behaviorConfiguration="Ford_WSSecBehavior"
             binding="customBinding"
             bindingConfiguration="Ford_Secure_https"
             contract="Proxcies.Ford.ProcessSalesLeadService.starTransportPortTypes"
             name="Ford_starTransport">
        <identity>
          <dns value="b2dgwqa.ford.com" />
        </identity>
      </endpoint>
    
      <endpoint  address="urn:ford/star/services/v1.0/SalesLead/EU"
           behaviorConfiguration="Ford_WSSecBehavior"
           binding="customBinding"
           bindingConfiguration="Ford_Secure_https"
           contract="AutoIt.Backend.FordIntegration.Proxcies.Ford.UpdateSalesLeadService.starTransportPortTypes"
           name="Ford_starTransport">
        <identity>
          <dns value="b2dgwqa.ford.com" />
        </identity>
      </endpoint>
    Please double check bindings & its corresponding endpoint in the config file whether it was configured properly or not.
    Monday, June 29, 2015 8:55 AM
  • Hi Edwin,

    Many thanks for your reply. The endpoints are correct as the request handled through these endpoints are same. Only difference here are the contracts. Any how thanks for a lead and i am looking into configuration to get any fault from therew


    Raza Ahmed

    Friday, July 3, 2015 11:50 AM