locked
MOSS 2007 - cannot create site or document list templates RRS feed

  • General discussion

  • Hi all

    I have a weird problem with Sharepoint 2007 that I am having trouble sorting out. Hopefully someone can help me! I am new to Sharepoint so please forgive me if I dont use the correct terms and phrases!

    I have created a few personal sharepoint sites for our customers on our Sharepoint page. What I now want to do is use one of these and create a site template from it. I go to the chose site, go to Site Actions - Site Settings - Save site as template. I fill in the File Name, Template Name, Template Description and leave the Include Content checkbox unticked. When I press OK, nothing happens. There is no error message, no information, no page loading, nothing. The same thing also happens if I try to create a document library template from an existing document library.

    If I go to Site Actions - Site Settings - Advanced Permissions, I can see that I have 'Full Control' permissions

    The Sharepoint version is 12.0.0.6565 (from Site Settings page)

    Is there something I am missing or not doing?

    Thanks for all help
    Naz

    
    

    Tuesday, May 1, 2012 8:52 AM

All replies

  • Hello Naz,

    Is the page re-directing or not (any message, page refresh etc. that you can see when you click on OK) ?

    I suggest to first clear the cache and temp Internet files in IE and then try again.


    Regards, Rohan --Please mark as "Answer" if the post resolve your issue--

    Tuesday, May 1, 2012 9:02 AM
  • Hi, thanks for the reply. I closed IE, flushed the DNS, reopened IE, deleted the IE cache, history, etc from IE - Safety - Delete Browsing History, re-flushed the DNS, then tried again, but still the same issue. Page is not redirecting, no message, no page refresh, nothing, when I click OK. Anything else I can do?

    Cheers

    Tuesday, May 1, 2012 9:13 AM
  • I have just tried this on the server where the Sharepoint site is hosted, but the same thing is happening there too. I am doing this using the customer login, but I dont believe that should matter? As the customer has Full Control access. As a side note, I tried to change the customer permission to Design, but the same thing happened there too - when I click OK, nothing was happening.

    I have also tried doing the same thing using a domain admin account, by setting up a sharepoint site for that domain admin account, then trying to create a template from that site, but same problem still. I am waiting at least 30 seconds, but nothing. Should I be waiting longer for something to happen?

    Aarrggh going crazy!

    Tuesday, May 1, 2012 9:18 AM
  • Have tried the same in Firefox now too, and same issue!
    Tuesday, May 1, 2012 9:21 AM
  • Hello, Usually it should give some sort of error like Access Denied or Unexpected Error or anything else.

    ok, let us first determine the scope of the issue:

    1. Try to do the same from different machine

    2. Try to do the same in different site collection as well as in different web application

    3. You already have tried different browsers, so now verify in IE if you get the small yellow 'Error on page' kind of error in your IE at bottom-left on the status bar? 

    Resolution/further troubleshooting will vary depending upon the scope of issue.



    Regards, Rohan --Please mark as "Answer" if the post resolve your issue--

    Tuesday, May 1, 2012 10:45 AM
  • Hi, thanks for replying.

    I have tried from 3 different machines, all Windows based machines.

    I have also tried this on other customer Sharepoint sites that I have created or others have created, but they all have the same issues. All of these Sharepoint sites are hosted on the same server. I dont have access to any other Sharepoint servers, just this one.

    I get no messages whatsoever in IE or Firefox or Chrome. Its as if the button isnt programmed to do anything at all, it just sits there. There is no error message, no yellow error icons, no page loading signs, nothing at all. Absolutely nothing.

    Not sure if it matters, but the URL for these sites is:

    http://portal.mycompanydomain.co.uk/personal/customerA
    http://portal.mycompanydomain.co.uk/personal/customerB

    etc...

    The permissions for each customer site are:

    CustomerName - Full control
    System Account - Limited access

    Thanks

    Tuesday, May 1, 2012 10:51 AM
  • ok, if possible, create another new site same as the others. SO it should be like http://portal.mycompanydomain.co.uk/personal/customerC

    Try to save site as template. In case if that works, then the problem is with these existing site settings which could be customized.

    In worst case if it does not work on new site as well, then the problem could be with the global settings and need in-depth troubleshooting.


    Regards, Rohan --Please mark as "Answer" if the post resolve your issue--

    Tuesday, May 1, 2012 11:36 AM
  • Hi, I have tried this already. The way I am creating sites is by logging into the main Sharepoint site (http://portal.mycompanydomain.co.uk) as different people, and this presumably creates a site for them? This too doesnt work. Although, with these new sites, the only difference is that there is one additonal permission in the Advanced Permissions page, which is:

    NT AUTHORITY\authenticated users - Read

    Anything else it could be?

    Have just noticed something else too. The IT guy (who has left a while back, and left me with all the Sharepoint stuff) set up a batch file which runs as a scheduled task. It copies files from the customer's folder in our fileshare drive, to the customers 'Documents' document library (which is created for each new customer manually). This is not running either. I get an error message which says:

    The remote server returned an error: <401> Unauthorised

    It seems like there may be an issue with permissions somewhere, but I am not sure where to look to find it. The batch file runs as a domain admin user. This domain admin user has Full Control settings for the fileshare folder where the files are kept. How do I make sure this domain admin user also has the proper permissions to the Sharepoint site, so that the file copy process works? I have tried to add the domain admin user to the customer sharepoint site in the Advanced Permissions page, but again, when I click OK to add the user nothing happens.

    Thanks

    

    Tuesday, May 1, 2012 11:42 AM