locked
Failed to load DataSet because of the following error RRS feed

  • Question

  • User-179702945 posted

    Hi,

       I am getting this error when i am opening  My dataset Design View



    One or more errors encountered while loading the designer. The errors are listed below. Some errors can be fixed by rebuilding your project, while others may require code changes.

    Could not load file or assembly 'System.Web, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a' or one of its dependencies. The system cannot find the file specified.



    at System.ModuleHandle.ResolveMethod(Int32 methodToken, RuntimeTypeHandle* typeInstArgs, Int32 typeInstCount, RuntimeTypeHandle* methodInstArgs, Int32 methodInstCount)
    at System.ModuleHandle.ResolveMethodHandle(Int32 methodToken, RuntimeTypeHandle[] typeInstantiationContext, RuntimeTypeHandle[] methodInstantiationContext)
    at System.Reflection.CustomAttributeData..ctor(Module scope, CustomAttributeRecord caRecord)
    at System.Reflection.CustomAttributeData.GetCustomAttributes(Module module, Int32 tkTarget)
    at System.Reflection.CustomAttributeData.GetCustomAttributes(Assembly target)
    at System.Resources.ResourceManager.GetNeutralResourcesLanguage(Assembly a, UltimateResourceFallbackLocation& fallbackLocation)
    at System.Resources.ResourceManager.InternalGetResourceSet(CultureInfo culture, Boolean createIfNotExists, Boolean tryParents)
    at System.Resources.ResourceManager.GetString(String name, CultureInfo culture)
    at Microsoft.VisualStudio.Web.SR.GetString(String name, Object[] args)
    at Microsoft.VisualStudio.Web.WebForms.DataEnvironment.System.ComponentModel.Design.Data.IDataEnvironment.get_Connections()
    at Microsoft.VSDesigner.VSDesignerPackage.AppSettingsHelper.GetConnectionsViaDataEnvironment(IDataEnvironment dataEnvironment)
    at Microsoft.VSDesigner.VSDesignerPackage.GlobalConnectionService.Microsoft.VSDesigner.VSDesignerPackage.IGlobalConnectionService.GetConnections(IServiceProvider serviceProvider, Project project)
    at Microsoft.VSDesigner.DataSource.DesignConnection.GetConnectionFromAppSettings(String objectName, String propertyName)
    at Microsoft.VSDesigner.DataSource.DesignConnection.get_ConnectionStringObject()
    at Microsoft.VSDesigner.DataSource.DbSource.set_Connection(IDesignConnection value)
    at Microsoft.VSDesigner.DataSource.DesignDataSource.SetConnectionProperty(Source source)
    at Microsoft.VSDesigner.DataSource.DesignDataSource.ReadXmlSchema(DataSourceXmlTextReader xmlReader)
    at Microsoft.VSDesigner.DataSource.DesignDataSource.ReadXmlSchema(TextReader textReader)
    at Microsoft.VSDesigner.DataSource.Designer.DataSourceSerializationService.DeserializeToDataSource(String filePath, Object serializationData)
    at Microsoft.VSDesigner.DataSource.ProjectDataSourceDescriptor.LoadDataSource()
    at Microsoft.VSDesigner.DataSource.ProjectDataSourceDescriptor.Init(IServiceProvider provider, IVsHierarchy primaryHierarchy, UInt32 primaryItemId, Object primaryDocDataObject, UInt32 docCookie, IVsInvisibleEditor invisibleEditor, IDesignerHost host)
    at Microsoft.VSDesigner.DataSource.ProjectDataSourceStorage.EnsureInvisibleEditor(ProjectItem dsProjectItem, Boolean ensureWritable, Boolean createInvisibleEditor)
    at Microsoft.VSDesigner.DataSource.ProjectDataSourceStorage.GetDataSourceInternal(Object caller, ProjectItem dsProjectItem, Boolean ensureWritable, Boolean createInvisibleEditor)
    at Microsoft.VSDesigner.DataSource.Designer.DataSourceDesignerLoader.HandleLoad(IDesignerSerializationManager serializationManager)


    also i am not able to see the controls in .aspx page Desin view and not able to run application. If i run my application i getting this error

    File NotFoundException was unhandled

    Could not load file or assembly 'System.Web, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a' or one of its dependencies. The system cannot find the file specified.

    I am using Visual studio 2005 SP2.

    Can anyone help me to resolve this problem.

    Thanks,

    Berna




    Thursday, June 24, 2010 3:14 AM

Answers

  • User-1203469223 posted

    Do you have a reference to System.Web ? 

    If it is already there, just remove it and re-add it... 

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Friday, June 25, 2010 7:27 AM