none
Text for some (not all) content controls (Word 2010) disappears after saving to SharePoint RRS feed

  • Question

  • I use three content controls (document properties) in a Word 2010 document: Subject, Company, and Manager. The Subject content control maintains the place-holder value I put in every time I save/check-in to SharePoint. However, the Company and Manager content controls will not save the place-holder text I enter. I've tried this with tracked changes on and off. When I check it in, the document shows the place-holder values are still there. However, if I close the document and check it out again, those two content controls don't have the place-holder text, only the default "[Company]" and "[Manager]". I've also tried adjusting the Properties of individual content controls, to no avail. Does anyone know what the issue may be? Thank you.

    FYI, I have used the same content controls in other similar documents (they all share the same style set and a similar layout), but have never had any trouble. But then, I wasn't working with them in SharePoint at the time either.

    Scott


    Scott Stocking

    Wednesday, February 11, 2015 5:54 PM

Answers

  • I found the setting I needed. For whatever reason, the particular document was set not to save personal information. Not sure how the program distinguishes personal information properties from generic properties, though.

    Scott


    Scott Stocking

    • Marked as answer by ScottSox Wednesday, February 11, 2015 8:20 PM
    Wednesday, February 11, 2015 8:20 PM

All replies

  • More information: I just checked the version of the file I had on my hard drive, and it's doing the same thing there. However, the other similar documents in the same folder on my hard drive are not behaving this way, so apparently it's not specifically a SharePoint issue.

    Scott


    Scott Stocking

    Wednesday, February 11, 2015 6:00 PM
  • I found the setting I needed. For whatever reason, the particular document was set not to save personal information. Not sure how the program distinguishes personal information properties from generic properties, though.

    Scott


    Scott Stocking

    • Marked as answer by ScottSox Wednesday, February 11, 2015 8:20 PM
    Wednesday, February 11, 2015 8:20 PM
  • Could you tell us where the setting is?

    You have Failed this City --Arrow :)

    Tuesday, February 17, 2015 8:18 AM
  • Hi Oliver

    Try Trust Center/Privacy Options, under Document specific settings


    Cindy Meister, VSTO/Word MVP, my blog

    Tuesday, February 17, 2015 3:56 PM
    Moderator