locked
WCF Test Client error RRS feed

  • Question

  • I have a WebApplication serving some WCF Services. When I run my app locally, I can connect with WcfTestClient.

    When I run my app in the cloud, the service is still avaliable, and clients can connect, however when I try to connect with WcfTestClient app I get the following error. (metadata publishing is enabled)

    Why do I get this?

    Error: Cannot obtain Metadata from http://XXX.cloudapp.net/Services/XXXService.svc If this is a Windows (R) Communication Foundation service to which you have access, please check that you have enabled metadata publishing at the specified address.  For help enabling metadata publishing, please refer to the MSDN documentation at http://go.microsoft.com/fwlink/?LinkId=65455.WS-Metadata Exchange Error    URI: http://XXX.cloudapp.net/Services/XXXService.svc    Metadata contains a reference that cannot be resolved: 'http://XXX.cloudapp.net/Services/XXXService.svc'.    <?xml version="1.0" encoding="utf-16"?><Fault xmlns="<Value>Sender</Value><Subcode><Value">http://www.w3.org/2003/05/soap-envelope"><Code><Value>Sender</Value><Subcode><Value xmlns:a="a:ActionNotSupported</Value></Subcode><Reason><Text">http://www.w3.org/2005/08/addressing">a:ActionNotSupported</Value></Subcode></Code><Reason><Text xml:lang="en-US">The message with Action 'http://schemas.xmlsoap.org/ws/2004/09/transfer/Get' cannot be processed at the receiver, due to a ContractFilter mismatch at the EndpointDispatcher. This may be because of either a contract mismatch (mismatched Actions between sender and receiver) or a binding/security mismatch between the sender and the receiver.  Check that sender and receiver have the same contract and the same binding (including security requirements, e.g. Message, Transport, None).</Text></Reason></Fault>HTTP GET Error    URI: http://XXX.cloudapp.net/Services/XXXService.svc    The document at the url http://XXX.cloudapp.net/Services/XXXService.svc was not recognized as a known document type.The error message from each known type may help you fix the problem:- Report from 'XML Schema' is 'The document format is not recognized (the content type is 'text/html; charset=UTF-8').'.- Report from 'http://XXX.cloudapp.net/Services/XXXService.svc' is 'The document format is not recognized (the content type is 'text/html; charset=UTF-8').'.- Report from 'DISCO Document' is 'There was an error downloading 'http://rd00155d4XXX/Services/XXXService.svc?disco'.'.  - The remote name could not be resolved: 'rd00155d494XXX'- Report from 'WSDL Document' is 'The document format is not recognized (the content type is 'text/html; charset=UTF-8').'.

    Saturday, July 14, 2012 1:06 PM

Answers

All replies