locked
How to uninstall metro device meta data for more option

    General discussion

  • I have got device meta data for my camera app from my team.I installed the device metadata using meta data authoring tool.since this device app keeps on changing as team is working on it,i regularly do update the device metadata everyday.
    so evrytime I update the metadata using authoring tool it creates new entry.so now i have lot many entry for same device app

    %programdata%\Microsoft\Windows\DeviceMetadataStore

    %programdata%\Microsoft\Windows\\DeviceMetadataCache\dmrccache\multilocmy 

    I have deleted all the entries in both store and Cache and installed the fresh metadata.now it is not showing custom more option.

    I followed the following steps

    1. Installed package for metro device app

    2. I  have a developer license installed

    3. run bcdedit -set testsigning on (and restart)
    4. uninstall the camera in devmgr
    5. unplug camera
    6. using metadata authoring tool to publish the meta data in 
            - %programdata%\Microsoft\Windows\DeviceMetadataStore
        - plug in the camera and I can metadata info appear under the cache
            - %programdata%\Microsoft\Windows\DeviceMetadataCache\dmrcache
           

    after following these steps also custom more option window is not coming up.

    I think it is the problem with manually removing the device meta data from system.

    Do we have any tool to uninstall the device metadata?

    Is there anything I missed in Uninstalling and installing the App and meta data?

    Saturday, September 22, 2012 4:11 PM

All replies

  • I Guess the problem is due to multiple copies of metadata of a device App for device(camera).
    I checked all the metadata in

    %programdata%\Microsoft\Windows\DeviceMetadataStore 
    using Metadata Authoring tools and compared the package name and deleted it if they were same. I deleted all related entry from

    %programdata%\Microsoft\Windows\DeviceMetadataCache\dmrccache\multiloc 
    one can also compare package Name in SoftwareInfo.xml.
    I re installed the metadata.now it is working fine.

    Please confirm my finding whether multiple copies of metadata for same device/device app cause problem.
    Monday, September 24, 2012 12:45 PM
  • Chris,

    It could cause a problem.  Are you still seeing the issue?

    Best Wishes - Eric

    Tuesday, September 25, 2012 12:42 AM
    Moderator
  • Thanks Eric,

    No I am not facing problem now....But I don't have explanation for it..it is just like trick...anyway good for me.If you get some info on it,share with me.

    thanks

    Tuesday, September 25, 2012 11:12 AM
  • Thanks Chris.  If I get something I will let post it here.

    Best Wishes - Eric

    Tuesday, September 25, 2012 3:51 PM
    Moderator