locked
Infopath Form with Web Service cann't open by web browser RRS feed

  • Question

  • Dears,

    I have a problem when i open form from Form Library it opens by InfoPath client not in browser.

    I use web service to retrieve data from database, i create a Data Connection Libaray (DCL) and apply all choices from Central Administration --> General Application Settings --> InfoPath Forms Services --> Configure InfoPath Forms Services, but still is opening from InfoPath Client

    also i use K2 BalckPeal to publish form and i set option to publish form in web browser.

    Please i need your help to open the form in web browser, Thanks in Advance.

     


    • Edited by Omar Nazzal Monday, February 6, 2012 12:45 PM
    Monday, February 6, 2012 8:56 AM

Answers

  •  

    Hi Ejsumi,

    In DataConnection library items has User credential as plain text (Embedded Authentication). For security reason it's block all the across domain access. Please as the following steps.

         1. Login into Central Admin

         2. click General Application Settings.

         3. On the General Application Settings ->  InfoPath Forms Services section -> click Configure InfoPath Form Services.

         4. Configured the necessary changes in that page,

         5. Especially, In the "Embedded SQL Authentication" section, select the Allow embedded SQL authentication check box to allow forms to use embedded SQL Server credentials.

         6. Restart the IIS and Try it again.

    About your second picture, I think it is may be some rules is not right. After my search, you can get the current user as the following link in InfoPath.

    http://blogs.microsoft.co.il/blogs/itaysk/archive/2007/04/05/InfoPath-_2D00_-Get-the-current-user-without-writing-code.aspx

    Thanks,

    Jack

    Thursday, February 9, 2012 1:58 AM
    Moderator

All replies

  •  

    Hi Omar,

    Are you have configure in SharePoint Form Library.  Settings->Form library Settings->Advanced Settings->Browser-enabled Documents->Display as Web Page. This will force open your form in browser .So, Please ensure check this.

    Here is a link about how to configure , you can refer to it.

    http://www.bizsupportonline.net/browserforms/allow-force-browser-enabled-form-open-in-browser.htm

    Thanks,

    Jack


    Wednesday, February 8, 2012 3:39 AM
    Moderator
  • Hi Jack,

    Yes, i have configured it and every thing in sharepoint from Central Administration Settings and Library Setting.

    please note that i publish web service in site differ from sharepoint site.

    Thanks,

    Omar 


    My Name Is Omar

    Wednesday, February 8, 2012 7:11 AM
  • Hi Omar,

    When you publish the form to SharePoint in InfoPath 2007, there is a checkbox called “Enable this form to be filled out by using a browser”, In default, this is checked. If this is not checked, the form will can’t open in browser. You said you publish this form by K2 BalckPeal, may be it is have not check this item. You said you publish web services differ from SharePoint Site, but there is no relation with open it in browser.

    Thanks,

    Jack

    Wednesday, February 8, 2012 8:17 AM
    Moderator
  • Hi Jack,

    Please find below screenshot for error:


    My Name Is Omar

    Wednesday, February 8, 2012 1:19 PM
  • Hi Jack,

    and i use InfoPath 2010 and SharePoint 2010.

    Thanks in advance,

    Omar


    My Name Is Omar

    Wednesday, February 8, 2012 1:21 PM
  •  

    Hi Ejsumi,

    In DataConnection library items has User credential as plain text (Embedded Authentication). For security reason it's block all the across domain access. Please as the following steps.

         1. Login into Central Admin

         2. click General Application Settings.

         3. On the General Application Settings ->  InfoPath Forms Services section -> click Configure InfoPath Form Services.

         4. Configured the necessary changes in that page,

         5. Especially, In the "Embedded SQL Authentication" section, select the Allow embedded SQL authentication check box to allow forms to use embedded SQL Server credentials.

         6. Restart the IIS and Try it again.

    About your second picture, I think it is may be some rules is not right. After my search, you can get the current user as the following link in InfoPath.

    http://blogs.microsoft.co.il/blogs/itaysk/archive/2007/04/05/InfoPath-_2D00_-Get-the-current-user-without-writing-code.aspx

    Thanks,

    Jack

    Thursday, February 9, 2012 1:58 AM
    Moderator