none
the microsoft ace oledb 12.0 provider is not registered on the local machine RRS feed

  • Question

  • Hi,

    I have a project that needs to connect to a dbase III file using VS 2017 – VB, Community version (free one). Access mdf are also being connected to. I have been trying to resolve error message “The Microsoft Ace OLEDB 12.0 provider is not registered on the local machine” I have run Microsoft Access Database Engine 2010 Redistributor as most threads call for. I have found the assembly aceoledb.dll on my computer but I could not add it as a reference(dll)  to the program's reference list using the add reference interface, or in the Project->Properties window. I'm just not sure where the provider is or where to find it, little lone what it's name is. I'm totally lost.

    I have a 64 bit windows 8.1 OS. But Visual Studio was set up in the folder ''Program File(86)'. I was only able to download Microsoft Access Database Engine 2010 Redistributor for 32 bit systems. 64 was not allowed.

    Up until a few days ago, before I accidentally wiped out much of my programs and data, I had a vb project working fine in VS 2017 that was using dbase III Plus file and mdb databases and Excel files. I think I'm going in the right direction with ' Microsoft Access Database Engine 2010 Redistributor'. But after that I'm lost. I can not figure out how to register the provider, or what the assemble might be named.

    Any help would be greatly appreciated.

    Wednesday, March 7, 2018 2:58 AM

All replies

  • Hi BOB5461A,

    Please install  Microsoft Office Access database engine 2007, which does not installed on your machine by default and check if it works for you.

    Best regards,

    Zhanglong


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.


    Wednesday, March 7, 2018 9:22 AM
    Moderator
  • Have you tried setting the Platform option (Build...Configuration Manager...) to x86. This will cause the app to run 32-bit under 64-bit Windows and use the 32-bit ACE OLEDB Provider.

    It sounds to me like your app is running 64-bit by default.


    Paul ~~~~ Microsoft MVP (Visual Basic)

    Wednesday, March 7, 2018 10:18 PM
  • Hi, I would like to thank both Zhanglong Wu and Paul for their replies. I did try both recommendations but I still did not think I had found the solution to my problem. As it turns out, the released version of my app was sitting in a new folder, “x86”, located in the Bin folder that contains the Debug and Release folders. I was expecting it to be in the Release folder. This must have happened when I switched from the platform being “Any CPU “to “Active(x86).” This should be of interest to others that are experiencing this same issue that I did. But again thanks to both Zhanglong Wu and Paul for their assistance.


    Newbie

    Saturday, March 10, 2018 7:32 PM
  • Hi Bob5461,

    I am glad to know that resolve the issue and thank you for sharing the solution to us, please mark it as answer, it will be beneficial to other communities who have the similar issue.

    Best regards,

    Zhanglong


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Monday, March 12, 2018 1:11 AM
    Moderator