none
Unable to load/set datasource on crystal report RRS feed

  • Question

  • I am using Visual Studio 2010 asp.net (.Net Framework 4.0) and crystal report ver 13.0.0 for my project. It is running fine on my local system. But on server (Windows Server 2012 R2 - 64 bit, IIS - 8), it is getting "Connection Time Out" or "Server hang-up" when trying to set DataSource. But if I load another report without DataSource, it performing well. Below is my code.

    //Getting Data
    SqlCommand _cmd = new SqlCommand("...SQL...", new SqlConnection("...ConnectionString..."));
    _cmd.CommandType = CommandType.Text;
    SqlDataAdapter adp = new SqlDataAdapter(_cmd);
    DataTable dt = new DataTable("MyDataTable");
    adp.Fill(dt);
    
    //Preparing Report
    ReportDocument _rpt = new ReportDocument();
    _rpt.Load("~/MyReport.rpt");
    _rpt.SetDataSource(dt); /*Problem on this line*/

    I search on this issue, found lots of threads. But none of that resolved my issue.

    Error Log 1:

    The description for Event ID 4353 from source Crystal Reports cannot be found. Either the component that raises this event is not installed on your local computer or the installation is corrupted. You can install or repair the component on the local computer. If the event originated on another computer, the display information had to be saved with the event. The following information was included with the event: The keycode assembly, BusinessObjects.Licensing.KeycodeDecoder.dll, cannot be loaded. the message resource is present but the message is not found in the string/message table

    Error Log 2:

    Faulting application name: w3wp.exe, version: 8.5.9600.16384, time stamp: 0x5215df96 Faulting module name: crqe.dll, version: 13.0.0.99, time stamp: 0x4cc40cb3 Exception code: 0xc0000005 Fault offset: 0x000000000017a197 Faulting process id: 0xaf8 Faulting application start time: 0x01d5997be3f9f78c Faulting application path: c:\windows\system32\inetsrv\w3wp.exe Faulting module path: C:\Program Files (x86)\SAP BusinessObjects\Crystal Reports for .NET Framework 4.0\Common\SAP BusinessObjects Enterprise XI 4.0\win64_x64\crqe.dll Report Id: d576cb9a-056f-11ea-81a7-00155d7dcb18 Faulting package full name: Faulting package-relative application ID:

    Please help me to fix this issue... Thanks in advance.

    What I have tried:

    i) On my server I install crystal report runtime 13.0 (64 bit) & CR for VS2010
    ii) Copy crystalreportviewers13 & aspnet_client on wwwroot
    iii) Grant permission of IIS_IUSRS & NETWORK SERVICE on Temporary Folders


    Wednesday, November 13, 2019 4:31 PM