locked
Running Import Export wizard as Power User RRS feed

  • Question

  • We have encounted a problem using the Import/Export wizard in SQL 2005 Management Studio (Right click on Database > Tasks > Import Data).  One of our users that is setup as a local Power User on his computer can not run the Import/Export wizard.  He is getting the following error:

    General access denied error

     

     

    ------------------------------

    Program Location:

     

       at Microsoft.SqlServer.Dts.Runtime.Wrapper.ApplicationClass.get_DBProviderInfos()

       at Microsoft.SqlServer.Dts.DtsWizard.DTSWizard.GetDtsDbProviderInfos(WizardInputs wizardInputs)

       at Microsoft.SqlServer.Dts.DtsWizard.DataSourceCombo.PopulateProviders(Boolean fSources, WizardInputs wizardInputs)

       at Microsoft.SqlServer.Dts.DtsWizard.Step1.OnInitializePage(EventArgs e)

       at Microsoft.SqlServer.Management.UI.WizardPage.RaiseEnterPage()

       at Microsoft.SqlServer.Management.UI.WizardForm.NextPage(WizardPage nextPage)

       at Microsoft.SqlServer.Management.UI.WizardForm.Next_Click(Object sender, EventArgs e)



    If we set him up as a local Administrator on his computer it runs fine.  What exactly does this program need access to in order to run?  Is it writing to the registry?  If so what keys does it need access to?
    Tuesday, July 7, 2009 1:13 PM

All replies

  • I am having the exact same issue as a Limited User on a WinXP Pro workstation running Microsoft SQL Management Studio 2005 (SMS; full), whether I launch DTSWizard.exe manually or by clicking Import / Export in SMS 2005.

    ===================================
    This wizard will close because it encountered the following error: (Microsoft SQL Server)
    ------------------------------
    For help, click: http://go.microsoft.com/fwlink?ProdName=Microsoft+SQL+Server&ProdVer=9.00.4035.00&EvtSrc=Microsoft.SqlServer.Management.UI.WizardFrameworkErrorSR&EvtID=UncaughtException&LinkId=20476
    ===================================
    General access denied error
    

    As you indicated, launching SMS 2005 via "Run As" with local admin credentials does *not* produce this issue.

    Apparently, the issue is when the DTS Wizard tries to pull a list of ODBC providers, as seen in the error text "get_DBProviderInfos()". Clearly, it's a permissions issue. But, as you asked, *what* is restricted ... a Registry key, Folder, File?

    Typically, ODBC configuration types are stored in the Registry at:
        HKLM\SOFTWARE\ODBC\ODBCINST.INI\

    While saved ODBC connections are stored in the Registry at:
        HKLM\SOFTWARE\ODBC\ODBC.INI\

    And / or under C:\Program Files\Common Files\ODBC\Data Sources\

    As the Limited User, I am able to open Control Panel > Administrative Tools > Data Sources (ODBC) without an issue ... as well as the above mentioned locations. However, when I tried to add a new connection using the Data Source wizard and choosing the "SQL Server" driver, my saved DSN was no where to be found ... even though no error was generated when I clicked save. Looking at the above path's security, my Limited User account only had READ permissions. I changed that using:  cacls "C:\Program Files\Common Files\ODBC\data sources" /E /P mylimiteduser:W and now I was able to create DSN's with that wizard. I suppose I could have clicked the Set Directory button and chosen an accessible path but I prefer keeping the Microsoft default path.

    SMS 2005 DTSWizard.exe, however, is still producing the error.

    I'll continue researching...



    • Edited by Westchaser Wednesday, August 12, 2009 3:02 AM
    Wednesday, August 12, 2009 2:18 AM
  • I had the exact same problem for months until I stumbled upon this completely unrelated article: http://support.microsoft.com/kb/913817

    I ran the code in the article and found dozens of keys with incorrect permissions.  I opened regedit as an admin and gave all users Full Control to everything under HKEY_LOCAL_MACHINE\Software\Classes\CLSID. That may have been overkill, but it solved this problem and several others.

    • Proposed as answer by Britton1 Wednesday, May 12, 2010 7:07 PM
    Wednesday, May 12, 2010 7:03 PM