locked
Svchost error at shutdown RRS feed

  • Question

  • Hi,
    I encountered this error when shutding down our device. I see this we I`ve got the label saying Windows is saving your setting. I get a mesagebox with a svchost error saying  that some memory address could not be read. I checked on the web on what could be the cause and my research ended with that was related with windows update, which is not included in WES and not even activated in my image. I don`t see any log in the event viewer. What is causing this and how can it be solved?

    Regards 
    Thursday, November 19, 2009 3:59 PM

All replies

  • Hi,

    I have encountered a similar (or maybe the same) problem.  My WES image occasionally shows the following message when I shutdown the system.

    svchost.exe -- application error
    the instruction at "0x7c92c288" reference memory at "0x00000008". the memory could not be 'read'

    I search the message on the web and found an web forum:
    http://forum.ru-board.com/topic.cgi?forum=62&topic=4310&start=580

    Unfortunately I can not understand the language in that forum. But it mentioned KB 971657 and wkssvc.dll in one reply.

    And I did install WES security update which includes KB
    971657 in the image I saw the problem. And the wkssvc.dll in the update has the same version number as mentioned in that forum.

    I don't know how to further debug this issue. Does anyone has any clue about how to identify the problem and how to solve it?

    Thanks and regards,
    Charles




    Tuesday, January 5, 2010 6:07 AM
  • The post that you found recommends the following steps.
    Download the hotfix:
    http://www.microsoft.com/downloads/details.aspx?familyid=9c0e5bff-c248-4e87-a83b-82ba52f5299d&displaylang=en

    Extract the content of the WindowsXP-KB971657-x86-ENU.exe to the temp folder:
    WindowsXP-KB971657-x86-ENU.exe  /x
    This hotfix includes 4 versions of the same file
     http://support.microsoft.com/default.aspx/kb/971657

    For all supported x86-based versions of Windows XP
    File version File size Date Time Platform SP requirement Service branch
    Wkssvc.dll 5.1.2600.3584 132,096 10-Jun-2009 06:32 x86 SP2 SP2GDR
    Wkssvc.dll 5.1.2600.3584 134,144 10-Jun-2009 06:26 x86 SP2 SP2QFE
    Wkssvc.dll 5.1.2600.5826 132,096 10-Jun-2009 06:14 x86 SP3 SP3GDR
    Wkssvc.dll 5.1.2600.5826 134,144 10-Jun-2009 06:17 x86 SP3 SP3QFE

    Copy the file from GDR subfolder to you image based on the level of SP of you image.
    For example:
    C:\WindowsXP-KB971657-x86-ENU\SP2GDR\wkssvc.dll for SP2 image
    or
    C:\WindowsXP-KB971657-x86-ENU\SP3GDR\wkssvc.dll for SP3 image

    Could you please give it a try.
    Thank you,
    Sergey
    • Proposed as answer by Hirotsugu Thursday, February 25, 2010 4:33 AM
    Tuesday, January 5, 2010 8:38 AM
  • The KB971657 is already installed in my image. So right now I am considering downgrade the "SMB Redirector" component to previous version and see if this issue can be solved.
    Tuesday, January 5, 2010 10:16 AM
  • Hi.

    I have same trouble. When the system shutting down, I get svchost.exe error.

    svchost.exe -- application error
    the instruction at "0x7c92c288" reference memory at "0x00000008". the memory could not be 'read'

    My environment is Windows XP Embedded SP3 with Japanese Language Support.

    I tried to disable the Workstation Service on my XPe image. 
    Then this svchost.exe error does not happen. I have checked boot/shutdown cycle testing of 50 times.
    But this solution is no good.

    Do you have other good solution? 
    Please help me kindly.
    Tuesday, February 9, 2010 3:20 PM
  • Thursday, February 25, 2010 4:36 AM
  • Ok, but if I have Windows Embedded Standard with all the latest QFEs and that I still see this issue, do I have to install those update? Those security updates should have been included with the WES QFEs, right?

    I'll give it a try and see if I still see that intermittent & totally random error!

    Regards
    Thursday, February 25, 2010 10:34 PM
  • I replaced the file Wkssvc.dll as Sergey Kireev - MS post, but this issue still here. Anyone has any other sollution?

    I use WES image too, and got the same error message when shutdown the OS.

    svchost.exe -- application error
    the instruction at "0x7c92c288" reference memory at "0x00000008". the memory could not be 'read'.

    My system drive is compressed, if I uncompress system drive, this issue looks like disappear( I tested 20 times), but our system has limited space, we must use compressed drive. 

    Wednesday, June 2, 2010 5:35 PM
  • You can solve by copying DQI's "wkssvc.dll" or XP Pro's "wkssvc.dll"!!

    Thursday, June 3, 2010 7:20 AM
  • Thank you very much.

    Andrey Urusov

    Friday, December 27, 2013 8:05 AM