.NET Framework 4.0 installation - Fatal error 0x80070643 Windows 7 RRS feed

  • Question

  • Hi, I am running Windows 7 ultimate SP1. I downloaded .NET Framework from http://www.microsoft.com/en-us/download/details.aspx?id=17851.

    I get Fatal error 0x80070643. I have tried installing as Run As Administrator, disabled virus scan ...  I would appreciate any assistance.

    This is from the log file, please let me know if you need anything else. (The entire log file was too large to include here)

    [9/25/2012, 18:12:49] Returning IDOK. INSTALLMESSAGE_ERROR [There is a problem with this Windows Installer package. Please refer to the setup log for more information. ]
    [9/25/2012, 18:12:54]MSI (C:\28ba83b0f09d4eafe7\netfx_Extended_x64.msi) Installation failed. Msi Log: Microsoft .NET Framework 4 Setup_20120925_181144654-MSI_netfx_Extended_x64.msi.txt
    [9/25/2012, 18:12:54]PerformOperation returned 1603 (translates to HRESULT = 0x80070643)
    [9/25/2012, 18:12:54]OnFailureBehavior for this item is to Rollback.
    [9/25/2012, 18:12:54] Action complete
    [9/25/2012, 18:12:54]Final Result: Installation failed with error code: (0x80070643), "Fatal error during installation. " (Elapsed time: 0 00:01:10).
    [9/25/2012, 18:12:54] Action complete
    [9/25/2012, 18:12:54] Action complete
    Wednesday, September 26, 2012 3:36 AM


  • There isn't even a Security folder

    I went ahead and changed ownership on C:\Windows\Microsoft.NET\Framework64\v4.0.30319\ and everything below it.

    I ran installation again and OMG it worked! Only took 8 weeks ... Given that I've been the only one to use this system since it was installed and am an admin, I have no idea how it got so mucked up. ...

    Thank you!

    Wednesday, November 21, 2012 6:00 AM

All replies

  • Please try this sequence of steps. Note that it uses the standalone installer vs. the web installer, and also shows how to provide complete log sets (which will be needed if the steps fail).

    Follow ALL these steps exactly:

    Before trying to install .NET Framework 4.0, execute this command from an ELEVATED Command Prompt provided by the .NET Framework Team:

    "This issue is likely caused by a bad ACL on assembly\tmp folder. After installing updates, the ACL propagates to installed assembly folders in both 4.0 & legacy GAC.  If those updates were installed by WU or another user, the propagated ACL will prevent install of the same assembly by the current user.

    A work around would be to reset the ACL on GAC dirs.

    for /F %D in ('dir %WINDIR%\assembly %WINDIR%\Microsoft.NET\assembly /s /b /a:d') do takeown /F %D && icacls %D /reset /T"

    After running that command, follow these steps:

    Please follow these instructions exactly:

    1. Download a fresh copy of the standalone installer for .NET Framework 4.0:


    2. Also, clear your %temp% directory and disable your AV software.

    The %temp% directory is a reference to the Temp folder associated with the current user. To clear it, do the following:

    Sign on to your system with the Administrator user account you will use to run the installer. Click the Start Orb and type %temp% in the search box. The search results will show the Temp folder you want. Click on the Temp folder to open it in Windows Explorer, then delete the entire contents.

    3. Run the standalone installer from step 1 As Administrator.

    Note: Just using an administrator account is NOT enough. To activate full privileges, you must right-click the installer, then select Run as administrator.

    If the install fails, provide complete install logs as follows:

    Please collect your install logs with this:


    After you run Collect.exe, you'll find vslogs.cab in your %temp% directory. Please upload vslogs.cab to a public site, like SkyDrive, and post the link here.

    Wednesday, September 26, 2012 1:53 PM
  • Unfortunately after following your instructions exactly it still did not install. I have uploaded the vslogs.cab file to my skydrive public folder at https://skydrive.live.com/#cid=E76491ADA626B7DD&id=E76491ADA626B7DD%21153.

    Hope it can shed some light!

    Thursday, September 27, 2012 4:04 AM
  • Thanks pvdg42 for your kindly help.

    Hi Kerrie,

    From the error message you provided, you get the following error message during your installation process:

    09/26/12 21:54:06 DDSet_Error: Failed to install assembly C:\Windows\Microsoft.NET\Framework\v4.0.30319\Microsoft.VisualC.STLCLR.dll. IAssemblyCache->InstallAssembly() returned -2147024891.
    09/26/12 21:54:06 DDSet_Error: Failed to install assembly 'C:\Windows\Microsoft.NET\Framework\v4.0.30319\Microsoft.VisualC.STLCLR.dll' because of system error: Access is denied.

    Normally, you will get the above error message when the installer is corrupted or the user account does not have the required privilege. So, please double check again your installer and user account you are using.

    Please update me result once you finished it.


    Vicky Song [MSFT]
    MSDN Community Support | Feedback to us

    Thursday, September 27, 2012 7:20 AM
  • Thank you Vicky and pvdg42.

    I am running as a member of the local admin group. The computer is not a member of a domain. I ran the installation as Run As Administrator to get to the command prompt.

    Vicky, when you say to check if the installer is corrupted I'm not sure what I should be checking. I downloaded the .NET Framework 4.0 (full) program from http://www.microsoft.com/en-us/download/details.aspx?id=17718.

    Please advise, and thanks!

    Thursday, September 27, 2012 1:45 PM
  • Hi Kerrie,

    One simple way to check whether the installer is corrupted or not is to install it on another machine to see if you can get it installed successfully.

    If you still can't install it successfully, please use the collect.exe tool to re-collect the installation logs, and share me the vslogs.cab file again.


    Vicky Song [MSFT]
    MSDN Community Support | Feedback to us

    Friday, September 28, 2012 2:03 AM
  • Well I don't have another machine that doesn't have .NET Framework 4 installed, and at this point I'm a bit gunshy about uninstalling it elsewhere and seeing if a reinstall actually works :(

    I can download again from microsoft.com and try installing again on THIS machine and run collect again if you want. If it fails I guess that would indicate the installer on the download page is corrupt?

    Friday, September 28, 2012 2:16 AM
  • Hi Kerrie,

    I can install the .NET 4.0 successfully on my machine, so I think that the installer provided on that site is OK. For your scenairo, please make sure you do a complete download of the .NET 4.0 installer. Copy it to your local machine, then install it again. If the installation still failed, please collect the installation logs again and share me the vslogs.cab file.


    Vicky Song [MSFT]
    MSDN Community Support | Feedback to us

    Friday, September 28, 2012 8:55 AM
  • Hi Vicki,

    I wish I could say it worked this time but it didn't.

    I did a complete download and save as of the .NET 4.0 installer.

    Disabled anti-virus software

    cleared out %temp% directory

    went to command prompt using Run as Administrator

    Navigated to the folder where I had downloaded the installer.

    Ran, it failed and rolled back.

    Ran collection program.

    Uploaded vslogs.cab to https://skydrive.live.com/#cid=E76491ADA626B7DD&id=E76491ADA626B7DD%21153

    (The previous one is there also - renamed to vslogs120926.cab). Size of the new one is slightly smaller.

    Hope it tells us what I should do!

    Thanks, Kerrie

    Friday, September 28, 2012 2:18 PM
  • "Windows6.1-KB958488-v6001-x64.msu) failed with 0x240006 - (null)."

    "INSTALLMESSAGE_ERROR [There is a problem with this Windows Installer package."

    This situation could also indicate an issue with the Windows Installer in your Windows 7. You can ask about Windows Installer repair here:


    If that does not help, and Vicky has no other suggestions, you may be looking at an OS reinstall.

    Friday, September 28, 2012 5:11 PM
  • Hi pvdq42,

    I checked the integrity of msiexec.exe by running sfc. Here are the results:

    C:\Users\Kerrie>sfc /verifyfile=c:\windows\system32\msiexec.exe

    Windows Resource Protection did not find any integrity violations.

    Vicky, any ideas? I would prefer not to reinstall the OS and all my programs!

    Friday, September 28, 2012 7:58 PM
  • Thanks pvdg42 for your kindly help.

    Hi Kerrie,

    The installation error in the second vslogs.cab file is the same as the first one. I am sorry that I run out of ideas about your issue now. And I am trying to involve someone familiar with this topic to further look at this issue.


    Vicky Song [MSFT]
    MSDN Community Support | Feedback to us

    Monday, October 1, 2012 7:07 AM
  • Hi Vicki,

    I appreciate your trying to help on this. I hope you will be able to pass it along to someone sle!

    Monday, October 1, 2012 1:08 PM
  • I can see some corruption under the windows update log file. So please run the System Update Readiness Tool to fix the  Windows update.

    All supported x86-based versions of Windows 7


    Download the update package now.

    All supported x64-based versions of Windows 7

    Download the update package now.

    #) Download standalone installer for .Net Framework 4.0 from the official Microsoft website  and try the installation.


    #)  If it fails again then try to extract the standalone installer with the help of command:

    “dotNetFx40_Full_x86_x64.exe /x”

    #) Try the installation of .NET framework 4.0 Client Profile with:

    “netfx_Core_x64.msi” or “netfx_Core_x86.msi” (dependent on the OS)

    Command line would be :

    msiexec /I netfx_Core_x64.msi EXTUI=1
    msiexec /I netfx_Core_x86.msi EXTUI=1

    #) Try the installation  of .NET Framework 4.0 Extended with :

    “netfx_Extended_x64.msi” or “netfx_Extended_x86.msi” (dependent on the OS)

    msiexec /I netfx_Extended_x64.msi EXTUI=1

    msiexec /I netfx_Extended_x86.msi EXTUI=1

    Trevor Hancock (Microsoft)
    Please remember to "Mark As Answer" the replies that help.

    • Proposed as answer by 4N0N Tuesday, March 11, 2014 4:38 PM
    Wednesday, October 3, 2012 6:40 PM
  • Hi Trevor, thank you for the detailed instructions.

    I was able to run the Update Readiness Tool.

    I then ran the standalone installer for .Net Framework 4. It failed.

    I then extracted the files and installed the client profile.

    Last I tried .NET Framework 4.0 Extended:

    msiexec /I netfx_Extended_x64.msi EXTUI=1

    Which failed. GUI error popup says:

    There is a problem with the Windows Installer package. Please refer to the setup log for more information

    I have put vslogs.cab in my skydrive public folder at https://skydrive.live.com/#cid=E76491ADA626B7DD&id=E76491ADA626B7DD%21153

    Here is the problem signature.

    Problem signature:

    Problem Event Name: VSSetup

    Problem Signature 01: Microsoft .NET Framework 4 Setup

    Problem Signature 02: 4.0.30319

    Problem Signature 03: 10.0.30319.1

    Problem Signature 04: 1

    Problem Signature 05: netfx_Extended_x64.msi

    Problem Signature 06: Install_I_Interactive_Error

    Problem Signature 07: 1603

    Problem Signature 08: 0

    Problem Signature 09: ProcessAssembly

    OS Version: 6.1.7601.

    Locale ID: 1033

    Thursday, October 4, 2012 5:23 AM
  • These errors are either due to some corruption at the OS level or due to corrupted download for .NET Framework 4.0.

    Please re-download the .NET Framework on other machine and try installation with the new source. It would be better If you use web installer (http://www.microsoft.com/en-us/download/details.aspx?id=17851)

    If it fails again, then try the below steps of steps:

    • Please make sure that windows update is running and there is no pending updates on the machine
    • Check the value of the registry key :

    HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\WinTrust\Trust Providers\Software Publishing\State

    The value should be 23c00.

    State = 0x00023c00 - ‘Check for publisher’s certificate Revocation’ Checked

    • Run the SFC /Scannow

    • Re-initializing the windows installer engine:

    Msiexec /unregister

    Msiexec /regserver

    C:\Windows\SysWOW64\msiexec.exe /unregister

    C:\Windows\SysWOW64\msiexec.exe /regserver

    • Re-start the windows installer service and windows modules installer.


    Trevor Hancock (Microsoft)
    Please remember to "Mark As Answer" the replies that help.

    Monday, October 8, 2012 3:52 PM
  • HI Trevor,

    Thanks I will go through these steps. But I did check the registry just now and I don't even have a registry key named HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\WinTrust

    - could that be part of the issue?

    Monday, October 8, 2012 10:24 PM
  • Hi Trevor,

    I downloaded .NET Framework (web installer) to another machine.

    I connected to that through a mapped drive and ran the installation (elevated command prompt). It failed.

    I verified the Windows Update service was running and there were no pending updates (e.g. requiring a reboot).

    I checked the value of the registry key (found it this time); it was 23c00

    Ran SFC /Scannow (elevated command prompt). Results:

    Windows Resource Protection did not find any integrity violations.

    Reinitialized the Windows Installer engine per your instructions (elevated command prompt), restarted Windows Installer service and Windows Modules Installer service (services.msc).

    Verified AV software was disabled.

    Reran the .NET Framework (web installer), connecting through the mapped drive, elevated command prompt. It failed !!!! Error message seemed very familiar :(

    Ran vscollect - vslogs.cab is uploaded to skydrive, https://skydrive.live.com/#cid=E76491ADA626B7DD&id=E76491ADA626B7DD%21153. You will note there are three earlier versions of the cab file as well, 9/26, 9/26, and 10/03.

    Hope you can help ...

    Tuesday, October 9, 2012 12:01 AM
  • Hi Kerrie,  thanks for the logs.  The last set of logs show that you are failing on the following:

    "..Failed to install assembly 'C:\Windows\Microsoft.NET\Framework\v4.0.30319\Microsoft.VisualC.STLCLR.dll' because of system error: Access is denied..." 

    This could be due to a permissions issue on that folder or it can be due to what we wrote about here: http://blogs.msdn.com/b/vsnetsetup/archive/2011/09/27/ddset-error-failed-to-install-assembly-c-winnt-microsoft-net-framework-v2-0-50727-system-web-dll-because-of-system-error-access-is-denied.aspx

    Monday, October 15, 2012 8:16 PM
  • Hi Kevin,

    I checked permissions on that folder and sure enough there weren't any! So I gave full control to System and my user account. I also checked for GACLock.dat but it did not exist on my system.

    I cleaned out the %temp% directory, disabled AV, downloaded web installer and used Run As Administrator to install it. It failed again (sigh), although it did seem to run longer.

    Ran vscollect - vslogs.cab is uploaded to skydrive, https://skydrive.live.com/?cid=E76491ADA626B7DD&id=E76491ADA626B7DD%21153. The file is smaller this time than the others, so maybe we're making progress?

    Tuesday, October 16, 2012 3:22 AM
  • You are right it did progress a little further.  You are still hitting permission problems however as we can see in the log snip below:

    "..Error occurred while initializing fusion. Unable to load C:\Windows\Microsoft.NET\Framework\v4.0.30319\fusion.dll. System error: 5.."

    To tell which permissions are missing you can utilize a tool such as Procmon.exe (www.sysinternals.com) and analyze the results.  It is also possible to compare permissions on that folder with that of a working system.  Also note whether you are propagating the permissions to child items within that folder.

    Tuesday, October 16, 2012 8:00 PM
  • I changed permissions all through that folder (and child folder), ran the install again but it failed sooner. I would like to compare it to a working system but it will be next Thursday before I have access to one of those.
    Saturday, October 20, 2012 1:55 AM
  • Ok, I am checking versus a system that has .Net Framework 4.0 installed. On the C:\Windows\Microsoft.NET\Framework\v4.0.30319 directory permissions look the same with two exceptions:

    My user account has full control on my system. The user for the working system does not have access, although the local admins group does (and he is a local admin).

    The working system has read & execute, list folder contents, and read for the IIS_IUSRS account (not inherited). My system does not list that account.

    What else would you like me to check?

    Saturday, October 27, 2012 5:59 PM
  • Thanks Kerrie.  Did you also try using Procmon?  You can use this to help identify the user account and the resources it is trying to access.
    Wednesday, October 31, 2012 3:05 PM
  • I downloaded Procmon but did not "try to use it" because I can't figure out what to do with it primarily because the help file (chm) doesn't work. Running procmon shows hundreds of thousands of running processes before I even try running the .NET Framework installation and makes my machine painfully slow. :(

    Tuesday, November 6, 2012 10:36 PM
  • When Procmon is running perform your installation.  Once the installation fails you can hit the hot key CTRL-E to stop the file\registry monitoring.  Now that you have a capture of the activity during the install you can search for any Access Denied results. Use hot key CTRL-F and search for denied.  If you find a install process that is having a Access Denied you can bring up the properties dialog (right click process name) and look at the operation and user performing the operation.  This should give you the information about which account and action is taking place during the failure.  You can then take steps to correct the permission problems.

    Wednesday, November 7, 2012 3:25 PM
  • Hi Kelvin,

    I ran procmon. it appears that the network account did not have access to my %temp% folder, in particular the files that .NET Framework was trying to use. So I gave it permission to the entire folder (after clearing out the temporary files that were not currently in use). I ran the installation again, and it failed there again. There are 534 instances of "access denied", so I'm at a bit of a loss. I did save the filtered events in a 5MB logfile.pml file that I have put on my skydrive at https://skydrive.live.com/#cid=E76491ADA626B7DD&id=E76491ADA626B7DD%21153. Maybe you can make more sense of it than I can.

    I appreciate your help. It would be nice to get past this finally.

    Tuesday, November 13, 2012 6:59 AM
  • Thanks Kerrie for your efforts on this so far.  From the procmon logs we can see the process msiexec is using the user KerriePC\Kerrie to read "C:\Windows\Microsoft.NET\Framework64\v4.0.30319\Microsoft.VisualC.STLCLR.dll".  It fails with a access denied because it doesn't have read permissions.  This failure in the Procmon logs matches up with the failure point in the verbose install logs we saw earlier:

    "..Failed to install assembly 'C:\Windows\Microsoft.NET\Framework\v4.0.30319\Microsoft.VisualC.STLCLR.dll' because of system error: Access is denied..." 

    Can you please check again and confirm what permissions user Kerrie has to make sure that account has the read and other appropriate permissions. 

    Tuesday, November 13, 2012 4:12 PM
  • Well this is interesting. There is no Microsoft.VisualC.STLCLR.dll file in that folder. But I checked the permissions on the folder and the user KerriePC\Kerrie did not have any access. So I gave the user read access, ran the installation again, and it failed.

    Do you have a preference as to whether you want to look at a procman log or the install logs? Its hard giving access to files that don't exist :(

    Wednesday, November 14, 2012 2:34 AM
  • Hang in there Kerrie we are making great progress and at least know why the install is failing :)

    What is happening is we are performing a read request for that file in the location  C:\Windows\Microsoft.NET\Framework\v4.0.30319\ folder to see if the file exists and \or to make sure we can access that location. Because it didn't have permission to do this it failed with a access denied and failed your install.  It makes sense that the parent folder not having the correct permissions would cause this issue.  You have to make sure when setting permissions to also let the permissions propagate to child items as appropriate.

    Typically if a machine has permission problems on it the problem is not isolated to just one folder or file.  This means that there is a possibility of many other access denied errors for other objects on the machine.  Sometimes the permissions were changed inadvertently by a user but also they could have been modified by a system administrator with a policy or script.  If this is a machine that is administered by an admin you might want to also check with them to discuss any hardening policies they might be pushing out.

    Next steps would be to look in the verbose install log to see why we are failing.  If it is a access denied problem again we would use Procmon.exe to determine the permissions problem. 

    Wednesday, November 14, 2012 4:15 PM
  • OK, cleaned out %temp% folder, ran installation using Run As Admistrator, anti-virus disabled.

    vslogs.Cab is a bit smaller than last time (a good sign??), and at https://skydrive.live.com/#cid=E76491ADA626B7DD&id=E76491ADA626B7DD%21153. Let me know if I should run Procmon again.

    Tuesday, November 20, 2012 3:28 PM
  • Ok different folder has permissions issues now.  See below:

    Error 1303. The installer has insufficient privileges to access this directory: C:\Windows\Microsoft.NET\Framework64\v4.0.30319\ASP.NETWebAdminFiles\Security.  The installation cannot continue.  Log on as administrator or contact your system administrator.

    You can either compare permissions again with another machine or use procmon to determine the account trying to access that location. 

    Tuesday, November 20, 2012 7:01 PM
  • There isn't even a Security folder

    I went ahead and changed ownership on C:\Windows\Microsoft.NET\Framework64\v4.0.30319\ and everything below it.

    I ran installation again and OMG it worked! Only took 8 weeks ... Given that I've been the only one to use this system since it was installed and am an admin, I have no idea how it got so mucked up. ...

    Thank you!

    Wednesday, November 21, 2012 6:00 AM
  • Thanks Trevor. This helped me
    Tuesday, March 11, 2014 4:38 PM