locked
Unable to compile in Blend RRS feed

  • Question

  • I just started using Blend 3 a few days ago and love it, but just hit an error I don't understand that occurs whenever I try to build and test a very simple Silverlight 3 App + Website project. I had the project open in Blend and Visual Studio and put my computer into "Sleep" mode, but was forced to do a hard restart when my computer was unable to come out of sleep mode. Ever since then I have been able to compile and run the project in Visual Studio but not in Blend.

    Here is the error text when compiling:
    --------
    ASPNETCOMPILER : error ASPRUNTIME: The target directory is not empty, and does not appear to contain a previously compiled application. Please delete it manually, or choose a different target.
    --------

    Here is the build output text:
    --------
    Build project: EQDVisualControls.sln, Targets: Build
    __________________________________________________
    Project "C:\Users\User\Documents\Expression\Blend 3\Projects\EQDVisualControls\EQDVisualControls.sln" (Build target(s)):

    __________________________________________________
    Project "C:\Users\User\Documents\Expression\Blend 3\Projects\EQDVisualControls\EQDVisualControls.sln" is building "C:\Users\User\Documents\Expression\Blend 3\Projects\EQDVisualControls\EQDVisualControls\EQDVisualControls.csproj" (default targets):

    Begin application manifest generation
    No changes detected. Application manifest file is up to date
    Validating file names being packaged in the XAP
    EQDVisualControls -> C:\Users\User\Documents\Expression\Blend 3\Projects\EQDVisualControls\EQDVisualControls\Bin\Debug\EQDVisualControls.dll
    Begin Xap packaging
    No changes detected. Xap package is up to date
    Creating test page
    Test page created successfully
    C:\Windows\Microsoft.NET\Framework\v2.0.50727\aspnet_compiler.exe -v /EQDVisualControlsSite -p EQDVisualControlsSite\ -u -f -d PrecompiledWeb\EQDVisualControlsSite\
    ASPNETCOMPILER : error ASPRUNTIME: The target directory is not empty, and does not appear to contain a previously compiled application. Please delete it manually, or choose a different target.
    Done building project "EQDVisualControls.sln" -- FAILED.
    Build failed.
    ---------

    Any help appreciated!

    Sunday, March 7, 2010 1:36 AM

All replies

  • I'm not familiar with that particular error message, but I would try cleaning out the project directory manually like it suggests.  Visual Studio may be able to do that for you with the "clean solution" command.

    The other possibility (not likely since VS can build) is that you have the obj or bin directories checked into some sort of source control, or the files are marked as read only in some way.

    Either way, cleaning out the bin and obj directories (AFTER BACKING EVERYTHING UP!) should help.


    Monday, March 8, 2010 3:37 PM
    Moderator
  • I JUST  DELETED     BIN,DEBUG AND PRECOMPILED CHARPET (THESE DIRECTORIES WERE GENERATED WHEN U BUILD THE APP), AND OPEN THE SOLUTION ANOTHER TIME AND IT'S DONE.

    YOUR APP WILL BE RUN WITHOUT WARNINGS NEITHER ERRORS

     

     

    I HOPE THIS HELP TO U.

     

    Wednesday, August 11, 2010 1:02 AM