locked
sql express as witness hostname truncation RRS feed

  • Question

  • Not sure if this is relevant here but I thought someone might have seen this.

    I am trying to set up Express edition as a mirror witness and am running into a problem.

    It seems the express instance thinks its "Host Name"[1] is foo-prod-witnes rather than it's real name foo-prod-witness (notice the additional "s")

    When I try to create the security endpoints everything appearsd to work as far as connecting to the express instance but i cannot start the mirror because the address listed is

    TCP://foo-prod-witnes:5022 (not a valid hostname)

    My enterprise editions report foo-prod-sql01.fqdn:5022

    Any ideas how to fix this?

    1. As shown in the Host Name tab of the Configuration Manager
    Friday, June 22, 2007 2:32 PM

Answers

  • I re-installed the machine with 32bit 2003 and it seems to be working now.
    Friday, June 29, 2007 5:35 PM

All replies

  • what kind of domain are you on - 2000 or later?

     

    if it's 2000, i think this might have something to do with the netbios name limitation in 2000, which is up to 15 characters - http://support.microsoft.com/kb/226144.

     

    also, you should specify the fully qualified domain name or ip when connecting mirroring.

    Friday, June 22, 2007 4:58 PM
  • The domain is 2003 r2, I have tried to specify the fqdn when specifying the witness when setting up the endpoints but it seems to take the hostname from the express instance. Which thinks its name is the truncated name.

    I haven't tried doing this using tsql so perhaps that is the next step.

    Also, the primary/failover are enterprise x64 while the witness is express 32bit.

    I'm not sure if that makes a difference.
    Saturday, June 23, 2007 2:50 AM
  • I re-installed the machine with 32bit 2003 and it seems to be working now.
    Friday, June 29, 2007 5:35 PM