locked
Getting access denied error RRS feed

  • Question

  • Hi ,

    I am getting access denied error when tried to import or export data from another machine. ( right click on database in management studio , select tasks , select import or export) i was getting that error in the second screen of the wizard which asks to select the source system to copy from. Previously in this process i got error while sql initialization which comes after selecting source ,destination system and database tables selcetion. i have searched the net for the sollutoin and got a sollution mentioning to install the sql service pack 1. while installing i kept my server running , in the middle of installation what happend is a message box is diaplayed saying something and showed three options cancel,continue and try again. i mistakenly clicked on continue without stopping the server. after successfull installation of service pack i once again tried to import data from other system. the above mentioned error is giving in the second screen of the wizard at the place where to select the source system. i tried to system restore but updates of service pack does not reflected. hoping that some one may solve my problem.

    this is the message

     

          General access denied error


    ------------------------------
    Program Location:

       at Microsoft.SqlServer.Dts.Runtime.Wrapper.ApplicationClass.get_DBProviderInfos()
       at Microsoft.SqlServer.Dts.DtsWizard.DTSWizard.GetDtsDbProviderInfos(WizardInputs wizardInputs)
       at Microsoft.SqlServer.Dts.DtsWizard.DataSourceCombo.PopulateProviders(Boolean fSources, WizardInputs wizardInputs)
       at Microsoft.SqlServer.Dts.DtsWizard.Step1.OnInitializePage(EventArgs e)
       at Microsoft.SqlServer.Management.UI.WizardPage.RaiseEnterPage()
       at Microsoft.SqlServer.Management.UI.WizardForm.NextPage(WizardPage nextPage)
       at Microsoft.SqlServer.Management.UI.WizardForm.Next_Click(Object sender, EventArgs e)
        

    Monday, May 7, 2007 3:20 PM

All replies

  • I would try a fresh installation to make sure everything is in sync.

     

    Thanks.

    Tuesday, May 8, 2007 4:28 AM
  • other than re installation is there any other simple sollution. As general access denied error seems to be something related to the access restriction , is there any other way to solve it.

    Thanks

    Tuesday, May 8, 2007 11:20 AM
  • I would start by checking if the Wizard is having problems accessing the registry when it tries to get DBProviderInfos.  Try your repro again with RegMon tracing registry access by the Wizard to see if there are any permissions-related issues.
    Tuesday, May 8, 2007 5:24 PM