locked
Website aren't available RRS feed

  • Question

  • User-532505892 posted

    Hello Forum,

    i have set up a Windows Server 2019 Essentials with a IIS. Now i delivered a ASP.NET Core Webapp from my local PC to that Server via WebDeploy.

    Inside the Eventmanager i can see the Log: Application 'MACHINE/WEBROOT/APPHOST/SASCHAMANNS' started process '1084' successfully and is listening on port '4726'.

    I have set Bindings from that WebApp to my domain saschamanns.de (http, https)

    Now i sadly can't view http://localhost:4726 or http://saschamanns.de. 

    I'm getting the second case a 404, and for the first one just a blank page. The Firewall itself works (tested with portscanner).

    Now what can i do, to debug the error?

    Greetings

    Sascha

    Monday, March 25, 2019 3:51 PM

All replies

  • User690216013 posted

    localhost is strictly local, so you cannot use this link to access another machine.

    The domain name might not work if you didn't set up DNS.

    Monday, March 25, 2019 9:04 PM
  • User-532505892 posted

    Hello lextm,

    thank you for answering. I forgot to write that i tried this on the same Maschine, as the IIS runs. So localhost should work. Inside the domain DNS settings, the IP is set to the Server. The portscanner also found the target IIS,

    So i don't know exactly what the problem is...

    Greetings Sascha

    Monday, March 25, 2019 9:09 PM
  • User-2114649853 posted

    Hi saigkill

    According to your description, I suggest that you could remove all bindings of your sites and  check setting as below:

    Then I hope that you could run your .net core application on the local to find whether it has any problem. At last ,I hope you could post your .net core web application  configure files so that it will help me to solve your problem.

    Best Regards

    Able

    Tuesday, March 26, 2019 10:07 AM
  • User-532505892 posted

    Hi Able,

    thanks for answering. I already have set this stuff to my IIS. My deployed App is that one: https://dev.azure.com/saigkill/_git/SaigkillsBacktrace

    Maybe i have misconfigured anything?

    Greetings

    Sascha

    Tuesday, March 26, 2019 3:02 PM
  • User-2114649853 posted

    Hi saigkill,

      According to your description,did you install  .net core runtime for your .net core application? If you want to host the .net core web application  on IIS , you should download sdk to provide environment for application. If you have downloaded this ,when you publish it on iis you could see these codes in web.config file.I suggest you could check it.

    <handlers>
            <add name="aspNetCore" path="*" verb="*" modules="AspNetCoreModule" resourceType="Unspecified" />
          </handlers>

    Here is the link to download SDK, I hope it could help you.  

    https://dotnet.microsoft.com/download/thank-you/dotnet-runtime-2.2.3-windows-hosting-bundle-installer

    Then here is link for how to host .net core application on IIS .You could follow the steps in the doc.

    https://docs.microsoft.com/en-us/aspnet/core/host-and-deploy/iis/?view=aspnetcore-2.2

    By the way, do you host your application directly on Azure DevOps?If so , could you please tell me how to host your application on this platform?

    Best Regards

    Able

    Wednesday, March 27, 2019 8:04 AM
  • User690216013 posted

    thank you for answering. I forgot to write that i tried this on the same Maschine, as the IIS runs. So localhost should work. Inside the domain DNS settings, the IP is set to the Server. The portscanner also found the target IIS,

    If that's the way you configured DNS settings are OK, move on and verify Windows Firewall settings, as you are now trying to make "The Internal Client" work,

    https://blog.lextudio.com/self-hosting-series-why-cannot-my-web-server-iis-be-reached-from-anywhere-else-8da0e0b252ef 

    Wednesday, March 27, 2019 2:23 PM
  • User-532505892 posted

    Hi Able,

    thanks for answering. Sorry for my delay.

    The web.config file meets your proposal. I re-installed the hosting bundle for my 2.1.4 app. (It's planned to upgrade it to 3.x soon). I rechecked the doc. But as far as i can see, it meets the requirements.

    To answer your question. The app was originally hosted on Azure. Now it is moved to a local NAS.

    Maybe to clarify my setup.

    saschamanns.de points to saigkill.ddns.net (because i'm using a private phone account, i just have a dynamic ip. This is solved through saigkill.ddns.net.)

    My Windows Server 2019 runs as virtual machine on a NAS. On the server runs the IIS and also a updater for saigkill.ddns.net. So saigkill.ddns.net points to the current IP for my Server.

    The Router is configured to route incoming stuff from 80/443 to the Servers IP.

    Greetings

    Sascha

    Thursday, March 28, 2019 8:26 PM
  • User-848649084 posted

    Hi Sascha,

    According to your description<g class="gr_ gr_14 gr-alert gr_gramm gr_inline_cards gr_run_anim Style replaceWithoutSep" id="14" data-gr-id="14">,I</g> suggest that you could check whether 4726 port in your computer is closed or not. I doubt that the port in your machine is not open. To check port, you could enter <g class="gr_ gr_9 gr-alert gr_spell gr_inline_cards gr_run_anim ContextualSpelling" id="9" data-gr-id="9">netstat</g> -a -<g class="gr_ gr_8 gr-alert gr_spell gr_inline_cards gr_run_anim ContextualSpelling ins-del" id="8" data-gr-id="8">n in</g> command. Then if the firewall is blocking them, you could start windows firewall logging and check the logs for dropped connections. You could follow the steps <g class="gr_ gr_12 gr-alert gr_gramm gr_inline_cards gr_run_anim Grammar replaceWithoutSep" id="12" data-gr-id="12">as</g> below:

    https://serverfault.com/questions/26564/how-to-check-if-a-port-is-blocked-on-a-windows-machine

    Regards,

    Jalpa.

    Friday, March 29, 2019 9:37 AM
  • User-532505892 posted

    Hi Jalpa,

    thanks for answering.

    In general it looks like the port where it published on localhost changes from time to time.

    The last Log i've seen is: "Application 'MACHINE/WEBROOT/APPHOST/SASCHAMANNS' with physical root 'C:\inetpub\wwwroot\saschamanns\' shut down process with Id '6292' listening on port '27473'"

    That entry was from 2019-03-26. And since that date no new process comes up. But this is strange, because since i posted my initial post there, i haven't changed anything on the maschine.

    Greetings

    Sascha

    Saturday, March 30, 2019 1:12 PM
  • User-848649084 posted

    Hi,

    According to your description, so, It's obvious that you couldn't see your application by using localhost: 4726 because <g class="gr_ gr_20 gr-alert gr_gramm gr_inline_cards gr_run_anim Grammar only-ins replaceWithoutSep" id="20" data-gr-id="20">port</g> has already changed. So I suggest you could firstly use <g class="gr_ gr_17 gr-alert gr_spell gr_inline_cards gr_run_anim ContextualSpelling" id="17" data-gr-id="17">netstat</g> -a -<g class="gr_ gr_15 gr-alert gr_spell gr_inline_cards gr_disable_anim_appear ContextualSpelling ins-del" id="15" data-gr-id="15">n -o</g> in Command Prompt to find PID which port is <g class="gr_ gr_25 gr-alert gr_gramm gr_inline_cards gr_run_anim Style multiReplace" id="25" data-gr-id="25">4726 ,</g> then you could use task manager find the <g class="gr_ gr_16 gr-alert gr_spell gr_inline_cards gr_run_anim ContextualSpelling ins-del multiReplace" id="16" data-gr-id="16">porcess</g> which has PID you just <g class="gr_ gr_14 gr-alert gr_spell gr_inline_cards gr_disable_anim_appear ContextualSpelling ins-del" id="14" data-gr-id="14">find</g><g class="gr_ gr_24 gr-alert gr_gramm gr_inline_cards gr_run_anim Style replaceWithoutSep" id="24" data-gr-id="24">.<g class="gr_ gr_21 gr-alert gr_gramm gr_inline_cards gr_run_anim Punctuation only-ins replaceWithoutSep" id="21" data-gr-id="21">lastly</g></g> I hope you could remove the program which is used port <g class="gr_ gr_22 gr-alert gr_gramm gr_inline_cards gr_run_anim Punctuation only-del replaceWithoutSep" id="22" data-gr-id="22">4726,</g> so that you could free the port.
    You could see as below:

    Monday, April 1, 2019 9:20 AM