locked
How to Remove the Outlining Margin RRS feed

  • Question

  • How do I remove the outlining margin in the VS2012 text editor? I don't want to just disable outlining, I want to get rid of the entire margin area on the left side of the screen. If you can't get rid of the margin, is there a way to change the margin color?
    Tuesday, July 23, 2013 5:16 PM

Answers

  • Hi SqlDan, I check my VS2012 and others' and all shows same to yours and maybe it makes you not feel so fine but I have to tell you that it should be by design. Thanks for your posting in MSDN here.

    However, if you remains want to change such a design,could you please submit the feature request here :User Voice. Thanks!


    Sophia Gou
    MSDN Community Support | Feedback to us
    Develop and promote your apps in Windows Store
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Friday, July 26, 2013 12:57 PM

All replies

  • Hi SrqDan,

    Thank you for posting in the MSDN forum!

    We can use the shortcuts(CTRL + M, CTRL + P) to remove all outlining information for the entire document.

    Please have a try for your requirement. Thanks!

    As for more detail info,please refer here:Stop Outlining-Outlining


    Sophia Gou
    MSDN Community Support | Feedback to us
    Develop and promote your apps in Windows Store
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.


    Wednesday, July 24, 2013 6:57 AM
  • Sophia,

    Thanks for your response. The CTRL-M, CTRL-P sequence does remove outlining, but it does not remove the outlining margin. When outlining is removed, it has the same background color as the text editor, so it appears as if there is more whitespace than is actually there. If the outlining margin can not be removed, is there a way to change its color?

    In VS2005, unchecking the "Selection Margin" option in Options->Text Editor->General actually removes the outlining margin. This is not the case in VS2012, but maybe it should be (i.e. it's a bug)??

    Thanks, Dan

    Wednesday, July 24, 2013 11:49 AM
  • Sorry for my misunderstanding.But I can turn it off using below two ways and feel good.

    1. Hit CTRL + M, CTRL + P on your keyboard
    2. Go to Edit -> Outlining -> Stop Outlining on your Menu Bar

    Could you please share me the screenshot of yours?

    Here shares an article for you ,please review :change the margins of an object.

    Hope it can help you!


    Sophia Gou
    MSDN Community Support | Feedback to us
    Develop and promote your apps in Windows Store
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Thursday, July 25, 2013 3:02 AM
  • Sophia,

    Both of your suggestions turn off outlining, but do not get rid of the outlining margin. See the picture below. There is one column of whitespace to the left of the code and to the right of the indicator margin (the grey column). This looks like I have indented all of my code by one space even though that is not the case.

    Thanks, Dan

    Thursday, July 25, 2013 11:21 AM
  • Hi SqlDan, I check my VS2012 and others' and all shows same to yours and maybe it makes you not feel so fine but I have to tell you that it should be by design. Thanks for your posting in MSDN here.

    However, if you remains want to change such a design,could you please submit the feature request here :User Voice. Thanks!


    Sophia Gou
    MSDN Community Support | Feedback to us
    Develop and promote your apps in Windows Store
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Friday, July 26, 2013 12:57 PM