locked
MFTrace bug? RRS feed

  • Question

  • I am trying to use the MFTrace tool to get an idea of what my loaded topology looks like.  I intend to use a hardware H.264 encoder available on my machine. The application runs fine in the debugger and normally from Explorer, with the hardware encoder working its magic.  However, when I run my application under MFTrace, I run into an Access Violation exception.  It appears that this happens when I try to resolve a partial topology created by MFCreateTranscodeTopology with IMFTopoLoader::Load.  The part of the trace that is logged before the exception shows a call to ActivateObject and subsequently MFGetMFTMerit.

    I tried isolating the exception and found that I could cause it to happen when I simply enumerate the hardware encoder and try to activate it.  Same trace output.

    It seems to me that there may be a bug in how MFTrace hooks itself into all the MF libraries.  Or could there be something wrong with the hardware encoder - I am using Intel's QuickSync H.264 encoder provided with Sandy Bridge chips (on a Core i7 3rd gen processor)?

    Wednesday, April 17, 2013 2:31 PM

All replies

  • I doubt this has much to do with Visual Studio.  I have the same problem running MFTrace outside of the debugging environment.  Without MFTrace attached, hardware pieces are picked up and work fine.  With it, I get the Access Violation exception.
    Monday, May 6, 2013 8:27 PM