locked
No such interface supported - running windows mobile phone application RRS feed

  • Question

  • I open sample project, build goes OK.
    When i try to run it (or just deploy it) i get error "No such interface supported" and project does not strat.

    It was working ok a day ago, i had to install VS 2008 since and this is my suspect No1.

    Any ideas? Thank you.

    Running on Windows 7.


    Grei
    Wednesday, November 17, 2010 3:24 PM

Answers

  • Check the version of the .Net Framework that your application is using:

    Project->Properties->Application tab->Target Framework: pulldown.

    Also, run a repair on .Net Framework 4 if that doesn't work.

    • Marked as answer by Andrew_Zhu Wednesday, November 24, 2010 7:30 AM
    Wednesday, November 17, 2010 10:14 PM

All replies

  • Check the version of the .Net Framework that your application is using:

    Project->Properties->Application tab->Target Framework: pulldown.

    Also, run a repair on .Net Framework 4 if that doesn't work.

    • Marked as answer by Andrew_Zhu Wednesday, November 24, 2010 7:30 AM
    Wednesday, November 17, 2010 10:14 PM
  • I'm having the same problem as listed above. No matter if I try to use, the emulator or actual WM device, I get this "no such interface supported" error. It happens every time I try to debug any new solution.  I've reinstalled VS 2008 Pro twice, reinstalled .Net framework 4 twice, and ran every other update I've been able find. I could really use some help to get past this error.

    THANKS!

    Saturday, January 22, 2011 12:25 AM
  • getting the same error w/ visual studio 2010 for wp. how to fix it and fast please.
    Monday, August 22, 2011 1:25 PM
  • Hi,

     

    You posted this in a Windows Workflow forum, so we don't have the expertise here to answer you.  Please ask this over at http://forums.create.msdn.com/forums/default.aspx?GroupID=19 so that you will reach a more relevant set of experts and you can get an answer to your question.

    Ed


    Ed Hickey http://blogs.msdn.com/b/edhickey/archive/2010/04/21/how-to-post-effectively-in-forums.aspx
    Monday, August 22, 2011 2:44 PM
  • ok. for some reason, I thought this was "forums.create."  

    Monday, August 22, 2011 3:14 PM