locked
Designer mashed objects RRS feed

  • Question

  • Kind of a vague title to the question I know, but I'm not sure how to categorize it. I run into this occasionally where I'll open a view and it literally just mashes all the objects into the left corner and loses all sense of layout. Would love to know what causes it, more importantly how to resolve it. Didn't find any good answers in a web search. Could it be something to do with the references to some of the toolkit items not being found or something? Any insight welcome, thanks.

    Image of the behavior to hopefully provide some further explanation of what I'm talking about. I get TargetType Mismatch errors on like toolkit and telerik items but everything builds fine at runtime?


    Please mark answers as helpful when used, and answered when completed.


    Tuesday, April 10, 2012 2:49 PM

All replies

  • This is speculation, but I would guess that an exception was thrown during the layout pass of the container panel, causing everything to be at 0,0. If you ever have a specific repro we'd be happy to take a look at it. 
    Tuesday, April 10, 2012 2:55 PM
    Moderator
  • Ya I haven't found a specific way to reproduce it, it's annoying because it will load in the VS designer, but pukes in blend. Except luckily I'm used to gutting what my dev's hand me to re-do the front end of anyway so we'll see what happens after I've butchered it. :)

    Please mark answers as helpful when used, and answered when completed.

    Tuesday, April 10, 2012 4:37 PM