locked
tabbled menu list items not showing after websecurity authentication RRS feed

  • Question

  • User1835582789 posted

    I have this code in my _SiteLayout.cshtml

    </div>
                        
                            <ul id="menu" class="tabbedMenu">
                                <li><a href="~/Public/PublicSearch.cshtml">Home</a></li>
                                <li><a href="~/Public/About.cshtml">About</a></li>
                                <li><a href="~/Public/Contact.cshtml">Contact</a></li>
                                @if (WebSecurity.IsAuthenticated) {
                                   <li><a href="~/Backend/Entity/EntitiesList.cshtml">Entities</a></li>
                                    <li><a href="~/Backend/Event/EventsList.cshtml">Events</a></li>
                                    <li><a href="~/Backend/Venue/VenuesList.cshtml">Venues</a></li>
                                    <li><a href="~/Backend/Admin/SystemAdmin.cshtml">System</a></li>
                                    <li><a href="~/Account/Manage.cshtml">Users</a></li> 
                                }
                                
                            </ul>
                        
                        </div>

    After I login successfully using WebSecurity, my additional tabs should show but they are not. Anything I should check?

    Saturday, January 24, 2015 10:57 AM

Answers

  • User-735851359 posted

    Hello,

    Do you have similar code in your _AppStart.cshtml file?

        WebSecurity.InitializeDatabaseConnection("db", "UserProfile", "UserID", "Email", true);

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Saturday, January 24, 2015 2:29 PM
  • User-735851359 posted

    I think everything is with this code (except divs..)

    try to remove

    class="tabbedMenu"

    and check again.

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Sunday, February 1, 2015 3:34 PM

All replies

  • User1835582789 posted

    It seems that all code using WebSecurity.IsAuthenticated is no longer working in the entire site

    Saturday, January 24, 2015 11:16 AM
  • User-735851359 posted

    Hello,

    Do you have similar code in your _AppStart.cshtml file?

        WebSecurity.InitializeDatabaseConnection("db", "UserProfile", "UserID", "Email", true);

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Saturday, January 24, 2015 2:29 PM
  • User1835582789 posted

    Thanks for responding.

    I do have that code in my _AppStart.cshtml page

    Saturday, January 24, 2015 2:46 PM
  • User-735851359 posted

    Mark as answer if it helped..

    Saturday, January 31, 2015 12:19 PM
  • User1835582789 posted

    It did not help because I already had that code.

    Saturday, January 31, 2015 1:56 PM
  • User-735851359 posted

    I think everything is with this code (except divs..)

    try to remove

    class="tabbedMenu"

    and check again.

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Sunday, February 1, 2015 3:34 PM