none
Workflow Manager with SharePoint RRS feed

  • Question

  • Hi,

    I've configured WF Manager in SharePoint but I can't make it working. Everytime I run the WF, it's get cancelled with message like below:

    RequestorId: 815a0350-8160-702f-824f-b8f03079f9fb.
    Details: System.ApplicationException: HTTP 401 {"x-ms-diagnostics":["3000006;
    reason=\"Token contains invalid signature.\";category=\"invalid_client\""],
    "SPRequestGuid":["815a0350-8160-702f-824f-b8f03079f9fb"],
    "request-id":["815a0350-8160-702f-824f-b8f03079f9fb"],
    "X-FRAME-OPTIONS":["SAMEORIGIN"],
    "SPRequestDuration":["1"],"SPIisLatency":["0"],"Server":["Microsoft-IIS\/7.5"],
    {"error_description":"Invalid JWT token. Could not resolve issuer token."}
    at Microsoft.Activities.Hosting.Runtime.Subroutine.SubroutineChild.Execute(CodeActivityContext


    I think I've followed all best practices I need to follow, like I'm not using system account for running workflow, I've setup proper db permission, I've enabled SQL Browser service at db server, all WF services are running in the server. I've also checked the trace log as described in the link: http://technet.microsoft.com/en-us/library/jj193526.aspx.But not found anything that might be helpful. Can anybody suggest?


    Thanks,
    Sohel Rana
    http://ranaictiu-technicalblog.blogspot.com


    • Edited by Sohel Rana Thursday, January 31, 2013 7:57 AM
    Thursday, January 31, 2013 7:26 AM

All replies

  • Are you authoring the Workflows using SPD or VS?  Can you build the Workflow project but can't execute it?  You may need to a user that has been allowed to execute/run Workflows.  Try running the Workflow as the site collection admin.
    Thursday, February 28, 2013 12:38 AM
  • Hi,

    It was SPD worfklow. I had been running the workflow using site collection administrator but not the system account. I had finally fixed by reinstalling SharePoint/workflow manager.


    Thanks,
    Sohel Rana
    http://ranaictiu-technicalblog.blogspot.com

    Thursday, February 28, 2013 3:40 AM