none
How to get TA1 in edi format not xml RRS feed

  • Question

  • Hi, Helpers,

    I created a send port to subscirbe the TA1s acknowledgement. If I use passthruTransmit pipeline, no problem, I can get TA1s xml. But I need TA1s Edi files, when I change the pipeline to Edisend, I keep getting errors : "message type root is not part of agreement". Do you know what happening? and how to fix it?

    Thanks for your time and help.

    R Z

    Tuesday, September 17, 2013 3:55 PM

Answers

  • David,

    This is what I got these days. If I changed "Transaction set list" to "Exclude" under the agreement settings, delete all of the edi type from the ST01 list, then I can get the TA1 in edi format. But previously we were using "support" setting with EDI type 834 in ST01 list, in this situation, I keep getting the errors "message type root is not part of agreement". So I think here I also need choose TA1 message type, but when I reveiw the ST01 list, which is from Edi 100 to EDI 999, I can not find EDI TA1 type. I think this is reason. So I am wondering do you know the EDI TA1's message type? or Transaction set number?

    Thanks for your time and help.

    R.Z

    • Marked as answer by R.Zi Friday, September 20, 2013 6:27 PM
    Thursday, September 19, 2013 2:32 PM
  • David,

    First, thanks for your help. What you answered is not the point. The problem is EDIsend can not assemble xml TA1 to edi TA1 if I check "Support" in "Transaction set list" under the agreement settings.

    Secondly, the case is opposite way as yours. I need send TA1 back to my partner as the result I received their EDI files. That means I need create a additional send port to subscribe the TA1, but I can only get TA1 xml out with passthruTransmit. If I want to get TA1 edi out with EDISend pipeline, I keep getting that errors. Sure, I have already added the send port to the agreement.

    For the ways you suggest, I am pretty sure that can be working, because it is used to process receiving EDI files.

    Actually, after checking for these days from online, I found this issue looks like unresolvable, but I am still wondering whether anybody has worked on the same issue before and whether fix it. Anyway, Thank you for your help and time. Really appreciate it.

    R.Z

    • Marked as answer by R.Zi Friday, September 20, 2013 6:27 PM
    Friday, September 20, 2013 2:56 PM

All replies

  • From the description of your error, it seems you need to include the TA1 as part of your agreement to allow the EDI pipeline to be selected.  See the following: http://msdn.microsoft.com/en-us/library/bb226319(v=bts.10).aspx


    David Downing... If this answers your question, please Mark as the Answer. If this post is helpful, please vote as helpful.

    Tuesday, September 17, 2013 8:16 PM
  • Hi David

     I did. Checked the "TA1 Expected " under the parties--> agreement-->acknowledgement. That's why I feel so confused.

    Thanks

    R.Z

    Tuesday, September 17, 2013 8:46 PM
  • Make sure you checked the "TA1 Expected" flag for both parties and the host instances have been restarted.

    One other question, does your application where you created the send port include a reference to the "BizTalk EDI Application" application?  Just in case you created it in a different application.


    David Downing... If this answers your question, please Mark as the Answer. If this post is helpful, please vote as helpful.

    Thursday, September 19, 2013 2:15 PM
  • David,

    This is what I got these days. If I changed "Transaction set list" to "Exclude" under the agreement settings, delete all of the edi type from the ST01 list, then I can get the TA1 in edi format. But previously we were using "support" setting with EDI type 834 in ST01 list, in this situation, I keep getting the errors "message type root is not part of agreement". So I think here I also need choose TA1 message type, but when I reveiw the ST01 list, which is from Edi 100 to EDI 999, I can not find EDI TA1 type. I think this is reason. So I am wondering do you know the EDI TA1's message type? or Transaction set number?

    Thanks for your time and help.

    R.Z

    • Marked as answer by R.Zi Friday, September 20, 2013 6:27 PM
    Thursday, September 19, 2013 2:32 PM
  • I believe the EDI X12 TA1 message type is: http://schemas.microsoft.com/Edi/X12#X12_TA1_Root


    David Downing... If this answers your question, please Mark as the Answer. If this post is helpful, please vote as helpful.

    Thursday, September 19, 2013 7:40 PM
  • I mean how to set it in "Transaction set list" under the agreement settings if I do not want to use "Exclude". Which one I should choose from the drop down list if I check "Support".

    Thanks

    R.Z

    Thursday, September 19, 2013 7:47 PM
  • R.Z

    Can you confirm the following:

    1. You are receiving TA1 acknowledgements as the result of EDI interchanges you sent to your partner and want to process them through both the EDI receive pipeline as well as send them in raw format to an alternate location.  Is that correct?
    2. What transport adapter are you using to send your EDI interchanges?

    If this is the case, you may be able to try:

    1. Create an additional receive port (TA1 Raw Receive Port) and pass-through receive location to receive the TA1 responses.
    2. Create an additional send port that filters on the receive port above (TA1 Raw Receive Port) and sends to the BizTalk EDI receive location that uses the EDI receive pipeline for EDI processing (new receive URI).
    3. Use your other existing send port with the same filter (TA1 Raw Receive Port) and pass-through send pipeline for the raw TA1 content.

    Basically by receiving the raw format, creating multiple subscribers for the raw content (send ports) and directing the raw content to two locations, you should be able to accomplish your goal.

    Let me know if you need clarification.


    David Downing... If this answers your question, please Mark as the Answer. If this post is helpful, please vote as helpful.

    Thursday, September 19, 2013 9:36 PM
  • David,

    First, thanks for your help. What you answered is not the point. The problem is EDIsend can not assemble xml TA1 to edi TA1 if I check "Support" in "Transaction set list" under the agreement settings.

    Secondly, the case is opposite way as yours. I need send TA1 back to my partner as the result I received their EDI files. That means I need create a additional send port to subscribe the TA1, but I can only get TA1 xml out with passthruTransmit. If I want to get TA1 edi out with EDISend pipeline, I keep getting that errors. Sure, I have already added the send port to the agreement.

    For the ways you suggest, I am pretty sure that can be working, because it is used to process receiving EDI files.

    Actually, after checking for these days from online, I found this issue looks like unresolvable, but I am still wondering whether anybody has worked on the same issue before and whether fix it. Anyway, Thank you for your help and time. Really appreciate it.

    R.Z

    • Marked as answer by R.Zi Friday, September 20, 2013 6:27 PM
    Friday, September 20, 2013 2:56 PM
  • Responding with a TA1 acknowledgement is pretty standard in terms of EDI processing.  It's possible that there is a bug in the BizTalk EDI processing?  You should consider contacting your Microsoft representative.

    David Downing... If this answers your question, please Mark as the Answer. If this post is helpful, please vote as helpful.

    Friday, September 20, 2013 3:27 PM
  • Just a question of procedure, do you really need the SupportTransaction list on the You->Them side?

    I can't remember an instance where I've had that anything but blank.

    Friday, September 20, 2013 4:00 PM
  • Hi Boatseller,

    Not have to. Actually, after I found this, my issue has already gone. I am just wondering whether anybody has worked on the same issue before and whether there is another way I do not know to fix this issue. Thanks for your time.

    Sincerely

    R.Z

    Friday, September 20, 2013 6:24 PM
  • David,

    I will try to contact Microsoft representative for it. Thanks for your help and time. Really appreciate it.

    Sincerely

    R.Z

    Friday, September 20, 2013 6:26 PM
  • One other thought; did you specify all X12 related send ports in the agreement(s)?

    David Downing... If this answers your question, please Mark as the Answer. If this post is helpful, please vote as helpful.

    Friday, September 20, 2013 6:28 PM
  • So, you removed the Support/Exclude from the You->Them tab and that solved your problem.

    In that respect, the Agreement editor is a little wonky, there's no reason to have that option on outbound Agreements.  There's really no way to randomly create outbound transactions ;)

    Friday, September 20, 2013 6:49 PM
  • David,

    Yes. I did. And I also tried enable and disable fallback agreement. The only way I can get success is that select the "exclude".

    Sincerely

    R.Z

    Friday, September 20, 2013 7:19 PM